Preset names?

Feb 3, 2012 at 10:15am

Preset names?

I’ve managed to add a preset section to my patch that works fine – is there any way I can add an object to store preset names instead of just working with the tiny buttons?

Thanks!

#61593
Feb 3, 2012 at 12:13pm

there`s an example in the pattrstorage help file, in the interface tab (max6).
and here is another solution i`ve found in the forum yesterday:

– Pasted Max Patch, click to expand. –
#222297
Feb 3, 2012 at 12:15pm

+ in the patch i`m currently workin on i managed that with jit.cellblock and dict.
if you`re not satisfied with the solutions mentioned in the last post i can send you an example of this

#222298
Feb 3, 2012 at 1:47pm

Also, know that a preset object linked to a pattrstorage object will display the “slotname” of the corresponding pattrstorage slot, if one exists. I don’t think this is documented anywhere?

#222299
Feb 4, 2012 at 10:59am

Ah, thanks all – this looks promising! Any way I can use this patch with the ‘preset’ object? – my device is already based around it.

#222300
Feb 4, 2012 at 11:19am

where’s the problem? just use one slot. store slot, write preset with your name.
then load preset with your name and recall slot automatically.
tell me if you need a patch that makes clear how it works..
O.

#222301
Feb 7, 2012 at 11:09pm

Hi 11olsen, sorry I missed your reply – yeah would be great if you could sketch something out for me, I’m a total noob at getting this working!

#222302
Feb 8, 2012 at 11:53am

Here you are. i just did a quicktest but i used this kind of system in many other situations successfully. fire the loadbang at first..
O.

– Pasted Max Patch, click to expand. –
#222303
Feb 8, 2012 at 12:31pm

Awesome, thanks mate – I’ll check this out tonight.

#222304
Feb 9, 2012 at 9:51pm

Right, this is great, but I’m not sure how to integrate it into my current patch – is it possible to just save presets without naming them? All I really want to do is add a name box to my current presets system…

I attach my current setup below – I guess I should have posted it at the start – Doh! :P

What I’m aiming for is something like the average preset manager you get on a synth – a drop-down list of say 128 presets, with a label box and a save button.. (plus maybe a ‘save as file’ button ;)

#222305
Feb 9, 2012 at 9:53pm

Damn, can’t attach the patch! Trying as text file here..

Attachments:
  1. patch.txt
#222306
Feb 9, 2012 at 10:26pm

What about something like that :

– Pasted Max Patch, click to expand. –

edit : re-uploaded the patch. tosymbol needed.

#222307
Feb 9, 2012 at 10:59pm

maybe like that, simply a coll with name references. you would only have to think about how you save the name-coll.
O.

– Pasted Max Patch, click to expand. –
#222308
Feb 10, 2012 at 12:36am

Ah, that’s pretty cool! It would be great if I could scroll thru somehow and see the tags of the presets – is this possible?

Also is it possible to still integrate my current Load / Save preset system?

Many thanks.

#222309
Feb 10, 2012 at 2:57am

here it is with a added menu to select saved named and unnamed (in case you replied to my thing above)
O.

– Pasted Max Patch, click to expand. –
#222310
Feb 10, 2012 at 9:06am

Wow, that is brilliant! Thanks so much! Love this forum :)

#222311
Feb 10, 2012 at 10:30am

Something like this really ought to be in the patch library or optionally added to any Max device – so useful!

#222312
Feb 10, 2012 at 2:58pm

the recalling from the umenu wasn’t correct. now it should be fine. and i added your original save/load system and changed it so now a second file with the names is saved/loaded when you save/load a preset.
you really have to be careful because every ui object is included. i tend to connect only objects i want to have included.
you can use [pvar] instead of connecting your [preset] with all objects with lines across the patch.
actually i don’t use [preset] anymore. build your own with a coll or pattr and it won’t have limits like no access to subpatchers and so on.
I’m happy to help and have a nice weekend.
O.

– Pasted Max Patch, click to expand. –
#222313
Feb 11, 2012 at 12:32am

Wow, ok thanks I will check this out!

Have a great weekend too! Like I said, I don’t know why something like this is not included with Max, Reaktor for instance has a very good preset system built right in.

I don’t mind that everything gets captured by the preset device – that’s what I’m going for. Is there any easy way to add a ‘save bank’ function to it as well? ;)

#222314
Feb 11, 2012 at 12:43am

Q1: because it is more fun to build it yourself exactly how you need it ;)
Q2: if you mean the complete bank of presets, that is what i was talking about in my last post. for some reason i wrote “when you save/load a preset” but i meant preset bank, but you’ll see that anyway when you look at the patch. i’m out
O.

#222315
Feb 12, 2012 at 12:57am

Alright, cheers for the clarification! All working perfectly – Now to figure out my next problem :)

#222316
Feb 12, 2012 at 2:11am

Oops – I’ve added it to my step sequencer now, and something weird is going on – when I recall a scene on the odd-numbered sequences – 1 or 3, the loop length gets set to 1 x 16th and I can’t get it to go back to normal! … strange.

`

– Pasted Max Patch, click to expand. –
#222317
Feb 12, 2012 at 2:15pm

have you ever looked at the output of your live.step when you load a preset. it’s completely outputting the state of all 4 sequences but you’re not using this to update your ui-utility bpatcher (which is buggy anyway). i think i will take a look later that day and send you something back. but this is really basic, and you have to be able to hunt down bugs like this for yourself if you want to learn something.
O.

#222318
Feb 12, 2012 at 6:39pm

Hmm I’m not really sure what you mean – I’ve just collaged this sequencer together from the basic Max one plus a few other bits!

#222319
Feb 12, 2012 at 6:53pm

Ok well I think I’ve cleared up that problem – the source was a previous mystery where I couldn’t get the ‘sequence length’ parameter to work, but I’ve made it visible in the presentation now and it (mostly) seems to be working fine.

Still not sure what you mean by “completely outputting the state of all 4 sequences but you’re not using this to update your ui-utility bpatcher”

The ui patcher is not wired up properly cos it was lifted from another project and some parts not needed.

I include the latest version anyhow, any comments welcome:

– Pasted Max Patch, click to expand. –
#222320
Feb 12, 2012 at 6:55pm

test

#222321
Feb 12, 2012 at 6:56pm

i cannot post the patch somehow. i tried several times

#222322
Feb 12, 2012 at 6:58pm

take a look..
O.

Attachments:
  1. patch.txt
#222323
Feb 12, 2012 at 8:48pm

Wow, this is brilliant – you have a real talent for this! Reckon this device is just about perfect for the purpose now :)

Re. posting the patch – it’s weird, I had the same thing happen to the other day, some kind of board error.

If you have a minute I’d be much obliged if you could help with this scene launching patch I’ve been trying to make!

http://cycling74.com/forums/topic.php?id=38036

Cheers!

Bill.

#222324
Feb 12, 2012 at 11:57pm

OK now moved to here … I’m getting somewhere with this, just stumbling on some regexp problems now: http://cycling74.com/forums/topic.php?id=38050#post-185112

#222325
Feb 14, 2012 at 10:59pm

HI 11olsen – I’m having trouble with this saving thing – it doesn’t seem to be working right now I’m using it with the step-sequencer patch in my set.

All seemed fine until I saved and reload the Ableton set – nothing got saved in the preset bank!

… on further testing it seems that it isn’t working even with just the ‘preset’ system on its own – weird as it seemed to be ok the other day.

I attach a copy of the preset-saver you created above, with just a fader added for testing. I can’t get it to save / recall bank or retain any info on restarting the project.

– Pasted Max Patch, click to expand. –
#222326
Feb 15, 2012 at 1:11am

i assume you know that it is only recalling the last bank if you’ve saved the bank before. you did send me the older example. i just tested what i posted as text file as a m4l device and it’s recalling fine when i load the set again. ??

#222327
Feb 15, 2012 at 10:19am

Ok this is weird – I’m pretty sure my patch above is just your text file with a fader added. I’ll do some more testing, thanks.

#222328
Feb 15, 2012 at 1:23pm

Really strange. Just tried it with the patch you send as text – made a few presets, saved the ‘bank’, restarted the set – nothing there!

#222329
Feb 15, 2012 at 1:49pm

can you load a preset bank with the load button in the device? if yes something goes wrong when you load the set. you have to isolate the problem, or what are you doing when you say “i’ll do some more testing”?
and you should try to save with the normal .maxpresets file extension. the last entry in the textedit shows that you tried to save a file just called “test” without any extension. are you on mac or pc?
and you should check the forum more often, i get a mail if you post here and most of the time i reply really fast. but you’re replying once a day maximum and i want to bring that to an end swloly but surely. that nobody else chimes in or replies to your other thread shows that your problems are trivial and not very interessting. normally specific problems are discussed here and not many people will guide you through the complete creation of your first m4l devices. so get cracking.
O.

#222330
Feb 15, 2012 at 2:29pm

Hmm thanks for the advice. No I can’t load the preset with the load button. I’m on PC, so it appends the .maxpresets by default.

Yeah, I’m aware I’m a total noob with this software, I’m just trying to hack something together that’ll work for now.. would love to do a course on Max and learn it properly, but I’ve got a 6 month year old son now, work etc etc!

#222331
Feb 15, 2012 at 2:55pm

just do a build-in tutorial from time to time. the help patches are essential to learn.
i don’t know what else to try, really weird that the exactly same patch works flawlessly on my end. try just creating a preset object and see if you can get it to write and read properly.
O.

#222332
Feb 15, 2012 at 3:13pm

Ok, I think you actually got it with the .maxpresets thing! (shameface) … it seems to be working fine now! (tail between legs.)

11olsen, you are a legend among men, a gentleman and a scholar. I will trouble you no more!

#222333

You must be logged in to reply to this topic.