Forums > Max For Live

preset not reloading automatically in live: again!

October 27, 2013 | 8:28 am

Hello,
sorry to bother again with the same issue.

I have a patch (M4L drumbox simple – check below).
If you create some pattern and save in the preset box, everything is fine, presets are saved and recall within the session. I then save my while live set, I play with another live set… and then I reload the first live set I saved: unfortunately the presets are gone :-(

I tried everything.. it doesnot work.. can you help?

cheers


October 27, 2013 | 8:29 am

Here is the patch I am talking about :-) in a zip format :-)


October 29, 2013 | 3:01 pm

i am always confused with the pattrstorage system but :
don’t you just need to put your pattrstorage’s name as the pattrstorage attribute in the preset’s inspector ?


October 29, 2013 | 11:57 pm

yes you are right, but if I do this then I get a stack overflow :-(


October 30, 2013 | 4:25 am

A stack overflow only has to do with patching logic, not the pattrstorage, you can set priority in the pattrstorage settings for each parameter to determine in which order they’re triggered, I would still say you don’t need that. Right to left is the key here.


October 30, 2013 | 5:35 am

Thanks for your replies guys! I have quesitons:
. "you can set priority in the pattrstorage settings for each parameter to determine in which order they’re triggered, "
-> Oki, I will check eventhough I can’t remember being alowwed to change priorities? Anyhow, I will check.

. "Right to left is the key here."
-> what do you mean? you mean that I should change (graphically) where I located my modules within the patche? don’t quite get it :-(


November 19, 2013 | 2:02 am

A bit late to the party, but if your original problem still persists, you could check your setup with the patch attached to this post: http://cycling74.com/forums/topic/pattrstorage-presets-not-recalled-properly/#post-266609

In short: If the presets are recalled properly with that patch, then there’s probably a flaw in your device. If the presets are messed up when reloading a Live set containing the test device, then you seem to have a buggy setup.

The latter was my problem, a clean install (uninstalling Max, erasing everything Max related from the computer, install latest version) of Max solved it.


November 24, 2013 | 12:51 am

Hello,
sorry for my late answer , I was busy on other matter :-)

I tested your patch, etc.
The patch you propose wokrs fine :-) SO it is not coming from my installation.. grrr! I would have like that it was due to my installation.

So I decided to look at the code (as you explained) and changed it, I found a solution.

It is wokring now but a friend of mine who tested it on his computer told me that ableton live cashes everytime he save a presets (clicking on the little dots in the presets make ableton live crashes).

I am fed up!
I will send a crash report to ableton live and cycling… let’see.

thanks again, you advice helped me a lot :-)
I keep you inform.


Viewing 8 posts - 1 through 8 (of 8 total)