Prevent Send from Sending to Other Patches

Sep 22, 2010 at 4:14am

Prevent Send from Sending to Other Patches

Trying to run multiple instances of a patch but I’m using sends in it. Can I disable communication between patchers?

#52427
Sep 22, 2010 at 7:58am

Use #0 in your send-names: [s #0_sendobject]
For every instance of a patch, the #0 is replaced by a unique number.

Note: this doesn’t work with subpatchers that are not saved as a file!

#188528
Sep 22, 2010 at 8:02am

Hi,

You can add “#0″ at the begining of your send and receive’s names, such as [send #0_myvalue] and [receive #0_myvalue], the “#0″ will be replaced by a random value in each instance, so the communication will be disabled between several instances.

#188529
Sep 22, 2010 at 7:35pm

Ok, thanks guys.

#188530
Sep 22, 2010 at 7:52pm

for subpatchers, if you have a lot of places where a number would need to be changed, look to [patcherargs]. Otherwise just change them manually :)

#188531
Sep 22, 2010 at 8:41pm

Does this #0 thing only work in max 5? It isn’t replacing it with a unique number for me. The patches are still communicating with each other. I could go through and give each send a new name for every instance of the patch I was running but I have a lot of sends and it would take forever.

#188532
Sep 22, 2010 at 11:05pm

#0 only works in abstractions, not in regular [p ...] patchers.

#188533
Sep 23, 2010 at 6:09am

this is Max proper right?
“—” for M4L
#0 for abstractions and bpatchers

#188535

You must be logged in to reply to this topic.