Forums > MaxMSP

pro tools le 8 max msp

August 9, 2009 | 12:03 am

I just got pro tools le, and i wondering how i could record max/msp in pro tools. if i wanted to sync the tempo, whould i use host sync if i want to match the tempo with a pro tools track? any suggestions for a setup?


August 9, 2009 | 3:33 am

morning man.

well i used pro tools properly (for work) for over a year on pro tools 7.4, so this should still apply to the new update of pro tools 8.

from what i remember what you would need is your patch (obviously) open and pro tools open. and then go to your pro tools plug-ins/effects bar and there should be a section for max/msp there to have a plug-in.
that would be for the audio side. i remember it working for me. and all i done was make sure i done all the usual i/o in max as well to talk to pro tools.

if you are wanting something that links with [hostsync~], which i needed only a few weeks ago. you need to convert the sample rate to tempo. if that makes sense, its early in the morning

here is a little patch that should help with your [hostsync~] from your patch to pro tools
there is most likely a better and much lesser patching way of doing this, but this is what came up for that works fine. it is for audio running at 48000
but i use this for an application, and it does work fine and dandy.
so when you press the space bar in pro tools to start the audio, it should sync with the max patch.
this little patch is for something going 64 steps, like sequencer by using [counter], but you obviously can edit the patch to do what you want blah blah blah…

– Pasted Max Patch, click to expand. –

have fun…


August 9, 2009 | 3:49 pm

thanks for the patch and for the help. unfortunetally, max msp is still not showing up in pro tools. should i pick rewire or core audio driver for my driver? How would i set up my i/o’s?


August 9, 2009 | 5:13 pm

there is a recent thread about this very topic

you might find something useful in here:

http://www.cycling74.com/forums/index.php?t=msg&th=28567&start=0&rid=9054&S=e280cc602e5fd525f849d445db06528b


August 12, 2009 | 4:13 pm

still nothing. max is not showing up in my plug in effects folder in pro tools. funny thing is, it shows up on my pc, not my tried playing around with the mac.MSPReWireDevice.bundle shwon in tim’s link, but wasn’t exactly sure what to do with it.


Viewing 5 posts - 1 through 5 (of 5 total)