Problem adding numbers with a trigger

Apr 10, 2013 at 1:57pm

Problem adding numbers with a trigger

I have a problem summing up two numbers using the trigger to activate the right input of an add.
I have connected everything correctly (following the add help).

The problem is that when I move a float knob from 0. to 5000. everything works almost fine until I get to 5000 where the output of the adder (5000 summed with 0) is lower than 5000 (ie 4700ish) . evertime I move my knob (or a slider) to 5000 the value never reaches 5000 and its randomly a bit lower.

The slider has a step count of 0 (automatic).

I need this to have a slider with float values from 0 to 5000 summed to a knob with float values from 0 to 180 to finetune.

– Pasted Max Patch, click to expand. –
#67637
Apr 10, 2013 at 3:49pm

Your live.numbox is capped to 5000, could that be the problem ? With a normal float it acts normally:

– Pasted Max Patch, click to expand. –
#243388
Apr 10, 2013 at 8:44pm

Thank you for your answer. Unfortunately it does not solve my problem.

Here is the complete patch ( with dial and slider)

– Pasted Max Patch, click to expand. –

If I move the slider to the maximum I don’t get 5000 but if I then move the dial a bit up and then back to zero, the reading goes to 5000. quite strange isn’t it?

#243389
Apr 10, 2013 at 9:52pm

Swap the order of the float & bang outputs of the trigger, so the float hits the add before the bang. The final value of 5000 is never ‘Banged’ because it comes before the last value of 5000 from the slider.

– Pasted Max Patch, click to expand. –
#243390
Apr 10, 2013 at 10:51pm

Thank you for the answer and the explaination. It makes perfectly sense cause I notified a value before setting it..

#243391

You must be logged in to reply to this topic.