Forums > Jitter

problem jit.gl.multiple postion control of jit.gl.videoplane


slo
August 9, 2012 | 8:09 pm

Hello,

Jit.gl.multiple is not controlling the positions of a number of videoplanes as I expect. It is changing the positions of the videoplanes but it appears to be on a shrunken scale. In the attached patch the fuzz_circles should be following the path of the sphere but appear stuck in the middle. In fact they are replicating the path of the sphere but on a much smaller scale. Can someone explicate?

Thank you,

Simon

– Pasted Max Patch, click to expand. –


slo
August 9, 2012 | 8:37 pm

It seems it is the scaling of the videoplanes that scales the positions also.


August 10, 2012 | 12:12 pm

hi, here your patch with little changes, control the position of jit.gl.multiple rather than "particles pos", may be your problem was the scaling of "jit.p.bounds" too ….
Even more be carefull to set dim to "dim 2 2" on videoplane….by default, videoplane dim is set to "20 20" , you can see a big difference with more than 1000 particles…
mathieu

– Pasted Max Patch, click to expand. –


slo
August 10, 2012 | 6:58 pm

mathieu,

Thanks for your response. Your solution makes great sense and works well. I also found that if if I left the scale attributes of the jit.gl.multiple and the jit.gl.videoplane alone and controlled the size of the videoplanes with a scale matrix to jit.gl.multiple this also resolved the problem. Your solution is nice as the particles maintain a position relative to the emission point where as with my solution the particles join the world and trail behind unless pushed by the jit.p.bounds. It’s hard to describe that, but both variations have their value.

Thanks also for the tip about the videoplane dim. Handy. :-)

Simon

– Pasted Max Patch, click to expand. –

Viewing 4 posts - 1 through 4 (of 4 total)