Forums > MaxMSP

problem when I make a project

August 13, 2012 | 10:12 pm

(sorry my bad english)

When I "save as project"
open a new window, with some patchers.
(some more *.maxpat)
var.maxpat
pan4S.maxpat

and then, are "stolen" from the max6 library !
I quit max6 and then I cannot run ok, becouse the var.maxpat & pan4S.maxpat are not there !

Two questions:
Where I must place the var.maxpat ? I cannot run [v variable] module
and What is what I do bad ?

Thanks
And sorry my bad english.

P.D.: I need port the patch made in Mac to Windows


August 14, 2012 | 4:14 pm

You might find it easier, at least at the beginning of your work, to just save all your patchers as .maxpat files in one folder. So use "Save" and "Save As" instead of "Save as Project". If all your patchers are in a single folder, they will find each other.

The "Save as Project" feature is very powerful, but may be confusing at the start. Also, the .maxproj format stores the paths to the individual project components, so if you move the individual .maxpat documents around on your hard disk, the Project may not be able to find them. If you open the .maxproj file in a text editor you will see the paths that are stored.

Although the main language on this list is English, there are many people who also speak different languages. If you give us a hint as to what your native language is, you may find someone who can help you more easily.


August 14, 2012 | 8:12 pm

Very Thanks Peter :)
Muchas gracias


August 14, 2012 | 8:30 pm

When you Save as Project it creates a folder for your project and keeps all of the various components that you use within subfolders (patches go into "patches" folder, coll and pattrstorage files go in "data", etc). This is very handy when you have large and complex patches, but probably unnecessary for what you’re doing at the moment. So take Peters advice :)
I didn’t think it would actually MOVE those files (should just copy into the subfolders) – maybe there’s a setting for that somewhere?
Also, be sure to set the correct file path preferences (I think it’s under settings?) to the folder that you keep all of your Max work in.


Viewing 4 posts - 1 through 4 (of 4 total)