Problem with analyzer~ object

Oct 3, 2012 at 10:40pm

Problem with analyzer~ object

Hi everybody
I’m new on this forum.
First of all I apologize for my bad english speaking (I’m frensh)

Some of my MAX 5 patches are feed with “analyzer~” object ; but somethimes, at the opening of the patch, this object appears in a grey tint and unfortunately it’s over of use.
I have no idea about resolving the problem. Could you help me please ?

Thanks so much
Sicerelly
zined

#64600
Oct 4, 2012 at 5:33am

Any message in the max window ? where did you put the analyzer~object ? does it “sometimes” load normally ?
Don’t worry about being french, it is not a fatality… I am too.

#233052
Oct 4, 2012 at 5:47am

Hi Stephane

Yes, most of the time, analyzer~ load normally.
The root of analyzer objet seems to have been downloaded in the MAX APPLICATION’s Folder (Mac OS X)

Thanks so much for helping
zined

#233053
Oct 4, 2012 at 6:00am

Oh yes, you’re right Stephane, there’s something written in the MAX Window :
“Analyzer~ : Warning !!! Objet set for 44.1 Khz only”

What can I do please ? Where ckecking and changing this ??

See you
zined

#233054
Oct 4, 2012 at 8:34am

i think (i think) that the analyzer~ object works in the the same way as pitch~ and fiddle~, in that you cannot have multiple objects in the same patch with the same settings. you have to offset the fft windows so that the multiple analyses are not taking place at exactly the same time.

i do not use any of these objects myself anymore, so my memory on them could be hazy; apologies if my ‘help’ is of no help. but i find it hard to believe that analyzer~ would be fixed at 44.1.

#233055
Oct 4, 2012 at 9:04am

… this might extremely trivial (in which case I apologize)…

but when the object does not instantiate, did you try checking the sampling rate in Options->Audio Status (Max6) or Options->DSP Status (Max5)?

aa

#233056
Oct 4, 2012 at 3:20pm

§§§ when the object does not instantiate, did you try checking the sampling rate in DSP Status (Max5)?

Yes Andrea, I’d checked and….. curiously the sampling rate was 44100 Hz … So I’ve set again 44100 Hz, and it works !

$$$ you cannot have multiple objects in the same patch with the same settings. you have to offset the fft windows
Hi pid. How do you do for offseting the FFT windows please ?

Thanks so much everybody for your advises
Sincerelly
zined

#233057
Oct 4, 2012 at 6:15pm

If you say the sampling rate was set at 44.1, there might be a conflict between the setting in max and a proprietary control panel for your soundcard ?

#233058
Oct 4, 2012 at 6:59pm

“If you say the sampling rate was set at 44.1, there might be a conflict between the setting in max and a proprietary control panel for your soundcard ? “

——> Ooooh, maybe yes, because I beleive the problem appears when I go to and fro between my external soundcard and my internal one….

Thanks for all your ideas and helping.
Sincerelly
zined

#233059

You must be logged in to reply to this topic.