Problem with audiounit~ b2

Nov 27, 2010 at 4:05pm

Problem with audiounit~ b2

Hello,

I’m having trouble if I really use audiounit~
It’s working fine once or twice, but then, when I load a new plugin, I’m getting crash:

Thread 28 Crashed:
0 …pple.audio.units.Components 0x7002d270 AUMixerEntry + 20979
1 …pple.audio.units.Components 0x7002dda2 AUMixerEntry + 23845
2 …pple.audio.units.Components 0x7000701c 0×70000000 + 28700
3 …pple.audio.units.Components 0x70005c7b 0×70000000 + 23675
4 …pple.audio.units.Components 0x70031a35 SystemOutputAUEntry + 2510
5 …pple.audio.units.Components 0x70030da2 AUMixer3DEntry + 5049
6 …ple.CoreServices.CarbonCore 0x98d7b7c9 CallComponentDispatch + 29
7 …apple.audio.units.AudioUnit 0x910575d2 AudioUnitRender + 67
8 com.cycling74.audiounit~ 0x3f2c8514 au_perform(int*) + 148
9 com.cycling74.MaxAudioAPI 0x14f0489c dspchain_tick + 90
10 com.cycling74.MaxAudioAPI 0x14f032cc ad_process + 470
11 com.cycling74.ad_coreaudio 0x1a8295c3 coreaudio_twodevice_ioproc + 537
12 com.apple.audio.CoreAudio 0x9118a044 HP_IOProc::Call(AudioTimeStamp const&, AudioTimeStamp const&, AudioBufferList const*, AudioTimeStamp const&, AudioBufferList*) + 374
13 com.apple.audio.CoreAudio 0x91189daa IOA_Device::CallIOProcs(AudioTimeStamp const&, AudioTimeStamp const&, AudioTimeStamp const&) + 370
14 com.apple.audio.CoreAudio 0x91189b9a HP_IOThread::PerformIO(AudioTimeStamp const&, double) + 620
15 com.apple.audio.CoreAudio 0x91186f5c HP_IOThread::WorkLoop() + 2506
16 com.apple.audio.CoreAudio 0x9118658d HP_IOThread::ThreadEntry(HP_IOThread*) + 17
17 com.apple.audio.CoreAudio 0x911864a4 CAPThread::Entry(CAPThread*) + 140
18 libSystem.B.dylib 0x95d4b85d _pthread_start + 345
19 libSystem.B.dylib 0x95d4b6e2 thread_start + 34

and always, in the console, I found:

27/11/10 14:26:43 [0x0-0x7a47a4].com.cycling74.MaxMSP[40551] MaxMSP(40551,0xa07b2540) malloc: *** error for object 0x4c9fe604: incorrect checksum for freed object – object was probably modified after being freed.
27/11/10 14:26:43 [0x0-0x7a47a4].com.cycling74.MaxMSP[40551] *** set a breakpoint in malloc_error_break to debug
27/11/10 14:26:59 [0x0-0x7a47a4].com.cycling74.MaxMSP[40551] Invalid memory access of location 0xa6a0007c eip=0x7002d270
27/11/10 14:27:04 com.apple.launchd.peruser.501[142] ([0x0-0x7a47a4].com.cycling74.MaxMSP[40551]) Job appears to have crashed: Segmentation fault

There is just need to set a plugin, use it (even without opening it”s configuration screen), change to another plugin, … and then, at the end, we get a crash.

I don’t think it’s a big problem to solve. If I run my patch in MaxMsp Runtime under XCode, I’m getting the crash in some js or juce object.

(Even in a simple patch…)

thanks for your help

#53594

You must be logged in to reply to this topic.