problem with jit.gl.render (opengl) into mixer video

Aug 2, 2010 at 12:34pm

problem with jit.gl.render (opengl) into mixer video

I have a problem and I can not understand where is the error.

I’m trying to create 4 video channels but only one of these in OpenGL so I can upload my object (. Obj).

my one and upload the patch. obj

Attachments:
  1. man.obj
#51604
Aug 2, 2010 at 4:53pm

I hope I can help you

I didn´t get the message “jitter couldn´t find destination named ml” after clicking in “name ml”.

You have another conflict: both “normal” jitter video and the OpenGL model are rendering in the same context/window. Sometimes this means you get a flickering image, because the program is trying to display the 2 images at the same time.

I see that you want to mix the 4 videos using jit.op, in normal CPU mode: this means that you have to bring back the model from the OpenGl realm to the matrices realm. You can do this by using a matrix as a rendering context (a matrix named “ml”). See the jitter example “jit.gl.render-tomatrix”, there are several methods to do this.

See patch here (it works for me)

– Pasted Max Patch, click to expand. –
#185117
Aug 2, 2010 at 5:11pm

also have a look at jit.gl.asyncread

#185118
Aug 3, 2010 at 11:16pm

ok..now i understand…but have another question…why the .obj don’t spin around the axis x/y/z ?! it’s blocked!

#185119
Aug 4, 2010 at 5:57am

jit.gl.handle

#185120
Aug 4, 2010 at 8:39am

jit.gl.handle does not work in the previous example, because the output window does not belong to OpenGL, so it does not receive the movement of the mouse.
I found this solution, rendering the model in a second window where you can move it and rotate it. jit.gl.asyncread will then transfer the (manipulated) model to normal CPU matrices. Maybe there are smarter solutions, but this works fine

– Pasted Max Patch, click to expand. –
#185121
Aug 4, 2010 at 9:29am

– Pasted Max Patch, click to expand. –

But indeed you cannot access the object by dragging over the window(you will need a combination of jit.gl.handle with other objects and attributes).

maybe is a good idea to use shaders for mixing the videos as textures, instead of jit.op. This way you don’t need to leave the openGL realm.

#185122
Aug 4, 2010 at 1:18pm

First of all thanks guys … I did not think there was all this together!
I tried the two patches (beatriz / efe) and I came to the conclusion to change the parameters of the axes of the object through the envelope follower.

But now Another question i have … ;)

is just as I created the channel envelope follower?
Why when I load a cube or sphere, etc., I see what the big screen jit.window?
Why as I load a 3D text. obj see it all changed?

you load all the files here so you can see what I’m trying to solve!

thanks guys!

Attachments:
  1. man.obj
#185123
Aug 4, 2010 at 1:24pm

ah sorry…..why don’t see the texture object into the max and assigned before the export on cinema4d?

#185124
Aug 4, 2010 at 1:48pm

sorry, I am a little bit confused now as your patch is behaving as expected. You see a big gray screen when you load your cubo.obj because of its size. Add the next attribute to your model object: [poly_mode $1 $1] and then a toggle to it, that enables/disables the wireframe rendering in openGL. When on, you will see that the cube displays the vertices that define the object’s shape. Another thing that you can try is to use the scale attribute. Check the jit.gl.model help file.

About the last question, sorry, i don’t seem to understand. If you want to bind textures to your object you can either do it inside jitter or with your modeling software(the textures will be created on a separate file). Be aware that jitter doesn’t load all types of bind materials and textures. I remember(but i am not sure anymore) C4D had some issues with exporting the textures. I think blender might be a better option for such task(you can even use shaders , very cool!):

http://www.blender.org/

sorry if i don’t reply your question, maybe if you clarify a little bit.

-emmanuel

#185125
Aug 8, 2010 at 2:53am

tanx efe!

#185126

You must be logged in to reply to this topic.