Problem with jit.gl.text2d and jit.textfile..

Apr 23, 2010 at 11:12pm

Problem with jit.gl.text2d and jit.textfile..

Hi,
I’m novice in Jitter, specially interested to manipulate text with jit.gl objects.
But I have a problem, maybe a beginner problem, with jit.gl.text2d and jit.textfile objects.
It seems to be impossible to display some words, some text which is in the jit.textfile connected to jit.gl.text2d just banging this object : the only solution I found is to send before a simple message, like [text a], in the jit.gl.text2d object, as if it would be necessary to initialyse it. After that, the text within jit.textfile can be displayed with a bang.
Is this normal ? Have I missed something in the functionning of these objects ?
I found a post in this forum, with a patch which can illustrate the problem :

– Pasted Max Patch, click to expand. –

Thanks for any explanation..

#49975
Apr 24, 2010 at 8:32pm

it’s not clear from the patch what the problem is? can you perhaps add some comments to the patch with specific steps to reproduce? thanks.

#179428
Apr 25, 2010 at 12:07am

Thanks for your reply.
Here is the patch (more simple), with comments. I hope it’s more clear.

– Pasted Max Patch, click to expand. –

Thanks again

#179429
Apr 25, 2010 at 8:37pm

ahh yes. i believe i’ve noticed that before, and my solution was to do exactly as you’ve done (initialize first with message box, followed immediately by the matrix).

thanks for the report, i’ll try to get to the bottom of this.

#179430

You must be logged in to reply to this topic.