Problem with jit.qt.grab

Aug 9, 2011 at 7:51pm

Problem with jit.qt.grab

I’ve been trying to use my I-sight with max and it was working fine until two days ago. When I test jitter in max it works, when I use photobooth it works fine, but when I open my patch, it doesn’t work at all. Mind you, my patch was working fine for months and everything is connected, but for some reason it doesn’t work anymore. I’m thinking maybe I deleted something that it needs to work? Cuz it also doesn’t work when I check the help file. Anyone know what I could do to fix this?

#58402
Aug 10, 2011 at 9:57pm

hard to say without seeing anything…. post the patch, tell us about error messages in the max window, system specs, max version….

#209892
Aug 11, 2011 at 1:35am

There is no error unless I try opening the lens again. It tells me that it’s already open. Put it into presentation mode and see if it works. I’m using Max 5.1.8 and Mac OS X 10.6.8

#209893
Aug 11, 2011 at 12:45pm

if i open the patch there is a problem with the [pfft~] object, in which the [jit.qt.grab] is embedded…i don’t think you can use [jit.qt.grab] inside a [pfft~], since the [pfft~] is made for spectral domain audio purposes.

#209894
Aug 11, 2011 at 7:35pm

Ok, well outside of the patch, jit.qt.grab doesn’t work in the help file either, even when no patch is open. When I test jitter, my camera works, just not with jit.qt.grab.

#209895
Aug 11, 2011 at 11:55pm

maybe it’s time to trash the preferences and see if that helps. Do you have the latests system update? QT update?

btw, why did you put the video inside the pfft~. As @Roel van Doorn said, that’s for spectral audio purposes. I don’t see any audio going in there… your jitter stuff should most definitely be outside that!!!

#209896
Aug 12, 2011 at 12:24am

I’m still fairly new to all of this. How do I trash the preferences? And I have Max 5.1.8… are there any other updates I should know about?

#209897
Aug 12, 2011 at 12:25pm

5.1.8 is the latest version, also i checked the ‘settings’ of the [jit.qt.grab] by attaching a (settings) message to the jit.qt.grab (send this message after message open). There were some strange google camera things in the source section, which are not the ones you want. You need to select the isight source. No clue what the google camera thing is…

#209898
Aug 16, 2011 at 6:28pm

When I did this, I have three options, none of them were google camera. And the only one that wasn’t grayed out was the i-sight camera. I closed and restarted max and created the most simple patch I could think of. It just has an open and close message, attached to jit.qt.grab and that is attached to a jit.pwindow. The green light on my camera is also on so I know the camera is responding, and the green light goes off when I click close. When I attach a settings message, it says it is using the i-sight camera and gives me a perfectly fine, working preview. What else could be wrong?

#209899

You must be logged in to reply to this topic.