Problem with Kslider and Polyphony

Nov 25, 2011 at 12:42pm

Problem with Kslider and Polyphony

Im trying to get polyphony to work but with no success. Ive followed Cycling74′s tutorial but with my own changes as i try to integrate polyphony into a bigger synth project.

Can anyone spot where ive went wrong?

#60245
Nov 25, 2011 at 1:02pm

First open the kslider inspector and change the setting from ‘monophonic’ to ‘polyphonic’.

#216852
Nov 25, 2011 at 1:09pm

Yeah ive done that. I think my problem lies within the number of oscillators i have within my poly~ subpatcher.

#216853
Nov 25, 2011 at 1:25pm

I had just opened the ‘experiment’… You should have a look at the poly~ object help and reference.

#216854
Nov 25, 2011 at 5:50pm

Your voice patch is pretty much there (although you will probably want to include a way to set the ADSR shape.)

Here’s a top level patch that implements poly~

– Pasted Max Patch, click to expand. –
#216855
Nov 25, 2011 at 9:20pm

I need the text for the polypatcher to be able to see that example :)

#216856
Nov 25, 2011 at 11:17pm

It’s the same as yours, called polyphonyvoice.maxpat

#216857
Nov 26, 2011 at 1:25am

should you not have only one oscillator inside the poly~, instead of using a selector inside one poly~ to choose between 6 oscillators create six poly~ patches with one osc in each and use a selector one level higher to choose the oscillator and poly~ patch holding it..? should be as easy as copy/ paste/ save as. i think.

good luck with the moog. :-P

#216858
Nov 27, 2011 at 7:22pm

Got it working guys with your help.

Crispypancakes whats your story? You have inside information, how did you know it was a Moog?

#216859

You must be logged in to reply to this topic.