Problem with pictctrl

Apr 12, 2008 at 4:04am

Problem with pictctrl

I read this manual part and the help files several times and managed to make toggle buttons but can’t get the dial working:

I have a 4-step knob that should work as a dial. Two rows of images. The first row contains the pictures for the 4 steps, the second row is a clone of the first row (I don’t need a “clicked” state).

I think I tried all possible settings in the Inspector but I get two picures in Max, always the first column. The dial function works, I have two moving knobs. But I would prefer to see only one ;-)

Where is the failure?

#36878
Apr 12, 2008 at 6:28am

Ok, I do not understand it but got it working with only one row. The help says there can be more pictures for a dial but however, I have no mask so I am happy with one row.

#126923
Apr 14, 2008 at 7:41am

Peter Ostry schrieb:
> Ok, I do not understand it but got it working with only one row. The
> help says there can be more pictures for a dial but however, I have
> no mask so I am happy with one row.

You simply need as many rows as you define views. If there is no clicked
image, there must not be a row for it…
(If you take your old version and check clicked images it should show
correctly as well…)

Its all explained in the subpatcher “pictureFormats” in the help file…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com

#126924
Apr 14, 2008 at 7:58am

Quote: Stefan Tiedje wrote on Mon, 14 April 2008 09:41
—————————————————-
> You simply need as many rows as you define views. If there is no clicked
> image, there must not be a row for it…

Yes, not sure what I did wrong. Works now with as many images as I want.

> Its all explained in the subpatcher “pictureFormats” in the help file…

Well, if you know how it works then it is well explained ;-)
Steep learning curve, you know …

#126925

You must be logged in to reply to this topic.