Problems extracting 3rd party externals

Apr 10, 2006 at 8:49pm

Problems extracting 3rd party externals

When I try to extract OSX externals for MAX/MSP from http://
mmonoplayer.com/mspexternals.html , they extract as folders, not as
externals. I seem to remember there were some posts about this kind
of problems on cycling74 forums, but can’t find any related posts
right now.

Any advice or solution?

klif

#25339
Apr 11, 2006 at 1:31am

Are you using stuffit? I believe these problems crop up from stuffit
not handling how some other programs encode archives. Maybe try
another unarchiver or use the command line tools.

best,
wes

#74522
Apr 11, 2006 at 2:09am

If you are dealing with .mxo plugins from a mac that does not have max/
msp installed (i.e if you are working with a stand alone or the
runtime) then it’s a crapshoot. Nothing registers the .mxo type with
LaunchServices unless you actually run the installer it seems, and you
need the Max frameworks on the system in order to actually load the
suckers.

_Mark

#74523
Apr 11, 2006 at 7:53pm

I have two machines – a G4 500 and a G4 867 – both running, identical software & OS versions and with Max/MSP installed (of course!).
One downloads these externals and unzips them, no problem, the other only sees them as folders no matter what i use to unzip them (and i tried all i could find on Versiontracker).
I can only suggest, therefore, that you try to download them on someone else’s machine.
Btw, does anyone know how to stop Safari from automatically unzipping files ?
cheers
roger

#74524
Apr 11, 2006 at 8:05pm

> Btw, does anyone know how to stop Safari from automatically unzipping files ?
>cheers
>roger

Preferences/General, uncheck “Open ‘safe’ files after downloading”.

Dan

Dan Nigrin
Defective Records
202 Hack / PC-1600 User / VSTi Host / OMS Convert / Jack OS X
http://www.defectiverecords.com

http://www.jackosx.com

#74525
Apr 11, 2006 at 8:12pm

> Btw, does anyone know how to stop Safari from automatically unzipping files ?

Use Firefox.

wes

#74526
Apr 12, 2006 at 6:57pm

On Apr 11, 2006, at 9:53 PM, roger.carruthers wrote:

>
> I have two machines – a G4 500 and a G4 867 – both running,
> identical software & OS versions and with Max/MSP installed (of
> course!).
> One downloads these externals and unzips them, no problem, the
> other only sees them as folders no matter what i use to unzip them
> (and i tried all i could find on Versiontracker).
> I can only suggest, therefore, that you try to download them on
> someone else’s machine.

indeed, i tried the same downloaded zips on other machine, and it
worked as it should…. well. now i know :)

> Btw, does anyone know how to stop Safari from automatically
> unzipping files ?
> cheers
> roger

you can disable “open safe files after downloading” in Safari
preferences.

klif

#74527
Apr 20, 2006 at 8:22am

I managed to download and open these files on my machine at home ( a G4 500, running OS 10.4.6 and Max/MSP 4.5.7) but when I try to transfer them to my work machine ( a G4 876, same OS & software versions) I still get the same problem, ie. They just appear as folders, rather than Max externals.
I tried drag n’ dropping them onto FileInfo to change the file type, but I get the following error message ?AppleScript Error: can?t make current application into type < >. (-1700)
mean anything to anyone ?
cheers
Roger
(and thanks for the Safari tip)

#74528
Apr 20, 2006 at 1:48pm

I hate to sound like a jaded monkey, but this question has nothing to do with maxmsp and shouldn’t be posted in this forum. Go to like, a stuffit forum or something, …man.

#74529
Apr 20, 2006 at 2:46pm

Really ? Having problems with 3rd party externals not a Max problem ? Funny thing, I ‘mailed the developer of these externals and he said he had been following the thread and was interested to see what came of it – wasn’t it you that was just posting about such “hero’s”..?
If you read the last post you might see that it’s nothing to do with Stuffit – I extracted the files succesfully on one machine but they wont work on another machine. I would have thought that such things would be of interest to developers and users alike ?
I’m with you on the stupid questions thing, but don’t throw the baby out with the bath water,eh?
cheers
Roger

#74530
Apr 20, 2006 at 2:59pm

do you have SubEthaEdit installed on the offending machine?
there’s a mapping of the suffix .mxo to something else in that app’s
plist somewhere that screws up the mapping of mach-o externals as
bundles.
just a thought…

/*j

#74531
Apr 20, 2006 at 3:08pm

Hi Roger,

there has been a problem some time ago where Mach-O externals would
show up as folders when you had subethaedit installed on the system. No
idea if this is still the case but the only solution was deleting it
afaik.

cheers, g.

And Now for Something Completely Different:

@ bine~/james: I’m annoyed as everyone by people posting tons of more
than obvious questions to the list, and i don’t think an “apology” in
the sig (“I got a deadline”) makes it any better. If, however, the only
way for you to deal with this is posting dozens of insulting replies a
day, then yes, please take your own suggestion seriously and do not
come here anymore.

#74532

You must be logged in to reply to this topic.