Forums > MaxMSP

Problems rewiring Max to Ableton Live

March 6, 2012 | 9:57 pm

Hello everyone – I’ve seen several posts about problems with interfacing Max and Live. I’m having trouble setting up Max to bus audio to Live (specifying Max as an input device in Live on specific channel strips) I’ve tried opening Live and THEN Max, and vice versa. Neither selecting ad_rewire nor Live as an audio driver works either. The ad_rewire setting WILL show specific ReWire out channels in the audio setup, and my meters are showing output from play~ objects in Max, but no sound is coming out in Live.

I’ve tried it in both Max 6 and Max 5 and neither works. By the way, I’m running Live 8.

Can anyone help?


March 7, 2012 | 7:50 am

Can’t help, but I can say that I have *never* gotten Rewire between Max and Live to work (though I haven’t tried recently) … one workaround -not as convenient (though its hardly convenient if it doesn’t work, right?) is to try Jack or possibly Soundflower


March 8, 2012 | 5:53 pm

Glad to know I’m not the only one. Although Max 6 isn’t really working with CoreAudio or any other driver either. Guess I’ll just stick to my copy of 5 for the time being and route it through soundflower.


March 10, 2012 | 12:17 am

I wouldn’t trust Soundflower with a blunt spoon, in my experience it ruins everything with clicks and pops after a certain amount of time running.

I managed to get sound from Max into Live by sending it to tracks 15 and 16 on my soundcard (MOTU Ultralite mkII), and then setting the inputs to 15 and 16 in Live. I can’t remember how it works, or how I set it up, but I know it is possible. I did this so I can get inputs into Max from the soundcard which rewire doesn’t seem to allow.


March 14, 2012 | 3:11 pm

Okay so what is the official status on this?

I tried to connect Max6 to Ableton8 and everything
locks up. I am running OSX 10.7.

Is this a known issue? Am I missing something?


March 15, 2012 | 4:20 am

Anthony –

I finally gave up on ReWire and am now using soundflower to do my inter-application audio routing. It’s been working well. Max 6, but running OSX 10.6.8 (and not sure I’ll upgrade right now, given some of the on-going difficulties I’ve heard about).

brad

http://music.columbia.edu/~brad


March 15, 2012 | 2:20 pm

Well I could use soundflower. But I would also like to sync
transport control.


Viewing 7 posts - 1 through 7 (of 7 total)