Forums > MaxMSP

Problems with building a "Standalone patch" that runs without installed MAX


hgh
September 25, 2011 | 12:06 pm

Hi,

i wants to make a standalone PRogramm from my Max-patch with:

File–> Build collective / Application…

Now, the build Application dont works… There are displayed these error messages:

Please help.
Best, hgh


September 25, 2011 | 5:13 pm

Sorry, what error messages? Nothing is showing up in your post…



hgh
September 25, 2011 | 8:32 pm

hi,

thanks, the file-upload failed: here is the screenshot of these error messages:

Best hgh

[attachment=171536,2665]

Attachments:
  1. maxdllprob.jpg


hgh
September 25, 2011 | 8:39 pm

Another problem is: i cant close the buildet .exe Application from my max-patch… The the "closing "x" of the window is disabled… so i cant close Build-Applications… or i have to close it with Windows task-manager… Does someone have an idea for my problams?

[attachment=171537,2666]

Attachments:
  1. cantclosemaxPatch.jpg

September 25, 2011 | 9:20 pm

In your patch, if you put a "standalone" object and open its inspector, you’ll be able to uncheck "can’t close top-level patcher".



hgh
September 25, 2011 | 9:42 pm

ahhhhhhhhhh: I´ve forgotten the "standalone" Object…

maybe that could be the reason? for all troubles with my standalone Builds?


September 25, 2011 | 9:51 pm

Maybe if you translate the error message you get?


September 25, 2011 | 10:14 pm

@hugobox

"the application couldn’t start, because cg.dll wasn’t found. Reinstalling the application may remedy the problem."

ps
I think this horrible phrase is the same in any language, no??

:-)


September 25, 2011 | 11:18 pm

Try searching the max folder for "cg.dll", then copy paste it in your standalone application’s "support" folder. Otherwise search the forum for cg.dll, it surely happenend to someone else before.



Joe
January 16, 2013 | 10:24 pm

alright lads

I am trying to build a standalone for my max patch (mac) but I have a question…

I have some externals in the patch , will they be automatically included?

thanks



Joe
January 16, 2013 | 10:36 pm

I have included everything that is needed now, but when I open the application that I have made it is not in presentation mode… why is this? and how do I make it so it is presentation mode?

cheers,

j



Jan
January 16, 2013 | 11:15 pm

Go to the patcher inspector and set the flag "open in presentation mode"
Cheers
jan



Joe
January 17, 2013 | 12:59 am

you beaut! perfect thanks

j


Viewing 13 posts - 1 through 13 (of 13 total)