Forums > Jitter

Problems with jit.vcr not recording required output matrix

April 30, 2011 | 7:02 pm

This is a bit of a tricky one to describe but i’ll try my best.

The comings and goings of the issue are essentially that jit.vcr wont record a glitch matrix (using a series of jit.noise objects) that I’ve included in my patch; choosing instead to just record the matrices (three jit.qt.movie objects fed through a switch and an xfade) that it is supposed to sit on top of.

The odd thing is that jit.qt.record does the job perfectly but seeing as i have msp audio and rewired audio from ableton to include in the recording as well, jit.qt.record doesn’t quite do the whole job.

Before someone recommends that i post the patch, it’s a bit messy by many peoples standards and would take quite a while to clean up so that it might be comprehended by anyone other than the person who built it. If it comes to it, obviously i’d happily spend the time cleaning it up but in the name of efficiency I thought it worth just describing the issue first.

Any help would be greatly appreciated.


May 1, 2011 | 9:39 pm

Any error messages in your Max window. If your media doesn’t sync up with your Audio you are SOL, meaning be sure jit.vcr is getting both a valid media track and your DSP (dac~) is on and your source is putting a valid audio stream into jit.vcr.

Post a patch if and when you can. Don’t worry TOOO much about a messy patch, if it’s unreadable then we might ask you to abbreviate or clean it up. Not like we are going to laugh at you or anything. :)


May 4, 2011 | 1:03 pm

The audio and the video sync up fine, its just that the glitch module that i made to lie on top of the jit.qt.movie matrices with a jit.op object wont record.
Here’s a copy of the patch:
Load a couple of .mov video into the ji.qt.movie objects at the top. Then play around with the blending options until the two videos lie on top of each other. Then press one of the toggles attached to the MSP cycle object to make a repetitive bleep (make sure the "ableton audio in" toggle is turned on in the bottom right). Next thing to do is hit the toggle marked glitch sequence to start the glitch overlay.
Then hit the write button at the bottom to start the jit.vcr record object.
You should see that the video underneath is included in the recording but not the glitch effect that is meant to over lay it.

Here’s the patch:

– Pasted Max Patch, click to expand. –

Hope this helps. Thanks for the assistance so far!


Viewing 3 posts - 1 through 3 (of 3 total)