Forums > Max For Live

Problems with Maxuino and M4L

February 10, 2010 | 12:29 am

hi,

today I was working with Arduino and some Sensors and I wanted to combine it with M4L. Therefore I used my modified Maxuino-Patch and sent the data to a Max Effect Patch via OSC, to control some basic parameters.
The problem is, that everytime I had the Max Effect Patch opened at the same time as the Maxuino Patch, my Computer seemed to freeze, or at least to become really really slowly. I no longer could use my mouse, the only possibility was to control my computer by keyboard, where I still could close e.g. the Maxuino Patch (the computer reacted with a delay of several seconds). But then everything was ok again. So I just had to close this window, not to shut down Max completely. It also worked, when I closed the opened Max Effect Patch.

(I also tried the connection between maxuino and live with send- and receive-objects, but there also came this problem, and so I tried it with OSC, but this doesn’t seem to be the problem now).

I really don’t know what could be the problem here.
Is it maybe because I am using a normal Max-Patch and the Max Effect-Patch in M4L simultaneously?
Or could it help to integrate everything in a Max Effect-Patch? But this would mean, that I can’t use normal Max, when using M4L ?!

regards,
Matthias


April 6, 2010 | 10:24 pm

if you are still looking for solutions, we released a max4live object for maxuino…see if that helps.
Chris


Viewing 2 posts - 1 through 2 (of 2 total)