Problems with MIDI mapping

Apr 30, 2013 at 6:01pm

Problems with MIDI mapping

I’m having trouble getting M4L devices to pick up midi movements. I’ve made a small patch that connects to various Live effect devices throughout my set and it controlled by my midi controller.
If I have it on pickup mode, it quickly loses track of its position (especially with fast movements) and you have to carefully find the last pickup point to continue.
Takeover isn’t much better. Imagine doing a low cut drop, the controller loses its way and gets stuck on 150hz… no good at all! You have to wiggle it around a little bit to make it pay attention again so this isn’t any good either.

Is there a way to make Max pay closer attention or something? Feel like I’ve just wasted an awful lot of time making a dynamic FX controller that isn’t very dynamic.

edit: Things work fine if you control the live.dial’s using the mouse so I’m confused as to why MIDI can’t handle it.

#68025
May 1, 2013 at 9:45am

In the live.dial inspector, try checking ‘Defer Automation Output’.
You can also try increasing the ‘Update Limit’ parameter.

I guess your problem is related to high vs. low priority events as explained in this article.

http://cycling74.com/2004/09/09/event-priority-in-max-scheduler-vs-queue/

#244421
May 6, 2013 at 6:51pm

Nice one! The ‘Defer Automation Output’ thing works perfectly :) Thank you

#244422
May 21, 2013 at 2:30am

Thanks as well !

I had some issues with my midi controlleur and thanks to “defer output automation” The midi controller controls fine my patch :-)

#250028

You must be logged in to reply to this topic.