Forums > MaxMSP

problemWithSerialObjectAndArduino

October 9, 2006 | 6:01 pm

Hello, I stiff on that!
I tried to use "simple message system", to communicate beetwin arduino and max;
it seems i can upload to arduino card…I tryed to use several arduino
it worked several days…then never wan’t any more???
Any one experimented same problem on OsX?
After reseach on web(faq arduino, etc)
Tryed any thing (from mac panel, from terminal, from library, from
preferences, from driver…erase, update…no change, I wait…one
mons no change
I hope it don’t append to you…or i hope it append to you also!
Then some one solve it simply!!??

view from Arduino, some time it said

Error inside Serial.()
gnu.io.PortInUseException: Unknown Application
at gnu.io.CommPortIdentifier.open(CommPortIdentifier.java:354)
at processing.app.Serial.
(Serial.java:127)
at processing.app.Serial.
(Serial.java:72)
at processing.app.Uploader.uisp(Uploader.java:146)
at processing.app.Uploader.uploadUsingPreferences(Uploader.java:78)
at processing.app.Sketch.upload(Sketch.java:1689)
at processing.app.Sketch.exportApplet(Sketch.java:1749)
at processing.app.Editor$38.run(Editor.java:1866)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:189)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:478)
at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:234)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:184)
at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:178)
at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:170)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
Atmel AVR ATmega8 is found.
Uploading: flash
Firmware Version: 1.18
Firmware Version: 1.18

view from max , it said

* error: serial: error setting tty attribute (/dev/cu.usbserial-5B22)
* error: serial: error setting tty attribute (/dev/cu.usbserial-5B24)

p.baes


Viewing 1 post (of 1 total)