ps3 eye 120 fps?

Aug 8, 2010 at 8:33am

ps3 eye 120 fps?

i’m searching a way to have 120 fps with a ps3 eye webcam on a macbook pro.
is there some one who know?
the driver is the latest macam. i’ve seen a post about it but the solution was not resolved

thank’s

cordialy

helios

#51707
Aug 8, 2010 at 10:34am

I’m looking for a solution too !
With macam it seems like it gets 100 to 120fps, but with the grab object I don’t get all these frames….
In the best case I get 40fps

#185504
Aug 8, 2010 at 12:42pm

100 to 120 fps? how do you do? in macam i can’t get more than 30 fps … even if i’m in 320 240 SIF …

#185505
Aug 9, 2010 at 4:44pm

perhaps a solution with a modification in the macam’s SDK ?
i’m looking for …

#185506
Aug 26, 2010 at 1:36pm

if i modify the .plist of the preference to 120 fps, i can see in macam 120fps, but it crash when you start to record in macam, and in jitter if you record at 120 fps, the images are duplicate, …
any idea?
thank’s

#185507
Nov 7, 2010 at 2:08pm

hi there,

I am also trying to get 120 fps in ps3 eye cam.
I am only capable of getting 50 fps though.

I store macam driver to 180 fps -> jit.qt.grab -> settings (window) -> compress -> change from fps setting “best” to “custom” 180 fps.

With @unique 1 in jit.qt.grab I get 50 fps. I anyone know how to get 120 I would be grateful to know.

-s

#185508
Jan 25, 2011 at 2:54pm

SOLVED!

Hello guys,
I have found a solution for mac users,

download the latest version of macam CVS here:

http://sourceforge.net/projects/webcam-osx/files/cvs-build/2009-09-25/macam-cvs-build-2009-09-25.zip/download

They have added the 320×240 support and now you can choose until 180 fps.
Tested and it works!

micron

#185509
Jan 25, 2011 at 7:25pm

I still only get 40 fps (at best) with [jit.qt.grab 320 240 @unique 1]. could you please share your setup and how you got it to run at 120?

#185510
Jan 25, 2011 at 8:03pm

Did you change camera settings to allow 120 fps?
Which “qmetro” setting are you using?

#185511
Jan 25, 2011 at 8:34pm

yes, I did change fps in “settings” and changed my qmetro to [qmetro 1]…

#185512
Jan 25, 2011 at 11:12pm

In “settings” you have to choose 320×240.
If you can post a screenshot of your settings panel.
Tomorrow if i can i will post my configuration but it is as I described before.

#185513
Jan 26, 2011 at 3:54am

here are my settings. thing is, if I set them hit ok and then go back to the settings, the fps is set back to 0. but the dimension stays at 320 240…

[attachment=152151,1722] [attachment=152151,1723]

Attachments:
  1. Screenshot20110125at7.45.49PM.png
#185514
Jan 26, 2011 at 10:43am

You were right, i forgotted to put “unique 1″
now i have 40 fps again damn!
In macam 120 fps but now i want find the right setting for max…

[attachment=152180,1727]

Attachments:
  1. macam120.tiff
#185515
Jan 29, 2011 at 4:55pm

on a separate but related note, has anyone had any luck teasing 48kHz out of the PS3 eye audio mic-array, as you know there are 4 mics in there and I can only select 16bit 16khz for them using usb audio driver b4.09.24.1
?

#185516
Jan 29, 2011 at 6:07pm

oh and for the record, meant to add that i too am getting 40fps max !

#185517
Feb 5, 2011 at 12:07am

I did a lot of test but it seems impossible now, maybe there is a jitter limitation in fps?

Maybe someone know if quicktime digitizer can’t give 120 fps?

I’m on a macbook pro 2.4 Ghz Intel core i5 4 GB RAM.

Macam driver seems work fine, on macam player I can obtain 120 fps.
What really do “unique 1″ ?

I don’t know what else can I do now!

#185518
Feb 5, 2011 at 1:28am

@unique 1 just outputs a frame if that frame is different from the previous one. so if you get rid of the @unique 1 you will easily get 120 fps. what you really get is a ton of duplicated frames!! since the best I could get is 40 fps that would mean that without @unique 1 you would get 3 repeated frames at 120 fps…

#185519
Feb 5, 2011 at 8:54am

try sending a message “framerate 180.” to jit.qt.grab…
(+ configure the settings to 180 fps)
–> I can reach 60 fps (@unique 1 !) with these settings.

the weird thing : if you send a message “framerate 60.”, (or anything else than ‘framerate 180.”), then you’ll get only 40 fps…

Mathieu

#185520
Feb 5, 2011 at 8:08pm

THANKS!

Now I can get 60 fps too.
Slowly will we reach 120fps ? ;)

#185521
Feb 7, 2011 at 1:57am

same here… getting there ;)

what is odd is that I need my qmetro set at 5 to get 60fps when 15 should do the trick…. what metro settings are you guys using?

#185522
Feb 7, 2011 at 3:43am

I can reach 170fps without unique 1 , and 60 with unique 1. qmetro set to 5.

so it is advisable to stay with unique 1 at 60fps and qmetro at 5?

#185523
Dec 14, 2011 at 10:43pm

any idea for windows? @:)

#185524
Dec 15, 2011 at 7:38pm

For Windows, install the CL-Eye Driver and consult this forum thread:

http://codelaboratories.com/forums/viewthread/154/P0/

Build and put the “cleye.config” file on Max directory and then using jit.dx.grab “format $1″ message, you’ll be able to use the following resolution/fps combinations:

format 0 to 5: 640×480, 75/60/50/40/30/15 fps
format 6 to 11: 320×240, 125/100/75/60/30/15

Good luck!

#185525
Dec 16, 2011 at 11:59am

wow!
works great!
thanks!!!

#185526
Feb 14, 2012 at 4:08pm

do you know, is there any way to access settings in windows? when i send “settings” message to jit.dx.grab the window pop up, but all sliders are unavalible.. i is quite nessesary for example to lock the exposure, and will be very helpfull in computer vision projects.

#185527
Feb 16, 2012 at 1:52pm

I can’t access the settings either. I don’t know if there is any workaround…

#185528

You must be logged in to reply to this topic.