Forums > Jitter

QT Playback – HELP!


d_s
September 4, 2008 | 6:15 am

I have created a simple QuickTime playback patch that displays 1024×768 30fps movies on a projector. The hardware is a mac mini 1.83, stripped bare of everything except the MAX 5 runtime.

The playback is direct to QuickTime, Jitter is not handling the stream. Patch included below.

During playback I get jitters / judder about every 3-5 seconds. It’s like a big hiccup.

I have tried a million configurations. h264, photo JPEG, sorenson 3, MPEG2, MPEG4, Animation. No change in codec fixes the problem. I have tried different movies to be sure it’s not the source material.

I have tried turning "caching" on and off in the QT movie properties.

I have tried all of vade’s QT playback patches, CPU and GPU based as well as QT direct. The QT direct method gives the smoothest playback.

Further, this problem is visible on my Mac pro 8 core. It can’t even play back the movies smoothly, even at lower resolutions.

Any recommendations as to what to try next? Is quicktime just this bad? Processor usage is only at 35% on each core the whole time.

Any advice is much appreciated. My show goes live on Sunday.


September 4, 2008 | 8:00 am

Why do you have the noaccel flag set to 1? I would guess that’s not
helping much. Try removing that and see what happens.

You can also try getting rid of all the various print objects in the patch.

On Thu, Sep 4, 2008 at 8:15 AM, Damon Seeley wrote:
> I have created a simple QuickTime playback patch that displays 1024×768 30fps movies on a projector. The hardware is a mac mini 1.83, stripped bare of everything except the MAX 5 runtime.
>
> The playback is direct to QuickTime, Jitter is not handling the stream. Patch included below.
>
> During playback I get jitters / judder about every 3-5 seconds. It’s like a big hiccup.
>
> I have tried a million configurations. h264, photo JPEG, sorenson 3, MPEG2, MPEG4, Animation. No change in codec fixes the problem. I have tried different movies to be sure it’s not the source material.
>
> I have tried turning "caching" on and off in the QT movie properties.
>
> I have tried all of vade’s QT playback patches, CPU and GPU based as well as QT direct. The QT direct method gives the smoothest playback.
>
> Further, this problem is visible on my Mac pro 8 core. It can’t even play back the movies smoothly, even at lower resolutions.
>
> Any recommendations as to what to try next? Is quicktime just this bad? Processor usage is only at 35% on each core the whole time.
>
> Any advice is much appreciated. My show goes live on Sunday.
>
>
>
>
>
>
>
>



d_s
September 4, 2008 | 11:50 pm

Thanks Scott,

Removing noaccel didn’t change anything. I think that’s because QuickTime is handling the video at a system level when run in direct mode.

I removed the one print statement with no change.

Investigation continues.


September 6, 2008 | 5:42 pm

i would try @unique 1 on your qt.movie, and perhaps lower your metro rate(maybe 10). as i’m sure you know, generally photo-jpeg plays the best with jitter.

it’s also been suggested to disable java by add "jitter java 0;" to a file named jitter-config.txt in your search path.

other than that can’t say much else. maybe just use max to send applescript messages to quicktime to play your movies.


September 7, 2008 | 10:51 pm

I’ve actually been able to get the best performance with Apple Intermediate codec.

———
d_s wrote:
"I have tried all of vade’s QT playback patches, CPU and GPU based as well as QT direct. The QT direct method gives the smoothest playback.

Further, this problem is visible on my Mac pro 8 core. It can’t even play back the movies smoothly, even at lower resolutions."
———

I can understand Vade’s GPU-based playback patches not working well on a Mac Mini, but on your Mac pro 8 core?

I’ve been able to play back 3 simultaneous 720×480 vids (apple intermediate) using Vade’s "GPU UYVY" method on my MacBook Pro (GeForce 8600M GT – 512 MB) without falling below 30 fps – and no hiccups.

If you feel like it, send me a link to one of your vids and I’ll tell you what I get.

Zachary



d_s
September 9, 2008 | 4:31 am

Hi Zachary,

Thanks for your post. Unfortunately the deployment machine is a mac mini which is underpowered in the video card department. Here is a link to a movie – I would love to find out what your results are on the MBP.

http://electroland.net/transfer/MIRA/PLAYBACK/fri_update/4.zip

I have tried photo JPEG and Apple intermediate and both start to stutter on the mac mini due to data rate I believe.

Thanks,
d_s


September 10, 2008 | 12:57 am

Yeah. I get minute stutters as well – in Jitter and when playing through Quicktime directly. Do you need 1024×768? If not, try 800×600, set the projector to 800×600 and keeping lowering the quality until you get the right mix of quality/performance. Good luck! Let us know what ends up working best for you.

Zachary



d_s
September 10, 2008 | 1:33 am

We don’t explicitly need 1024 resolution but given that most projectors are 1024-native it would be *really* nice. I can’t believe that in this day and age QuickTime can’t playback a low-bitrate file smoothly at that rez. I am no Windows fan but I can tell you that Windows Media is pretty darn smooth, even on wimpy boxes.



FP
September 10, 2008 | 8:11 am



d_s
September 10, 2008 | 5:55 pm

Thank you for your reply.

Update on this project: We deployed it in China and it seems to be working with the occasional judder mentioned here. Synchronization across 10 projectors is nearly frame accurate.

The judder problem has been helped by opening each QuickTime movie and turning off the "conform to aperture" option, as well as making sure that each QT track is set to cache.

Final movies were encoded using CBR h.264 because they had to be transfered trans-pacific to the project site. I found that using CBR instead of VBR h.264 decreased judder.


Viewing 10 posts - 1 through 10 (of 10 total)