quick crossfades without clicks?

Jun 5, 2008 at 1:43pm

quick crossfades without clicks?

Hi guys,

I’m trying to create an scratch effect by quickly switching a signal on and of but I’m getting a click when between the on and the off setting. How would you create a ramp so that you’d get a smooth transition between the states. It has to be very quick similar to, but preferably faster than, a crab scratch.

http://www.youtube.com/watch?v=w5OeaC3rI-A&feature=related

Basically I’m using MsPinky vinyl to control numerous scratch noises but want use a drum pad(s) or midi key(s) for the cutting.

Thanks in advance
John

#38250
Jun 5, 2008 at 2:22pm

On 5 juin 08, at 15:43, dx1200 wrote:

> I’m trying to create an scratch effect by quickly switching a signal
> on and of but I’m getting a click when between the on and the off
> setting. How would you create a ramp so that you’d get a smooth
> transition between the states.

It depends on how you do your on/off switch:
[gain~] has a “Interpolation time” parameter;
you could use [line~] with [*~ ];
you could use [matrix~ ] and an adequate ramp message;
etc.

_____________________________
Patrick Delges

Centre de Recherches et de Formation Musicales de Wallonie asbl

http://www.crfmw.be/max

#133086
Jun 5, 2008 at 4:52pm

as well as what patrick mentioned you can use a peek~ or wave~ lookup

On Thu, Jun 5, 2008 at 3:22 PM, Patrick Delges

wrote:
>
> On 5 juin 08, at 15:43, dx1200 wrote:
>
>> I’m trying to create an scratch effect by quickly switching a signal on
>> and of but I’m getting a click when between the on and the off setting. How
>> would you create a ramp so that you’d get a smooth transition between the
>> states.
>
>
> It depends on how you do your on/off switch:
> [gain~] has a “Interpolation time” parameter;
> you could use [line~] with [*~ ];
> you could use [matrix~ ] and an adequate ramp message;
> etc.
>
> _____________________________
> Patrick Delges
>
> Centre de Recherches et de Formation Musicales de Wallonie asbl
> http://www.crfmw.be/max
>
>

#133087
Jun 5, 2008 at 4:53pm

At the moment I’m using gain~ and turning the audio on and off using a toggle that is receiving midi from a drum pad. When toggle is off I’m sending the 0 value to the gain~ and when toggle(audio) is on it sends a volume setting for gain~ to jump to.

I’ve looked at the help files and reference but I’m afraid I don’t understand how I can get the fader to smoothly go between the two points.. I’ve changed the ramp time in the inspector but this didn’t seem to have much effect.

What am I missing?

J

#133088
Jun 5, 2008 at 6:28pm

Hmm I thought this would be easier…

Thanks

#133089
Jun 5, 2008 at 7:26pm

On 05-juin-08, at 20:28, dx1200 wrote:

>
> Hmm I thought this would be easier…

in [gain~]‘s inspector, rise the interpolation time to something bigger
than 10ms (like 30). It works but you won’t see the fader moving
slower. If you don’t trust me, just try with a big value like 4000ms.

p

#133090
Jun 5, 2008 at 7:30pm

I trust you Patrick :) this sounds right to me. I’ll try and let you know.

Thanks man
Best
j

#133091
Jun 6, 2008 at 2:49pm

you can also try connecting a message box with this in it: [$1 20] to
a line or line~ object connected to the gain~ object. The number in
the message box is the ramp time in ms. then you you can route your
toggle 0 1 to bang a message box with 0 and a message box with 130
both connected to the [$1 20] :) is that as clear as mud?

Cheers,

On Thu, Jun 5, 2008 at 8:30 PM, dx1200

wrote:
>
> I trust you Patrick :) this sounds right to me. I’ll try and let you know.
>
> Thanks man
> Best
> j
>

#133092
Jun 6, 2008 at 7:56pm

My apologies. I should have seen this sooner. I had been stopping and starting the file as well as killing the signal. I’ve rectified this error and all runs smooth as Patrick had initially suggested.

Thanks for the help gentlemen.
J

#133093

You must be logged in to reply to this topic.