Forums > MaxMSP

Receive MIDI controll messages

May 13, 2014 | 2:05 pm

I have been using MAX4Live for some time however I just bought MAX standalone and I wanted to create a patch that I can control using my MIDI controller. I assume [ctlin] is the correct object to use (?) but adding this to the patch it seems like nothing is received by the object. The controller is enabled in Options-> MIDI setup. Is there anything else that needs to be configured etc to get this to work?


May 13, 2014 | 2:23 pm

Hey,

You can try this, if I am not misunderstood.

– Pasted Max Patch, click to expand. –

You should be sure that you are receiving data from a desired port. Just double click on the [ctlin] object. You’ll be able to see your devices as a list.

Best,

mco


May 13, 2014 | 3:08 pm

Thanks. That worked fine. Not sure what I was doing wrong. Well well.. Can I ask if you please can advise what is the best practise for routing/binding the incoming message to a slider etc.


May 14, 2014 | 7:45 am

From a midi device to a slider or vice versa?


May 14, 2014 | 2:27 pm

From a MIDI device to e.g a slider.


May 15, 2014 | 12:00 pm

I’d go for [ctlin] -> [scale] -> slider/whatever is necessary. [scale] can be used in exponential way with the last argument
(ex. scale 0 127 0. 1. 1.) and I guess better to use with volume scaling.


May 15, 2014 | 2:22 pm

Great! Thanks for the advise:) Nice tip about the exponential parameter.


Viewing 7 posts - 1 through 7 (of 7 total)