Recording Webcam with a good preview

Dec 7, 2011 at 9:02pm

Recording Webcam with a good preview

Hello,

I just begin to learn MaxMsp, event though I previously used Pure Data.
I would like to finish a little object. A webcam which records people in front of it. I would like the preview to be enough fluent and each time somebody clicks on a button, it records 30 seconds of video.
The patch I made is partly completed although I tried the jit.vcr component to record the video and sound while the jit.qt.grab displays the image in a windows.
Nevertheless, I didn’t get videos. I only got incomplete videos (100 ko each time, only one frame…

Here is my patch. ANy help or advive would be welcome :)

Thanks

– Pasted Max Patch, click to expand. –
#60543
Dec 7, 2011 at 9:22pm

you should enter a sound from MSP in the 2 first inlet of the jit.vcr.
I don’t have “jpeg” in the codec list. so I’ve used photojpeg and a stop message to jit.vcr after 30 second.
it works for me
better picture with a dim 640 480 attribute to jit.qt.grab too.

– Pasted Max Patch, click to expand. –
#217891
Dec 7, 2011 at 9:28pm

Hi Robert,
the sound I want to record is the sound coming from the webcam indeed. That’s why I connected it in the first inlets… If I use an adc~ object, will it take only the webcam sound?
I just tryed as well your patch, and I have a problem. Each time I’m trying to record, I only get a 1 second movie… Strange, isn’t it? Did you get something similar?

#217892
Dec 7, 2011 at 9:35pm

If your webcam got a built in microphone, it should appears as an input device in the dsp statut window.
double click on the adc~ object.

#217893
Dec 7, 2011 at 9:39pm

Strange, it works well when I test it within the system folder. But as soon as the main patch is saved in an other directory, it doesn’t wor anymore.
Anyway, Robert, MANY thanks, it is great to get help:)

#217894
Dec 7, 2011 at 10:01pm

just grabed this in the “grab” tutorial :

“Some video capture devices don’t work properly in the jit.qt.grab object’s default mode (vmode 0, or sequence grabber mode). If you find that jit.qt.grab is acting erratically, try sending it the message vmode 1 (vdig mode). This enables a method of video capture that is more reliable on certain capture devices.”

might help.
but your issue is definitily weird.

#217895

You must be logged in to reply to this topic.