Forums > MaxMSP

Remembering VST presets in Max/Msp

December 3, 2013 | 6:39 pm

I am trying to get Max/MSP to remember vst presets for my patch. Every time I close the patch and re-open, the vst goes to default. The vst I am trying to use is called alchemy (free version). Does anyone know how to get max/msp to remember vst presets, does it vary for different vst’s and audio unit plugins? Here is the link to download alchemy player. http://www.camelaudio.com/AlchemyPlayer.php

Note: screenshot is attached.

Attachments:
  1. Screen-Shot-2013-12-03-at-8.19.59-PM

December 3, 2013 | 6:52 pm

you must find a custom solution to save the data in or with your patch. look at the helpfile or reference and check what all the outlets can return upon certain messages.

of course one solution can also be to just write a preset to disk and load it again next time, maybe even manually.

-110


December 4, 2013 | 12:09 am

I think the "write preset to disk" that Roman pointed out is the only effective way. You could save/recall every parameter in the VST in max. However, there are usually many parameters in a vst (such as mseg’s and graphical parts) that are not available directly in max, but are available in FXP/FXB.

If anyone knows of a way to save an FXP/FXB file inside of max rather than on disk, it would be lovely to find out.


December 4, 2013 | 4:05 am

The problem with automating preset loading with vst~ is that there is no way for vst~ to signal that a plug-in is done loading.
It would be great if vst~ could do this, but as has been discussed before, this is a VST issue, and not one that Cycling74 can do anything about.
Search the forum, because this has come up before, but I’m not sure that anyone came up with a satisfactory solution,
Cheers
Roger


December 4, 2013 | 11:36 am

There *is* a good way to know when vst~ is done loading – it’s a long thread, but see the Andrew Pask code that I pasted there.


December 4, 2013 | 12:41 pm

this might help

http://olilarkin.blogspot.co.uk/2009/12/olvstpattr-vst-wrapper.html


December 4, 2013 | 3:48 pm

the [error] object ?!


December 4, 2013 | 3:54 pm

ah, oh, no, then simply, max control messages won’t go on until a vst is loaded. So a proper [t] is enough !


December 4, 2013 | 4:35 pm

that may work, I never bothered to try it, since what Andrew provided worked fine for my purposes!


Viewing 9 posts - 1 through 9 (of 9 total)