Forums > Jitter

rendering with no erase

June 15, 2006 | 5:24 pm

Hi buddy,

I would like to have my opengl canvas be continuously draw over without erasing so that I can have a complex background with newly added elements.

However, I’ve just found that I cannot draw on the portion of the screen where I have already draw before. In a result, I cannot add my new colors over my old color.

I have tried to use rendering context feedback to redraw my background but there is some slight displacement among frames and make it result in a small bluring effect…

I guess the problem is because the default rendering in Max/Jitter is double-buffering and my idea in the first should work if I can have a single-buffered canvas, is it?

Thanks for your attention and look forward to hear any advise…

yours,
William


June 15, 2006 | 6:09 pm

Hiya pal,

This is just a guess, but possibly you are rendering with
depth_enable on, and z buffering is preventing more things from being
drawn. Try turning depth_enable off.

best,
Randy


June 16, 2006 | 5:14 am

Thanks Randy.
Your guess is right, and now I can have my graphics correctly.

But when I have the window fullscreen, the screen flicks and I can see swaps
among my desktop and my graphics.

Are there a way to "invalidate" my screen, so it is always be the target to
be refreshed ?

Many thanks to all.

yours,
William


June 16, 2006 | 8:01 am

If on windows, you may be able to avoid of of his by changing your
windowing acceleration in your monitor settings. Otherwise after you
switch to (or from) fullscreen, perform an erase for he first render,
then don’t erase.

-Joshua


Viewing 4 posts - 1 through 4 (of 4 total)