replace_selected_notes message doesn't work

Jun 25, 2011 at 8:40am

replace_selected_notes message doesn't work

Hi,

I would like to use Live API to replace/create midi notes in a midi clip via the replace_selected_notes message box.
All message boxes works fine except this one, the Max window sending the message «an operation is already in progress» each time I click on the message box.
I tried and tried (including this: http://cycling74.com/forums/topic.php?id=26062 ) but nothing seems to work with this message.
Any idea would be really welcome !!
I join the patch, note that it has to be inserted in the track 0, this one being a midi track.

Thanks,
Best,
Nakatano.

– Pasted Max Patch, click to expand. –
#57764
Jun 25, 2011 at 9:14am

Hey, it seems to work like this !

– Pasted Max Patch, click to expand. –
#207246
Jun 25, 2011 at 9:33am

Could be something like this:
(cannot understand the errors messages in Max window…

– Pasted Max Patch, click to expand. –
#207247
Jun 27, 2011 at 1:51pm

Well, this time I really cannot understand: the patch works great when you “bang manually” but doesn’t work when using a metro object ?!?!

Any idea ?

here’s the patch:

– Pasted Max Patch, click to expand. –
#207248
Jun 27, 2011 at 10:29pm

It’s a matter of event priorities. Try inserting [deferlow] after the metro.

See this article for more information.

http://cycling74.com/2004/09/09/event-priority-in-max-scheduler-vs-queue/

#207249
Jun 28, 2011 at 6:25am

It works great !
I read this article immediately.

Thanks

#207250

You must be logged in to reply to this topic.