Forums > Jitter

Resolution of Jit.GL.Render

December 29, 2012 | 5:55 pm

Hi, I’m trying to get OpenGL in to a matrix, and I want to be able to readily set the resolution. However, it’s not working how I expect, and when I try to set the dimensions it does not seem responsive. Can anyone help me to understand the object better?

My patch is rigged up to give some simple OpenGL graphics, and to render to a matrix. However, the resolution doesn’t seem to be being set.

– Pasted Max Patch, click to expand. –


dtr
December 29, 2012 | 6:58 pm

Try this. Jit.gl.render gets its resolution from its render destination. In this case the matrix so it should be set explicitly there.

– Pasted Max Patch, click to expand. –


dtr
December 29, 2012 | 7:02 pm

Here’s the same but stripped of the confusing @drawto’s.

– Pasted Max Patch, click to expand. –

December 29, 2012 | 9:31 pm

Hey dtr, thanks for the response.

When I try sending the matrix dimensions settings to go from 1080 to 720, the image then appears cropped. Do you get this too? I wonder how to stop this cropping and preserve the full frame?



dtr
December 29, 2012 | 10:00 pm

Not entirely sure why that’s happening but here’s an alternative. The matrix will have the same size as the render destination window.

– Pasted Max Patch, click to expand. –

December 30, 2012 | 5:59 am

Interesting. Your patch seems to work as expected. I tried recreating my problem after looking through Tutorial 31, and am still having the same issue – it seems to be that new matrix dimensions are relative to the initial dimensions, as illustrated in the patch below.

It still seems strange that I can’t change the dimensions in the way expected :-?

I wonder what I am overlooking??

– Pasted Max Patch, click to expand. –

December 30, 2012 | 9:35 pm

you can fix this problem by re-sending the drawto attribute to jit.gl.render after changing the matrix dimensions.

eg, send dim 160 120 to the matrix, then send drawto clyde to the gl.render.

– Pasted Max Patch, click to expand. –

December 31, 2012 | 3:32 am

That has sorted me out! Much appreciated

Is this a bug, or just the way it’s supposed to work?


June 27, 2014 | 8:41 am

How can I manually control resolution of gl.render output texture regardless of jit.window size ? ("drawto matrix" do not count).


June 27, 2014 | 10:31 am

jit.gl.node @capture 1 @adap 0 @dim width height


June 27, 2014 | 11:44 am

output texture of jit.gl.node will desired resolution, but then we send it to the jit.gl.videoplane "master" render still has resolution of jit.window. right?


June 27, 2014 | 2:18 pm

No, jit.gl.videoplane just accepts the resolution of whats coming in.
If your videoplane has a lower resolution coming than the master setting (jit.window) and you make it full screen then it will be pixelated, which makes perfect sense.


June 28, 2014 | 7:02 am

ok!)


Viewing 13 posts - 1 through 13 (of 13 total)