Forums > MaxMSP

Retina performance

May 28, 2013 | 11:40 am

Hello.

 

Anyone else experiencing buggy retina performance?

Even non-graphical performance takes more CPU than non-retina mode.

If I switch into non-retina and back into retina WHILE doing any type of processing CPU usage drops for around 45% and stays that way… which leads me to believe there is some bug involved and should not be considered normal behaviour?

 

This is happening on integrated graphics.



dtr
May 28, 2013 | 1:46 pm

Another retina performance report: http://cycling74.com/forums/topic/possible-bug-using-poly_mode-on-macbook-pro-retina/


May 29, 2013 | 11:18 am

For optimal graphics performance on retina devices at the cost of resolution, I would suggest that you disable retina support on the Max application. Get Info on the application in the finder and check the box for "Open in Low Resolution".


May 30, 2013 | 7:07 am

Sometimes it helps resetting the System Management Controller (SMC)

http://support.apple.com/kb/HT3964

https://us.battle.net/d3/en/forum/topic/6606352204

http://forums.macrumors.com/showthread.php?t=1451750

This worked on a MacBook Pro Retina as well as a non-Retina MacBook Pro from this year when the framerate suddenly dropped to about 16 fps. After the reset it went back to 60 fps.


June 5, 2013 | 1:02 pm

@Joshua Kit Clayton: I really really really like the added screen real-estate micro-pixel give me. I’m spoiled, i know, and I’m shameful.

 

@Karl Kliem: thanks, will try it right now.


Viewing 5 posts - 1 through 5 (of 5 total)