rewire AGAIN

Oct 18, 2006 at 6:07pm

rewire AGAIN

i am very close to throwing my computer out the window

been sitting here for 2 hours today trying to get logic and max msp to speak to each other with rewire. when i change drivers to rewire in MSP it crashes max msp, in such a way that i cannot force quit, it stays in the dock and i have to restart the computer. this also happens if i quit while rewire driver is running, i cannot restart max msp, and it remains active in the dock. tried every combination.

i can never work out how to use rewire properly…whatever order i do stuff in , it seems to work for a while, then just either not start up in max, or crash max. i am seriously going to destroy my computer if i cant sort this out its wasting my life

#28235
Oct 18, 2006 at 6:21pm

On Oct 18, 2006, at 11:08 AM, bin ray wrote:

>
> i am very close to throwing my computer out the window
>
> been sitting here for 2 hours today trying to get logic and max msp
> to speak to each other with rewire. when i change drivers to rewire
> in MSP it crashes max msp, in such a way that i cannot force quit,
> it stays in the dock and i have to restart the computer. this also
> happens if i quit while rewire driver is running, i cannot restart
> max msp, and it remains active in the dock. tried every combination.
>
> i can never work out how to use rewire properly…whatever order i
> do stuff in , it seems to work for a while, then just either not
> start up in max, or crash max. i am seriously going to destroy my
> computer if i cant sort this out its wasting my life

Cycling has a good tutorial up for this:

http://www.cycling74.com/story/2006/9/18/121516/485

The step order Darwin lists is what I’ve been using for awhile.
Works like a charm here, but you have to remember to set the audio
driver back to something other than ReWire in the DSP Status panel
before quitting Max or it will hang.

From the tutorial:

1. You set up Max/MSP to speak to ReWire.
2. You start your host application.
3. You create a channel in the host to accept Max/MSP input.
4. You create (or load) a Max/MSP patch and turn on the DSP output.

Vlad

Vlad Spears
Urbi et orbi
http://www.daevlmakr.com

http://www.2secondfuse.com

#86495
Oct 18, 2006 at 6:26pm

Versions? OS details? Let us know exactly what you’re doing and we’ll try and follow along.

First try deleting all rewire stuff on your drive and then install the latest ReWire ( 1.7 ) from Propheads site. Delete the rewire device aliases and then try and start from scratch.

-A

#86496
Oct 18, 2006 at 6:30pm

os x 10.4.7
logic express 7
max msp 4.5.7
rewire 1.7

im going for a long walk

#86497
Oct 18, 2006 at 8:51pm

nope
max says it cant start the rewire driver, and then if i try to change to another driver to quit and try again, max hangs and i have to restart.

#86498
Oct 18, 2006 at 8:58pm

Is there some reason why you are using 4.5.7?

ReWire in 4.5.7 is created using an earlier version of the ReWire libs. It may be that either going to 4.6.2 or deleting all the 1.7 stuff might help you get there, however nonsensical it might seem. I have seen problems trying to get rewire working across versions.

-A

#86499
Oct 18, 2006 at 9:57pm

sorry i’m using 4.6.1

#86500
Oct 18, 2006 at 10:22pm

are there some preferences i can trash to get Max to register as a rewire device again? it doesnt appear in Live as a device any more. and Max isnt aware of Logic Express when i start it up.

i dont understand why, it worked this morning

so far i’ve updatd to MSP 4.6.2 and installed the latest rewire driver 1.7 from propellorheaed site

#86501
Oct 18, 2006 at 10:26pm

search your hard drive for

“MaxMSP Rewire Device”

And delete any you find.

-A

#86502
Oct 18, 2006 at 11:03pm

i just tried that to no avail, although i just got Live to work together with max via rewire ok.
but Logic just wont work. just selecting or deselecting ad_rewire while logic is running will crash max msp requiring restart. no midi or audio is exchanged, though max msp appears in the rewire device menu

#86503
Oct 18, 2006 at 11:13pm

and i’ve just tried reinstalling logic express too. no joy

#86504
Oct 20, 2006 at 11:50am

still cant get this to work. dont know what else to try. there nothing about this on the logic user forum….
just cant start the ad_rewire driver when logics running

#86505
Oct 21, 2006 at 3:29pm

sorry to bump this again, i urgently need these programs to work together for my project, they were working, now they arent, i’m totally stuck, tried everything i can think of..

i just cant get logic express to talk to max, any ideas please?

#86506
Oct 22, 2006 at 1:56pm

bin,
I was having the same problem as you descirbe. Here’s what I did to fix the problem. After restarting the computer on last Max/MSP hangup, I

1) Deleted all files called “MaxMSP Rewire Device”

2) went to http://www.propellerheads.se/download/ and got the most recent version of Rewire (ver. 1.7)

3) Repaired disk permissions (not sure this was needed but did it anyway)

4) started Logic then started Max/MSP

5) then I open the patches from my site called “MaxLogicRewire”.
http://home.lagrange.edu/mturner/
click the “logic help file” link at the top. On the logic help files page, there is a Max Patch, a Logic file, and a text file describing how to Rewire the two applications together. Doubt you need these but they are there if you want to give them a go.

I am using PowerBook (1.5) PPC, OS 10.4.8, Max/MSP 4.6.2 LogicPro 7.2.3

All worked as expected. Hope this helps you,
Mitch

#86507
Oct 23, 2006 at 3:27pm

thanks i’ll try that…it seems to be a problem specifically with logic express, since i’ve got logic gold 6.3.1 and Ableton to work with max now. i’m pretty sick of rewire/logic’s eccentricities now though….just going to record stuff in max and edit it later..

#86508

You must be logged in to reply to this topic.