sah~ thing i don't seem to understand

Apr 9, 2007 at 5:59pm

sah~ thing i don't seem to understand

the following patch, in my mind, once the metro is turned on, should give me an ascending number from the snapshot~. why doesn’t it? is there something about sah~ that i am not getting?

#P toggle 152 118 15 0;
#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P newex 150 137 52 196617 metro 10;
#P button 94 239 15 0;
#P flonum 98 206 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 96 177 55 196617 snapshot~;
#P newex 39 72 40 196617 +~ 1.;
#P newex 134 79 55 196617 phasor~ 1;
#P newex 84 110 49 196617 sah~ 0.02;
#P window linecount 3;
#P comment 213 89 100 196617 WHY DOESN’T THE OUPUT FROM SAH~ ASCEND?;
#P connect 7 0 4 0;
#P connect 2 0 1 1;
#P connect 3 0 1 0;
#P connect 8 0 7 0;
#P fasten 1 0 3 0 89 140 10 140 10 39 44 39;
#P connect 1 0 4 0;
#P connect 4 0 5 0;
#P connect 5 0 6 0;
#P window clipboard copycount 9;

#31268
Apr 9, 2007 at 6:12pm

you can do it like this:

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P newex 83 32 62 9109513 receive~ add;
#P newex 82 160 51 9109513 send~ add;
#P window setfont Geneva 9.;
#P flonum 151 32 35 9 0 0 0 201 0 0 0 221 221 221 222 222 222 0 0 0;
#P user number~ 13 118 70 132 9 201 3 2 0. 0. 0 0. 250 0. 0 0 0 221 221 221 222 222 222 0 0 0;
#P user scope~ 343 133 473 263 256 3 128 -1. 1. 0 0. 0 0. 102 255 51 135 135 135 0;
#P user ezdac~ 254 206 298 239 0;
#P toggle 188 118 15 0;
#P window setfont “Sans Serif” 9.;
#P newex 188 137 52 9109513 metro 10;
#P button 166 252 15 0;
#P flonum 166 219 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 166 190 55 9109513 snapshot~;
#P newex 83 66 29 9109513 +~ 1.;
#P newex 128 61 55 9109513 phasor~ 1;
#P newex 83 118 44 9109513 sah~ 0.5;
#P window linecount 3;
#P comment 221 60 100 9109513 WHY DOESN’T THE OUPUT FROM SAH~ ASCEND?;
#P connect 1 0 13 0;
#P connect 1 0 4 0;
#P connect 14 0 3 0;
#P connect 3 0 11 0;
#P connect 3 0 1 0;
#P connect 2 0 1 1;
#P connect 2 0 10 0;
#P connect 12 0 3 1;
#P connect 5 0 6 0;
#P connect 4 0 5 0;
#P connect 8 0 7 0;
#P connect 7 0 4 0;
#P window clipboard copycount 15;

jl

#101340
Apr 9, 2007 at 6:13pm

Ah…figured this out. Looks like this thread answers the question:

http://www.cycling74.com/forums/index.php?t=msg&goto=100545&rid=0&srch=msp+loop#msg_100545

Modified patch:

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P newex 176 125 92 196617 receive~ feedback;
#P newex 137 225 78 196617 send~ feedback;
#P toggle 288 196 15 0;
#P newex 286 215 52 196617 metro 10;
#P button 230 317 15 0;
#P flonum 234 284 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 232 255 55 196617 snapshot~;
#P newex 175 150 40 196617 +~ 1.;
#P newex 270 157 55 196617 phasor~ 1;
#P newex 220 188 63 196617 sah~ 0.02;
#P window linecount 3;
#P comment 349 167 100 196617 WHY DOESN’T THE OUPUT FROM SAH~ ASCEND?;
#P connect 1 0 9 0;
#P connect 10 0 3 0;
#P connect 3 0 1 0;
#P connect 5 0 6 0;
#P connect 1 0 4 0;
#P connect 7 0 4 0;
#P connect 4 0 5 0;
#P connect 2 0 1 1;
#P connect 8 0 7 0;
#P window clipboard copycount 11;

#101341
Apr 9, 2007 at 6:24pm

Nothing’s happening because you have a feedback loop – use send~ and
receive~ and it works.


Owen

joshua goldberg wrote:
> the following patch, in my mind, once the metro is turned on, give me
> an ascending number from the snapshot~. why doesn’t it? is there
> something about sah~ that i am not getting?
>

#101342
Apr 9, 2007 at 6:25pm

#101343
Apr 9, 2007 at 6:29pm

Because you have feedback in your signal path. Use send~/receive~ if
you need to do this. Here is another way you might try and accomplish
this same thing:

#P user ezdac~ 211 195 255 228 0;
#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P newex 104 119 26 196617 +=~;
#P newex 104 98 52 196617 ==~ 0.01;
#P toggle 159 125 15 0;
#P newex 157 144 52 196617 metro 10;
#P flonum 102 204 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 103 184 55 196617 snapshot~;
#P newex 104 78 55 196617 phasor~ 1;
#P window linecount 3;
#P comment 220 96 100 196617 WHY DOESN’T THE OUPUT FROM SAH~ ASCEND?;
#P connect 6 0 7 0;
#P connect 1 0 6 0;
#P connect 7 0 2 0;
#P connect 2 0 3 0;
#P connect 5 0 4 0;
#P connect 4 0 2 0;
#P window clipboard copycount 9;

best,
Andrew B.

#101344
Apr 9, 2007 at 6:32pm

Could be a problem with the feedback loop?

FWIW – As long as that feedback loop is connected, I don’t get any
measured output from [sah~] at all. Disconnect it and hook up a
different input into [sah~] and all is well.

On Apr 9, 2007, at 11:59 AM, joshua goldberg wrote:

>
> the following patch, in my mind, once the metro is turned on, give
> me an ascending number from the snapshot~. why doesn’t it? is
> there something about sah~ that i am not getting?
>

—-
Steven M. Miller

Home < http://pubweb.csf.edu/~smill>
SFIFEM <
http://sfifem.csf.edu>
Atrium Sound Space <
http://atrium.csf.edu>
OVOS <
http://pubweb.csf.edu/~smill/ovos.html>

#101345
Apr 9, 2007 at 6:43pm

It wasn’t sah~. Let me know what you think of this:

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P comment 425 208 100 196617 does this do it?;
#P newex 72 93 39 196617 noise~;
#P toggle 166 132 15 0;
#P newex 164 151 52 196617 metro 10;
#P button 108 253 15 0;
#P flonum 112 220 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 110 191 55 196617 snapshot~;
#P newex 148 93 55 196617 phasor~ 1;
#P newex 98 124 63 196617 sah~ 0.02;
#P message 315 210 33 196617 set 0;
#P user number~ 353 266 428 281 9 3 3 2 0. 0. 0 0. 250 0. 0 0 0 221
221 221 222 222 222 0 0 0;
#P newex 352 238 26 196617 +=~;
#P newex 352 208 52 196617 ==~ 0.02;
#P user ezdac~ 414 89 458 122 0;
#P newex 352 182 55 196617 phasor~ 1;
#P window linecount 3;
#P comment 67 290 100 196617 nothing is wrong with sah~ , it was the
accumulating;
#P connect 14 0 7 0;
#P connect 10 0 11 0;
#P connect 12 0 9 0;
#P connect 7 0 9 0;
#P connect 9 0 10 0;
#P connect 8 0 7 1;
#P connect 13 0 12 0;
#P connect 1 0 3 0;
#P connect 6 0 4 0;
#P connect 3 0 4 0;
#P connect 4 0 5 0;

Keith

On 4/9/07, joshua goldberg wrote:
>
> the following patch, in my mind, once the metro is turned on, give me an ascending number from the snapshot~. why doesn’t it? is there something about sah~ that i am not getting?
>
> #P toggle 152 118 15 0;
> #P window setfont “Sans Serif” 9.;
> #P window linecount 1;
> #P newex 150 137 52 196617 metro 10;
> #P button 94 239 15 0;
> #P flonum 98 206 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
> #P newex 96 177 55 196617 snapshot~;
> #P newex 39 72 40 196617 +~ 1.;
> #P newex 134 79 55 196617 phasor~ 1;
> #P newex 84 110 49 196617 sah~ 0.02;
> #P window linecount 3;
> #P comment 213 89 100 196617 WHY DOESN’T THE OUPUT FROM SAH~ ASCEND?;
> #P connect 7 0 4 0;
> #P connect 2 0 1 1;
> #P connect 3 0 1 0;
> #P connect 8 0 7 0;
> #P fasten 1 0 3 0 89 140 10 140 10 39 44 39;
> #P connect 1 0 4 0;
> #P connect 4 0 5 0;
> #P connect 5 0 6 0;
> #P window clipboard copycount 9;
>
>

#101346
Apr 9, 2007 at 7:00pm

feedback

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P newex 89 96 63 196617 receive~ uu;
#P newex 88 211 49 196617 send~ uu;
#P user number~ 77 169 116 184 9 3 3 2 0. 0. 0 0. 250 0. 0 0 0 221 221
221 222 222 222 0 0 0;
#P user number~ 166 200 205 215 9 3 3 2 0. 0. 0 0. 250 0. 0 0 0 221 221
221 222 222 222 0 0 0;
#P toggle 212 178 15 0;
#P newex 210 197 52 196617 metro 10;
#P button 154 299 15 0;
#P flonum 158 266 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 156 237 55 196617 snapshot~;
#P newex 99 132 40 196617 +~ 1.;
#P newex 194 139 55 196617 phasor~ 1;
#P newex 144 170 63 196617 sah~ 0.02;
#P window linecount 3;
#P comment 273 149 100 196617 WHY DOESN’T THE OUPUT FROM SAH~ ASCEND?;
#P connect 12 0 3 0;
#P connect 1 0 11 0;
#P connect 1 0 4 0;
#P connect 1 0 9 0;
#P connect 3 0 10 0;
#P connect 3 0 1 0;
#P connect 5 0 6 0;
#P connect 4 0 5 0;
#P connect 8 0 7 0;
#P connect 2 0 1 1;
#P connect 7 0 4 0;
#P window clipboard copycount 13;

joshua goldberg wrote:
> the following patch, in my mind, once the metro is turned on, give me an ascending number from the snapshot~. why doesn’t it? is there something about sah~ that i am not getting?
>
> #P toggle 152 118 15 0;
> #P window setfont “Sans Serif” 9.;
> #P window linecount 1;
> #P newex 150 137 52 196617 metro 10;
> #P button 94 239 15 0;
> #P flonum 98 206 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
> #P newex 96 177 55 196617 snapshot~;
> #P newex 39 72 40 196617 +~ 1.;
> #P newex 134 79 55 196617 phasor~ 1;
> #P newex 84 110 49 196617 sah~ 0.02;
> #P window linecount 3;
> #P comment 213 89 100 196617 WHY DOESN’T THE OUPUT FROM SAH~ ASCEND?;
> #P connect 7 0 4 0;
> #P connect 2 0 1 1;
> #P connect 3 0 1 0;
> #P connect 8 0 7 0;
> #P fasten 1 0 3 0 89 140 10 140 10 39 44 39;
> #P connect 1 0 4 0;
> #P connect 4 0 5 0;
> #P connect 5 0 6 0;
> #P window clipboard copycount 9;
>
>

#101347

You must be logged in to reply to this topic.