Forums > MaxMSP

sample playback problem

May 6, 2010 | 5:46 pm

ezz all, apologies as im sure this has come up before but i cant seem to find anything that answers my question. im an utter max noob, ive got a basic one shot sample player, but the length of the samples is being cut short.

im wondering where abouts and what object i need to use to be able to control the sample length? i cant figure if im meant to input something into the buffer object or before the play~ object


May 6, 2010 | 5:53 pm

Perhaps the soundfile is too large for your [buffer~]; this can happen if you give the buffer a default size as an argument; also the [play~] object might have a "play from – play to" message somewhere, but you need to post your patch so we can diagnose and solve your issue. The quickest solution is to send the [buffer~] a message with this word: replace. This will resize the buffer to fit your chosen file.


May 6, 2010 | 6:12 pm

muchos gracias! can see what i did now, the values i was inputting into play~ were way off.

while im here, how do i save my patch so all the samples are included when i load on another computer?


May 6, 2010 | 6:35 pm

If they are ‘non-native’ soundfiles, i.e. your own, then the samples will obviously need to be moved to the other computer; then you will have to inform Max of the new folder/file-path, via Options/File Preferences.


May 6, 2010 | 7:39 pm

yeh they are my own sounds, saved on the desktop in the same folder as the patch. how do i get the patch to load with the sounds in automatically? (so i dont have to load them individually each time)


May 6, 2010 | 8:43 pm

umm, I think you need [loadbang] -> message "preload mySoundfile.aif" -> [sfplay~]; look at the helpfile for the [sfplay~] object. The preload message has to follow a certain syntax (using cue numbers if I remember correctly).


May 6, 2010 | 10:18 pm

last one – how the hell do i record? ive tried a really basic thing with sfrecord~ and adoutput~ . its creating the files but they are only a few kb and they wont open (quicktime gives me an error notification and media player wont open the wavs) so yeh it seems to be creating the file but not recording

thanks for your help


May 6, 2010 | 10:43 pm

you can use the extra called ‘quick record’. its up in one of the menus, under ‘extras’ i think


Viewing 8 posts - 1 through 8 (of 8 total)