Sampling : what's wrong ?

Nov 15, 2011 at 8:42am

Sampling : what's wrong ?

I have a really hard time trying to build something for a live sampling patch, and problems arise with even the most basic stuff. So I try to start with very simple elements to figure out where I miss the point. See below. One thing I noticed is, contrarily to what is written in the buffer~help file, the length argument doesn’t seem to be optional. If I don’t give one, the buffer takes a given length which seems to be always the same (see attached picture), no waveform appears and it doesn’t play sound. Can someone please confirm that ? So i add a length and the buffer recording works. But, if I want a variable length recording, it seems I’m stuck, because the buffer will always be of that given length… By the way, I’m a stubborn guy so I want to play that buffer and build something like msp tut17. This is the patch below. And the buffer doesn’t play… No message in the Max window.

max 5.1.9, mbp 2,4 ghz OSX 10.5.8

– Pasted Max Patch, click to expand. –

`
[attachment=176343,2905]

Attachments:
  1. Image3.png
#60023
Nov 15, 2011 at 9:30am

The length is only optional if your are loading the buffer with files using replace.

Here’s your patch edited, slightly. It works here, now.

– Pasted Max Patch, click to expand. –
#216103
Nov 15, 2011 at 9:33am

Stephane,

the size argument is indeed optional (it will be set when you load a file into the buffer with replace), but it you want to do live sampling, then as you noticed you have to give a maximum size to your buffer. Analysing the output of record~ when you stop to record (a value between 0 and 1) will tell you how long your recording is.

Then you’ll need to adjust your groove settings to stop at the end of the recording.

In your patch, you should remove the line~ object, then you’ll hear something.

Here are some small modifications to your patch (r starts & stops the recording):
If you want to build a clean patch, then you’ll have to add fadein & fadeout to the input when you start and stop your recording to avoid clicks.

– Pasted Max Patch, click to expand. –
#216104
Nov 15, 2011 at 11:21am

As usual , such a great feedback, even for beginners like me. You are great, guys… and I’ll soon be back with some silly questions regarding sfplay !

#216105

You must be logged in to reply to this topic.