Forums > MaxMSP

Save coll data with patcher not working

February 23, 2011 | 2:22 am

Hey all,

This has been bugging me for the past few months. I can’t for the life of me figure out how to get the "save data with patcher" attribute of the coll object to function properly. Let me know if this sequence of events is normal or not. I could swear that when I first started using Max I didn’t have this difficulty:

1) I create a new coll object and check the "save data with patcher" attribute in the inspector.
2) I open the coll by double-clicking and input my data.
3) I close the coll. Max asks me if I want to save the coll as a text file to my hard drive. If I don’t, the data is lost.

The only real problem here is that I end up with a lot of miscellaneous .txt files in my Max folder, which is annoying, but not much else. But isn’t there a way to get Max to, well, save the coll data as part of the patcher? Am I missing something?

Thanks,
Phil


February 23, 2011 | 7:33 am

> 3) I close the coll. Max asks me if I want to save the coll as a text file to my hard drive.
> If I don’t, the data is lost.

This step is the extraordinary one. Normally not a dialogue for saving should appear, but simply a confirmation request whether you want to keep the edits. Somehow max cannot write the data into coll and instead asks you to save it externally. What version of max and system are you working on? If you save the patch on another drive (or usb stick) does it work as expected?


February 24, 2011 | 12:34 am

I’m both relieved and upset to learn that there is indeed something weird going on.

I’ve got Max 5.1.7 on a MacBook running OS 10.6.6.

A small correction to 3) above:
After inputting text into the coll (with "save data .." checked), if I close the coll, Max asks "Store changes to ‘[name of coll]‘ before closing?". Clicking SAVE closes the coll, and the data is lost.
And if I save the coll, I get the save-a-file dialogue box. Normal behavior, I remember, is for the patcher — not the coll — to be saved when I input CMD-S and "save data" is checked.

This behavior is unchanged whether the patcher is on my hard disk or on my thumb drive.

I’ve got no clue what could be causing this — and I’ve tried reinstalling Max. Any bright ideas would be appreciated.

Phil


February 24, 2011 | 11:19 am

Hi,
When you input your data to the coll, are you using semi-colons at the end of each line?
The steps I usually take when using coll is:
- instantiate a new coll object,
- check the ‘save data with patch’ attribute
- enter the data, using semi-colons at the end of each line
- save the data to text file

When I re-open the coll, the data is still there and is stored with patch. I usually then put the text file to the trash.


February 25, 2011 | 12:22 am

This works! I didn’t realize that it wasn’t necessary to keep the .txt file, and I’m glad to see that coll is able to keep ahold of the data without it.

Thank you!


February 25, 2011 | 12:40 am

I’ve used Coll a lot in the last 2 months.

My impression is that Max parses into internal format ("02" for example, becomes "2") and regenerates the coll contents when storing stuff. If the parsing fails, it does not stop and warn you, it just fails – sometimes with a message to the log.
If it has created some lines, then that is what is saved. This has been very fustrating at times, since a missing semi-colon can cost one hours of work.

This, INMSHO, comes very close to being a bug, especially since it will make me very least reluctant to have allow users to edit their own colls, which would be a *very* nice option in my new project.
Ken, MusicScienceGuy


Viewing 6 posts - 1 through 6 (of 6 total)