saving patches always brings up file dialog

Jan 18, 2009 at 8:25pm

saving patches always brings up file dialog

hey all,

i’m just starting to use Max5 and it would seem (10.5 MacBook Pro, Max 5.0.5) that I can’t save (overwrite) patches using Command + S or the file menu without Max poppin’ up the ‘ol file menu.

what gives? anyone else seen this?

cheers,
jamie

#41828
Jan 18, 2009 at 9:06pm

You should be able to use cmd+S, maybe your permissions are set to prevent
you overwriting the files? You can check this by selecting a file and
choosing get info. (I’ve never used 10.5 though stil on 10.4)

pelado

> i’m just starting to use Max5 and it would seem (10.5 MacBook Pro, Max
> 5.0.5) that I can’t save (overwrite) patches using Command + S or the file
> menu without Max poppin’ up the ‘ol file menu.
>
> what gives? anyone else seen this?
>
>

#149130
Jan 18, 2009 at 9:21pm

or you’ve got a character in it that’s making it difficult, like a
slash.

On Jan 18, 2009, at 4:06 PM, pelado wrote:

> You should be able to use cmd+S, maybe your permissions are set to
> prevent you overwriting the files? You can check this by selecting
> a file and choosing get info. (I’ve never used 10.5 though stil on
> 10.4)
>
> pelado
>
>
> i’m just starting to use Max5 and it would seem (10.5 MacBook Pro,
> Max 5.0.5) that I can’t save (overwrite) patches using Command + S
> or the file menu without Max poppin’ up the ‘ol file menu.
>
> what gives? anyone else seen this?
>
>

#149131
Jan 18, 2009 at 9:49pm

On 18 Jan 2009, at 21:06, pelado wrote:

> You should be able to use cmd+S, maybe your permissions are set to
> prevent you overwriting the files? You can check this by selecting
> a file and choosing get info. (I’ve never used 10.5 though stil on
> 10.4)

As I recall, Max5 will prompt to save its new-format (.maxpat) files
if you’ve opened old Max4-format ones.

– N.

Nick Rothwell / Cassiel.com Limited
http://www.cassiel.com
http://www.myspace.com/cassieldotcom
http://www.last.fm/music/cassiel
http://www.reverbnation.com/cassiel
http://www.linkedin.com/in/cassiel
http://www.loadbang.net

#149132
Jan 18, 2009 at 10:13pm

On 18 janv. 09, at 22:49, Nick Rothwell wrote:

>> You should be able to use cmd+S, maybe your permissions are set to
>> prevent you overwriting the files? You can check this by selecting
>> a file and choosing get info. (I’ve never used 10.5 though stil on
>> 10.4)
>
> As I recall, Max5 will prompt to save its new-format (.maxpat) files
> if you’ve opened old Max4-format ones.

That’s correct, but once it’s a maxpat, it shouldn’t bring the save
dialog box unless there’s some permissions issues.

Best,
ej

#149133
Jan 18, 2009 at 11:09pm

bah – there WAS a slash way up a few levels that i didn’t see – cheers y’all!

#149134
Jan 18, 2009 at 11:17pm

I’ve been having the same issue and it was driving me crazy. Sometimes it just saved, and sometimes I would have to overwrite it. I think this would happen whenever saving the patch outside of the max search path because now its fine.

Andrew

#149135
Jan 19, 2009 at 11:17am

Another thing that can happen is if your patch is sending a ‘patcher ‘ message to thispatcher. The name change causes Save to bring up the Save As… dialog to confirm the new name.

I find this scenario usually easier to track down than permissions issues, but it can also be a gotcha.

#149136
Jan 31, 2009 at 4:59am

I’m having the exact same problem, but in my case, it seems to be dependent on which of my two computers I’m using. If I create a new patcher and just put a single message box in it and save it with the name test.maxpat, I am initially prompted–as expected–to give the file a name. BUT, if I reopen that file on my Desktop computer (G4, OS 10.4.11) and make any change to the file and choose save (cmd-s), I am prompted to give the file a name and if I use the same name am told that there is an older file with the same name…

If I do the exact same thing on my laptop (Intel Core 2 Duo, OS 10.5.6) it works just fine–no prompt to name the file, etc.

#149137
Jan 31, 2009 at 5:06am

BTW, I checked permissions and they are set to read & write, and the patch is so simple that the problems like thispatcher don’t apply for me. I just always get prompted with a file dialog whenever I choose “Save” (cmd-s) on my G4 and I don’t on my Intel PowerBook.

#149138
Feb 1, 2009 at 4:05pm

Hi, I’m an italian user, and I have the same problem:

I can’t save a file without overwriting, but until a few days ago this function has worked…
maybe the cause is a displacement of files that i’ve made on the last week.. can you help me?

thanx a lot

#149139
Feb 1, 2009 at 6:35pm

Can you provide some specific information about your computer and operating system. I experience the problem on one computer, but not the other.

Computer 1–save works as expected
Mac 2.4 GHz Intel Core 2 Duo PowerBook, 10.5.6, Max/MSP 5.0.5

Computer 2–always prompts to overwrite when saving
Mac Dual 1 GHz PPC G4, 10.4.11, Max/MSP 5.0.5

#149140
Feb 1, 2009 at 7:41pm

mine was doing it for a while, i think i changed something in settings or preferences and it sorted it out.

#149141
Feb 1, 2009 at 7:49pm

#149142
Feb 1, 2009 at 10:10pm

Yep, that was it…

I had a folder 2 levels up with a slash in the name. Thanks!!!

#149143
Feb 2, 2009 at 1:23pm

Quote: joshua goldberg wrote on Sun, 01 February 2009 20:49
—————————————————-
> do you have a suspect character in your file name or path? a slash
> perhaps?
—————————————————-

YES! I was a little careless, That’s the second time that you write this!

many thanks,

M.

#149144
Jul 2, 2012 at 2:29am

Do spaces also cause this issue? I have neither slashes or any special characters in any of my upper level folder naming, as well as the file.

#149145

You must be logged in to reply to this topic.