Forums > Jitter

scaling of textures for syphon and or jit.gl.texture

January 22, 2012 | 3:43 am

Hey,

I have just jumped back into Jitter after a few years away! I have tried to search the forums for answers, but I don’t think I’m asking the right questions.

Basically Im using a small 4 jit matrix 16 x 16, as the input for a jit.gl.texture

When the texture is rendered on a plane, the divisions of the 16×16 matrix become soft, a sort of interpolation between each matrix cell.

I’m pretty sure this has something to do with the auto scaling of the texture object?

I’m fairly sure the jit.gl.gridshape doesn’t have a specific pixel by pixel size – so how am I to determine the size of a mesh to create if i want to map a 16 x 16 matrix to it in a ratio of 1:1.

I realise I can render this without resorting to GL, but in order to send this image to SYPHON for use in VDMX, I need to render my graphic as a texture.

Thanks so much for any help

Cheers
Tim


January 22, 2012 | 3:45 am

here is an image of as far as I have got!!

[attachment=182876,3236]

Attachments:
  1. maxTextureIssue.png

January 22, 2012 | 1:25 pm

After a few hours I managed to sort it all out!

it came down to the size of the texture, and the interpolation method – both on the jit.render object.


January 22, 2012 | 2:38 pm

which messages? You can’t set texture size on the jit.gl.render, as far as I know? Would you mind posting what you ended up with as CopyCompressed, so I may take a look?


January 22, 2012 | 7:17 pm

you can set a gl.textures dimensions by setting the @dim attribute and setting @adapt 0 (by default this is 1, causing the texture to automatically set it’s dimensions to that of the render context window).

you can turn off interpolation by setting the gl.texture attribute @filter to "none"


Viewing 5 posts - 1 through 5 (of 5 total)