Forums > Dev

SDK & XCode 4.1 ?

October 1, 2011 | 12:30 pm

hi mates,
I have a basic problem.
I'm trying to use the sdk with XCode 4.1 which provides a very basic error at the beginning about the Scheme which is 64bits etc.

Anyone could help by unsticking me ??

[attachment=171888,2685]

Attachments:
  1. Capturedcran2011100114.29.02.png

October 1, 2011 | 2:26 pm

To my knowledge, Max is 32 bit only. Go into your project settings and for build type get rid of the x86_64. It’s safe to keep it under valid architectures.


October 1, 2011 | 2:28 pm

yep I tried
probably I missed something
I’ll retest asap
thanks a lot :)


October 1, 2011 | 2:32 pm

I don’t know if it’s the same for 4.1 but in 3.2 you have to click Edit project settings on both the project root and on the build product. Sometimes just doing one or the other doesn’t do both.


October 1, 2011 | 3:23 pm

problem was (just) :

the Xcode Project file required 10.4 sdk .. I changed that for 10.7 and it is okay now (the scheme has switched on 32bits etc)

thanks again


Viewing 5 posts - 1 through 5 (of 5 total)