Send to Back Bug

Apr 28, 2008 at 6:00pm

Send to Back Bug

I think I found what may be a bug. That or I’m doing something wrong. I included an example patch to show what I’m talking about. I have a bunch of coment boxes and am trying to put a panel behind them but not matter what I do, the panel stays on top of the comment boxes. I tried all the different ways of sending it to the back or bringing the comment boxes to the front. The weird thing is it’s unpredictable to what comment boxes it happens to. Can anyone else recreate this or is just something I’m doing wrong.

– Pasted Max Patch, click to expand. –
#37343
Apr 28, 2008 at 6:05pm

Check “Include in Background” under “Arrange”.

#128979
Apr 28, 2008 at 6:08pm

Ah thanks. I don’t know how those comment boxes got into the background but all is well now. Thanks.

#128980
Apr 28, 2008 at 6:11pm

Hey since I helped you could you check the “key” object help file and see if it outputs both ASCII and Key Code for you, or if it just Outputs two streams of ASCII like it does for me? It’ll just take a second. Just type some keys.
( :

I’m going crazy, methinks.

#128981
Apr 28, 2008 at 6:14pm

I had the same exact weirdness happen. You patch opened up where the panel wouldn’t go to the back. Selecting the object and
using “Arrange > Include in background” pops it into the back. After that it seems to be fine with send to back and bring to front.

I had this happening on Windows and OSX.
I was hoping 5.0.1 would fix this, but i guess not. Or is it supposed to be this way? Either way it’s confusing and annoying since it doesn’t happen all the time.Here’s the same exact patch, only thing I did was include in background on the panel.
Now it pops forwards or backwards no problem. Weird buggy behavior?

– Pasted Max Patch, click to expand. –
#128982
Apr 28, 2008 at 6:16pm

Nevermind, didn’t see the next posts. :)

#128983
Apr 28, 2008 at 6:18pm

I’ve tried the key object and both the middle and left output send out the same numbers. I’ve seen this discussed before on this forum and can’t remember if it is a bug or the new behavior for [key].

#128984
Apr 28, 2008 at 6:45pm

On Apr 28, 2008, at 11:00 AM, Theo wrote:
> Can anyone else recreate this or is just something I’m doing wrong.

The comments are included in the background, the panel is not.

Objects have a Z-axis, but only within their layer. If you want the
comments to be above the panel, either they need to be removed from
the background layer, or the panel needs to be added to the background
layer.

Chris Muir
cbm@well.com

http://www.xfade.com

#128985
Apr 28, 2008 at 7:49pm

There are two layers in Max. Each layer is a list of things drawn in order from back to front, and Send to Back / Bring to Front work on each layer separately.

When something is removed from the background, it goes to rear-most position in the foreground. You can see this because if you select the object you just removed from the background, the “Send Backward” icon is disabled in the patcher toolbar.

I’m not sure which example I should be looking at, but the most recently posted example shows some comments and a panel. Both the comments and the panel are in the background. If you select the panel and remove it from the background, it moves in front of all the comments. This is how it is supposed to work, and how Max since 4.0 has always worked.

David Z.

#128986

You must be logged in to reply to this topic.