Sending 1 then undefinied amount of 0

Oct 29, 2008 at 5:53pm

Sending 1 then undefinied amount of 0

Hello everybody , i know this topic name looks strange but didnt find anything else to describe.

Im looking a way for a bang to send ONLY ONE “1″ then an undefined list of “0″. (1.0.0.0.0.0…..)
Then when i click on another bang it resets this list and start again with (1.0.0.0)

(a kind of [toggle] that stays on 1)

I know this sounds a bit lame question but im really stucked on it for one hour now.

Thanks a lot and excuse for my english.

#40564
Oct 29, 2008 at 6:06pm

Use a [gate 2] object.

Initialize the gate to open up the first outlet (i.e. send a 1 to the right inlet of the gate).

Send a bang through the left inlet of the gate.

Connect the left outlet of the gate to a [t 1 2] object. The left outlet of the trigger object is where your “1″ message will come from. The right outlet of the trigger outlet should get connected back up to the right inlet of the gate object. This will set the gate to open the second outlet.

Connect the second outlet of the gate object to a message box with a 0 in it. This is where your “0″ message will come from.

See how that works? Each time the “1″ message is triggered, it switches the gate back to route the bangs over to the “0″ message. If you ever need to send out another lone “1″ message again, just open the first outlet of the gate object by sending a 1 to the right inlet of it.

#143660
Oct 29, 2008 at 6:07pm

I am not quite sure what you are asking for/what you need….

– Pasted Max Patch, click to expand. –
#143661
Oct 29, 2008 at 6:17pm

i am not sure what u are after but i found it interesting from what i have understood ;)

– Pasted Max Patch, click to expand. –

Quote: Tobald wrote on Wed, 29 October 2008 18:53
—————————————————-
> Hello everybody , i know this topic name looks strange but didnt find anything else to describe.
>
> Im looking a way for a bang to send ONLY ONE “1″ then an undefined list of “0″. (1.0.0.0.0.0…..)
> Then when i click on another bang it resets this list and start again with (1.0.0.0)
>
> (a kind of [toggle] that stays on 1)
>
> I know this sounds a bit lame question but im really stucked on it for one hour now.
>
> Thanks a lot and excuse for my english.
—————————————————-

#143662
Oct 29, 2008 at 7:29pm

Thanks for your quick answers. I cant read two last patches cause im still on max 4.6.

Swieser : I tried to follow your instructions but connecting “The right outlet of the trigger outlet should get connected back up to the right inlet of the gate object” causes stack overflow.

So i tried to mix [gate 2] and [t 1 2] in different ways but i think i need to make a pause before my head explodes :)

Could you post a patch for version 4.6 or maybe a screenshot. But yes i see what you trying to explain to me :)

Thanks

#143663
Oct 29, 2008 at 8:29pm

Finally i solved my problems with [onebang] linkend to “0″ and “1″ message :)

Thanks :)

#143664
Oct 29, 2008 at 10:09pm

here is a screen shot of what I had…

#143665
Oct 29, 2008 at 11:40pm

Yeah thats exactly what i needed MIB :)
I did the same but without the [zl group]

Thanks again dudes.

#143666
Oct 30, 2008 at 1:42am

Here’s the patch I described above:

– Pasted Max Patch, click to expand. –
#143667
Oct 30, 2008 at 1:43am

Sorry, I meant to connect the right outlet of the [t 1 2] object to the RIGHT inlet of the gate object, not the left.

#143668

You must be logged in to reply to this topic.