Forums > Max For Live

Sending from Max4Live to MaxMSP?

November 25, 2013 | 1:01 pm

Hey friendly people,

I’m trying to send bangs from M4L into MaxMSP based on things that occur during my live arrangement. The bangs are all being triggered properly in M4L, and when I go into the device editor and manually press the button, it is properly received in MaxMSP. However, even when keeping the device editor open, the bangs are not received by MaxMSP when they’re triggered by my Ableton playback. It only works when I manually push the button.

Does anybody have any ideas as to why this might be the case, and how I can fix it? I’m not sure if M4L was meant to send data into MaxMSP, but it works manually so I don’t see why it wouldn’t in my situation.

In case it somehow matters: my patch is just midiin into midiparse, first outlet into the button (just for viewing/troubleshooting) straight into a send object, going into a receive object in MaxMSP. I’m just trying to get MaxMSP to count noteon and noteoff messages for one track playing in Ableton. It’s part of a much greater patch that I don’t want to run in MaxForLive.

Thanks a ton!
-n


November 26, 2013 | 4:52 am

I use udpsend and udprecieve.
Set udpsend to 127.0.0.1 (declares host computer) 6002 (number doesn’t matter its the port you send out of)
In max msp create a udprecieve 6002 (same port number) voila !
Try usuing the m4l observer object to send a simple bang when live starts playing to sync both programs, far more reliable and faster than midi.


Viewing 2 posts - 1 through 2 (of 2 total)