sfrecord~ and MIDI problem

Nov 4, 2010 at 8:22pm

sfrecord~ and MIDI problem

Hi folks,
I’m having a bizarre problem with sfrecord~. I’m attempting to use a MIDI footpedal to trigger opening a new file and beginning recording. If I use my alternate trigger method (a number key) everything works great. With any MIDI data, generating exactly the same 1 and 0 through a toggle, I get “start requested without preceding ‘open’” from sfrecord~.

I’ve troubleshooted (troubleshot?) this subpatch in every way I know how. There is no other MIDI anywhere in the mother patch, this is the only place I’m using it. Everything should work exactly the same regardless of triggering method, but somehow my event ordering is getting hosed!

Insights? Ideas?

– Pasted Max Patch, click to expand. –
#53096
Nov 5, 2010 at 12:59am

without knowing the specifics of your pedal, i would try to insert a change object between the top if and the thru.
there might be unwanted repetitions coming from your pedal.

hth
hans

#190945
Nov 5, 2010 at 1:27am

Thanks, Hans. No dice, though. The output of the toggle is identical regardless of the source (I tested by connecting its output to a [sel 0] and counting the bangs out of both of its outputs). Change is a good addition either way, though, so thanks.

#190946
Nov 5, 2010 at 2:03am

Solved. Well, not solved so much as worked around. I put a deferlow object between the 1 and the final toggle going into sfrecord~, and message ordering is preserved now. Still no idea why it should have been disrupted in the first place, but at least now the subpatcher works!

#190947

You must be logged in to reply to this topic.