[Share] V-Module/Jitter Shaders for fractals 2D effects and for 3D materials

Apr 18, 2012 at 8:13pm

[Share] V-Module/Jitter Shaders for fractals 2D effects and for 3D materials

All,

May be you got these already, as I shared them as part of the V-Module tool I made public a year ago, (see http://fabriziopoce.com/max.html), but here a few archives with shaders for fractal generation, a number of ported or original effects for matrix/texture/frame manipulation (both supposed to be used with jit.gl.slab) and a few shaders for lighting/materials (for use with jit.gl.shader and 3D objects).

You can see some of the results on my vimeo page: http://vimeo.com/june74

Cheers
Fabrizio

http://fabriziopoce.com/

#63068
Apr 18, 2012 at 9:51pm

hello Fabrizio,

i would love to have a look into your shaders.

but i dont even get the 2d ones to work.

i put the following folders in my searchpath:
fp-shader-generators
Jitter Shaders Collection
Jitter Shaders Pipeline

if i try to load the 0086-fp.zoom.jxs shader into the slab, i get the following error:

– START GLSL INFO LOG: fp –
ERROR: 0:3: ‘textureSize’ : no matching overloaded function found
ERROR: 0:3: ‘=’ : cannot convert from ‘const float’ to ’2-component vector of float’
– END GLSL INFO LOG: fp –
jit.gl.shader: GLSL program failed to compile.

same behaviour in max5 and max6.

i am on mac 10.6.8

here is my testpatch:

– Pasted Max Patch, click to expand. –

it would be great to have a helpfile or a tip how we can load your shaders.

best,
l.

#227570
Apr 19, 2012 at 9:44am

Hi Lee,

The shader in question (like many other in the same bundle) makes use of the textureSize() GLSL function, which requires Open GL glsl version 1.30 or higher. It is probably not supported on you graphic card GL implementation.

The “0206-fp.kaleid.jxs” for instance does not. You should be able to load this, instead.

If you are practical with glsl you could try to implement a change in the shader to have this:

1) Add this in the vertex shader:
// Create a varying to be passed to the fragment shader
varying vec2 resolution;
….
void main()
{
// Get the texture size in the vertex shader
resolution = vec2 (abs(gl_TextureMatrix[0][0][0]),abs(gl_TextureMatrix[0][1][1]));

}

2) Remove this line in the fragment shader:
vec2 resolution = textureSize(tex0,0);

3) Replace the line just removed with this in the fragment shader:
varying vec2 resolution;

This should be supported in older GLSL implementations.

PS: about the help. May I have some time in the furture I will make some notes. For the time being, sorry, but it is what it is……

Gr
Fabrizio

#227571
Apr 19, 2012 at 3:34pm

Hello Fabrizio,

Thanks for the help.

My macbook pro, i bought last year does only support glgs 1.2
AMD Radeon HD 6750M

So i edided you shades.
I never wrote shader in my life, but i got something working.

I also made a litte helpfile.
Its all in the zip file attached.

some of the shaders have problems with the “gain_t” parameter.

0071-fp.tunnel_mod.jxs
0082-fp.motion-blur_mod.jxs
0084-fp.flashing_mod.jxs

all the best,
l.

#227572
Apr 19, 2012 at 9:07pm

Interesting, I never had issue on my system.
I will check your versions out when I can.

Cheers
Fabrizio

#227573

You must be logged in to reply to this topic.