Forums > Jitter

[sharing is fun] projective texture isosurfer

May 31, 2007 | 7:15 am

Hi everyone,
Here’s a little patch I’ve been having fun with that projects textures
into an isosurface. It even makes the default texture checker pattern
and dishes.mov look interesting. There’s a shader for calculating the
project texture coordinates, a javascript that constructs the
coordinate transform matrices the shader needs, and a patch to run the
thing. enjoy.

http://www.mat.ucsb.edu/~whsmith/ProjTex4.zip

wes


May 31, 2007 | 8:47 am

Hi Wes,

It looks exciting, but after a first glance I don’t get output yet. Is there a secret bang somewhere that I have to press apart from enabling the two metro’s and loading dishes.mov?

OS 10.4.9, Max 4.6.3, jitter 1.6.3

Mattijs

Quote: wesley.hoke@gmail.com wrote on Thu, 31 May 2007 09:15
—————————————————-
> Hi everyone,
> Here’s a little patch I’ve been having fun with that projects textures
> into an isosurface. It even makes the default texture checker pattern
> and dishes.mov look interesting. There’s a shader for calculating the
> project texture coordinates, a javascript that constructs the
> coordinate transform matrices the shader needs, and a patch to run the
> thing. enjoy.
>
> http://www.mat.ucsb.edu/~whsmith/ProjTex4.zip
>
> wes
>
—————————————————-


May 31, 2007 | 1:16 pm

Quote: wesley.hoke@gmail.com wrote on Thu, 31 May 2007 09:15
—————————————————-
> Hi everyone,
enjoy.
>
> http://www.mat.ucsb.edu/~whsmith/ProjTex4.zip
>
> wes
>
—————————————————-

nice ;)


May 31, 2007 | 4:07 pm

You just have to be different don’t you :) On my machine it works
simply by turning on the renderer. What GPU do you have? It works
perfetly on my PB 1.67 osx 10.4.8 Jitter 1.6.3 radeon 9700.

wes

On 5/31/07, Mattijs Kneppers wrote:
>
> Hi Wes,
>
> It looks exciting, but after a first glance I don’t get output yet. Is there a secret bang somewhere that I have to press apart from enabling the two metro’s and loading dishes.mov?
>
> OS 10.4.9, Max 4.6.3, jitter 1.6.3
>
> Mattijs
>
> Quote: wesley.hoke@gmail.com wrote on Thu, 31 May 2007 09:15
> —————————————————-
> > Hi everyone,
> > Here’s a little patch I’ve been having fun with that projects textures
> > into an isosurface. It even makes the default texture checker pattern
> > and dishes.mov look interesting. There’s a shader for calculating the
> > project texture coordinates, a javascript that constructs the
> > coordinate transform matrices the shader needs, and a patch to run the
> > thing. enjoy.
> >
> > http://www.mat.ucsb.edu/~whsmith/ProjTex4.zip
> >
> > wes
> >
> —————————————————-
>
>
> –
> SmadSteck – http://www.smadsteck.nl
> Hard- and software for interactive audiovisual sampling
>


June 1, 2007 | 8:31 am

Hi wesley,

I use macpro 2x dualcore 2.66, osx 10.4.9, max 4.6.3, jitter 1.6.3, 2x geforce 7300 GT.

When I turned on the renderer just a few minutes ago, max crashed, I attached the crash report.

When I turn on the renderer now I simply get a black screen.

Mattijs

Quote: wesley.hoke@gmail.com wrote on Thu, 31 May 2007 18:07
—————————————————-
> You just have to be different don’t you :) On my machine it works
> simply by turning on the renderer. What GPU do you have? It works
> perfetly on my PB 1.67 osx 10.4.8 Jitter 1.6.3 radeon 9700.
>
> wes
>
> On 5/31/07, Mattijs Kneppers wrote:
> >
> > Hi Wes,
> >
> > It looks exciting, but after a first glance I don’t get output yet. Is there a secret bang somewhere that I have to press apart from enabling the two metro’s and loading dishes.mov?
> >
> > OS 10.4.9, Max 4.6.3, jitter 1.6.3
> >
> > Mattijs
> >
> > Quote: wesley.hoke@gmail.com wrote on Thu, 31 May 2007 09:15
> > —————————————————-
> > > Hi everyone,
> > > Here’s a little patch I’ve been having fun with that projects textures
> > > into an isosurface. It even makes the default texture checker pattern
> > > and dishes.mov look interesting. There’s a shader for calculating the
> > > project texture coordinates, a javascript that constructs the
> > > coordinate transform matrices the shader needs, and a patch to run the
> > > thing. enjoy.
> > >
> > > http://www.mat.ucsb.edu/~whsmith/ProjTex4.zip
> > >
> > > wes
> > >
> > —————————————————-
> >
> >
> > –
> > SmadSteck – http://www.smadsteck.nl
> > Hard- and software for interactive audiovisual sampling
> >
>
—————————————————-


June 1, 2007 | 8:43 am

Wow, looks like jit.gl.sketch got hosed by a linked list error. I
just tried it on an imac dual core 1.6 osx 10.4.8 Jitter 1.6.3 b2
radeon x1600. If it was black, did you try to interact with the
thing. If you disable the shader do you at least see the isosurface?

wes

On 6/1/07, Mattijs Kneppers wrote:
> Hi wesley,
>
> I use macpro 2x dualcore 2.66, osx 10.4.9, max 4.6.3, jitter 1.6.3, 2x geforce 7300 GT.
>
> When I turned on the renderer just a few minutes ago, max crashed, I attached the crash report.
>
> When I turn on the renderer now I simply get a black screen.
>
> Mattijs
>
>
> Quote: wesley.hoke@gmail.com wrote on Thu, 31 May 2007 18:07
> —————————————————-
> > You just have to be different don’t you :) On my machine it works
> > simply by turning on the renderer. What GPU do you have? It works
> > perfetly on my PB 1.67 osx 10.4.8 Jitter 1.6.3 radeon 9700.
> >
> > wes
> >
> > On 5/31/07, Mattijs Kneppers
wrote:
> > >
> > > Hi Wes,
> > >
> > > It looks exciting, but after a first glance I don’t get output yet. Is there a secret bang somewhere that I have to press apart from enabling the two metro’s and loading dishes.mov?
> > >
> > > OS 10.4.9, Max 4.6.3, jitter 1.6.3
> > >
> > > Mattijs
> > >
> > > Quote: wesley.hoke@gmail.com wrote on Thu, 31 May 2007 09:15
> > > —————————————————-
> > > > Hi everyone,
> > > > Here’s a little patch I’ve been having fun with that projects textures
> > > > into an isosurface. It even makes the default texture checker pattern
> > > > and dishes.mov look interesting. There’s a shader for calculating the
> > > > project texture coordinates, a javascript that constructs the
> > > > coordinate transform matrices the shader needs, and a patch to run the
> > > > thing. enjoy.
> > > >
> > > > http://www.mat.ucsb.edu/~whsmith/ProjTex4.zip
> > > >
> > > > wes
> > > >
> > > —————————————————-
> > >
> > >
> > > –
> > > SmadSteck – http://www.smadsteck.nl
> > > Hard- and software for interactive audiovisual sampling
> > >
> >
> —————————————————-
>
>
> –
> SmadSteck – http://www.smadsteck.nl
> Hard- and software for interactive audiovisual sampling
>
>
>
>


June 1, 2007 | 9:30 am

Yeah, without the shader I see a cool isosurface that I can handle with handle.

Mattijs

Quote: wesley.hoke@gmail.com wrote on Fri, 01 June 2007 10:43
—————————————————-
> Wow, looks like jit.gl.sketch got hosed by a linked list error. I
> just tried it on an imac dual core 1.6 osx 10.4.8 Jitter 1.6.3 b2
> radeon x1600. If it was black, did you try to interact with the
> thing. If you disable the shader do you at least see the isosurface?
>
> wes
>
> On 6/1/07, Mattijs Kneppers wrote:
> > Hi wesley,
> >
> > I use macpro 2x dualcore 2.66, osx 10.4.9, max 4.6.3, jitter 1.6.3, 2x geforce 7300 GT.
> >
> > When I turned on the renderer just a few minutes ago, max crashed, I attached the crash report.
> >
> > When I turn on the renderer now I simply get a black screen.
> >
> > Mattijs


June 1, 2007 | 4:00 pm

ok, can you apply the shader to a simple thing like a gridshape?

wes

On 6/1/07, Mattijs Kneppers wrote:
>
> Yeah, without the shader I see a cool isosurface that I can handle with handle.
>
> Mattijs
>
> Quote: wesley.hoke@gmail.com wrote on Fri, 01 June 2007 10:43
> —————————————————-
> > Wow, looks like jit.gl.sketch got hosed by a linked list error. I
> > just tried it on an imac dual core 1.6 osx 10.4.8 Jitter 1.6.3 b2
> > radeon x1600. If it was black, did you try to interact with the
> > thing. If you disable the shader do you at least see the isosurface?
> >
> > wes
> >
> > On 6/1/07, Mattijs Kneppers
wrote:
> > > Hi wesley,
> > >
> > > I use macpro 2x dualcore 2.66, osx 10.4.9, max 4.6.3, jitter 1.6.3, 2x geforce 7300 GT.
> > >
> > > When I turned on the renderer just a few minutes ago, max crashed, I attached the crash report.
> > >
> > > When I turn on the renderer now I simply get a black screen.
> > >
> > > Mattijs
>
> –
> SmadSteck – http://www.smadsteck.nl
> Hard- and software for interactive audiovisual sampling
>


June 1, 2007 | 4:12 pm

I added this to your patch:

#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P comment 432 204 115 196617 black (handle is visible);
#P message 344 184 40 196617 shader;
#P message 344 204 86 196617 shader projector;
#P newex 301 224 177 196617 t draw getposition getrotate getscale;
#P newex 301 204 41 196617 r draw;
#P newex 301 245 189 196617 jit.gl.gridshape project @texture movie;
#P comment 386 183 36 196617 works;
#P connect 2 0 3 0;
#P connect 5 0 1 0;
#P connect 4 0 1 0;
#P connect 3 0 1 0;
#P connect 3 1 1 0;
#P connect 3 2 1 0;
#P connect 3 3 1 0;
#P window clipboard copycount 7;

It seems the shader doesn’t work on a simple gridshape either (also without the movie texture). The handle is visible though, but the sphere is seems rendered entirely black. I wanted to make a screenshot of this but osx can’t seem to make a screenshot of the entire screen (without the necessity of using the mouse).

Mattijs

Quote: wesley.hoke@gmail.com wrote on Fri, 01 June 2007 18:00
—————————————————-
> ok, can you apply the shader to a simple thing like a gridshape?
>
> wes
>
> On 6/1/07, Mattijs Kneppers wrote:
> >
> > Yeah, without the shader I see a cool isosurface that I can handle with handle.
> >
> > Mattijs
> >
> > Quote: wesley.hoke@gmail.com wrote on Fri, 01 June 2007 10:43


June 1, 2007 | 4:28 pm

Well, if it’s coming out black then there is something to do with Cg
and the shader that’s not working on your machine. Can you verify if
the mat.phong.cg.jxs shader works for you? If so, go into the
projective texture shader and comment out the entire fragment shader
and add a line that just assigns a color like red to every pixel. If
this works, keep uncommenting more code until it fails. This will
tell myou what is going on.

wes

On 6/1/07, Mattijs Kneppers wrote:
>
> I added this to your patch:
>
> #P window setfont "Sans Serif" 9.;
> #P window linecount 1;
> #P comment 432 204 115 196617 black (handle is visible);
> #P message 344 184 40 196617 shader;
> #P message 344 204 86 196617 shader projector;
> #P newex 301 224 177 196617 t draw getposition getrotate getscale;
> #P newex 301 204 41 196617 r draw;
> #P newex 301 245 189 196617 jit.gl.gridshape project @texture movie;
> #P comment 386 183 36 196617 works;
> #P connect 2 0 3 0;
> #P connect 5 0 1 0;
> #P connect 4 0 1 0;
> #P connect 3 0 1 0;
> #P connect 3 1 1 0;
> #P connect 3 2 1 0;
> #P connect 3 3 1 0;
> #P window clipboard copycount 7;
>
> It seems the shader doesn’t work on a simple gridshape either (also without the movie texture). The handle is visible though, but the sphere is seems rendered entirely black. I wanted to make a screenshot of this but osx can’t seem to make a screenshot of the entire screen (without the necessity of using the mouse).
>
> Mattijs
>
> Quote: wesley.hoke@gmail.com wrote on Fri, 01 June 2007 18:00
> —————————————————-
> > ok, can you apply the shader to a simple thing like a gridshape?
> >
> > wes
> >
> > On 6/1/07, Mattijs Kneppers
wrote:
> > >
> > > Yeah, without the shader I see a cool isosurface that I can handle with handle.
> > >
> > > Mattijs
> > >
> > > Quote: wesley.hoke@gmail.com wrote on Fri, 01 June 2007 10:43
>
> –
> SmadSteck – http://www.smadsteck.nl
> Hard- and software for interactive audiovisual sampling
>


June 3, 2007 | 9:13 am

amazing job, works on my xp machine.
x800 ati

On 6/1/07, Wesley Smith wrote:
>
> Well, if it’s coming out black then there is something to do with Cg
> and the shader that’s not working on your machine. Can you verify if
> the mat.phong.cg.jxs shader works for you? If so, go into the
> projective texture shader and comment out the entire fragment shader
> and add a line that just assigns a color like red to every pixel. If
> this works, keep uncommenting more code until it fails. This will
> tell myou what is going on.
>
> wes
>
>
> On 6/1/07, Mattijs Kneppers wrote:
> >
> > I added this to your patch:
> >
> > #P window setfont "Sans Serif" 9.;
> > #P window linecount 1;
> > #P comment 432 204 115 196617 black (handle is visible);
> > #P message 344 184 40 196617 shader;
> > #P message 344 204 86 196617 shader projector;
> > #P newex 301 224 177 196617 t draw getposition getrotate getscale;
> > #P newex 301 204 41 196617 r draw;
> > #P newex 301 245 189 196617 jit.gl.gridshape project @texture movie;
> > #P comment 386 183 36 196617 works;
> > #P connect 2 0 3 0;
> > #P connect 5 0 1 0;
> > #P connect 4 0 1 0;
> > #P connect 3 0 1 0;
> > #P connect 3 1 1 0;
> > #P connect 3 2 1 0;
> > #P connect 3 3 1 0;
> > #P window clipboard copycount 7;
> >
> > It seems the shader doesn’t work on a simple gridshape either (also
> without the movie texture). The handle is visible though, but the sphere is
> seems rendered entirely black. I wanted to make a screenshot of this but osx
> can’t seem to make a screenshot of the entire screen (without the necessity
> of using the mouse).
> >
> > Mattijs
> >
> > Quote: wesley.hoke@gmail.com wrote on Fri, 01 June 2007 18:00
> > —————————————————-
> > > ok, can you apply the shader to a simple thing like a gridshape?
> > >
> > > wes
> > >
> > > On 6/1/07, Mattijs Kneppers
wrote:
> > > >
> > > > Yeah, without the shader I see a cool isosurface that I can handle
> with handle.
> > > >
> > > > Mattijs
> > > >
> > > > Quote: wesley.hoke@gmail.com wrote on Fri, 01 June 2007 10:43
> >
> > –
> > SmadSteck – http://www.smadsteck.nl
> > Hard- and software for interactive audiovisual sampling
> >
>


June 4, 2007 | 8:23 am

Hi, I tried mat.phong.cg.jxs and it doesn’t work either. Other shaders (mat.glass.jxs for example) do work.

Mattijs

Quote: wesley.hoke@gmail.com wrote on Fri, 01 June 2007 18:28
—————————————————-
> Well, if it’s coming out black then there is something to do with Cg
> and the shader that’s not working on your machine. Can you verify if
> the mat.phong.cg.jxs shader works for you? If so, go into the
> projective texture shader and comment out the entire fragment shader
> and add a line that just assigns a color like red to every pixel. If
> this works, keep uncommenting more code until it fails. This will
> tell myou what is going on.
>
> wes
>


June 4, 2007 | 8:32 am

Hi Mattijs,
Sounds like Cg in general doesn’t work with Jitter on your machine.
The reason I asked you to try the phong shader was that it uses Cg
like the projective texturing one. THe glass shader uses GLSL so that
doesn’t help too much. The only shader I’m aware of that came with
Jitter 1.5 using Cg was vd.twist.jxs . If that one doesn’t work, then
Cg is definitely the problem. There’s supposed to be a Cg framework
in the jitter-externals folder. Is this the case?

wes

On 6/4/07, Mattijs Kneppers wrote:
>
> Hi, I tried mat.phong.cg.jxs and it doesn’t work either. Other shaders (mat.glass.jxs for example) do work.
>
> Mattijs
>
> Quote: wesley.hoke@gmail.com wrote on Fri, 01 June 2007 18:28
> —————————————————-
> > Well, if it’s coming out black then there is something to do with Cg
> > and the shader that’s not working on your machine. Can you verify if
> > the mat.phong.cg.jxs shader works for you? If so, go into the
> > projective texture shader and comment out the entire fragment shader
> > and add a line that just assigns a color like red to every pixel. If
> > this works, keep uncommenting more code until it fails. This will
> > tell myou what is going on.
> >
> > wes
> >
>
> –
> SmadSteck – http://www.smadsteck.nl
> Hard- and software for interactive audiovisual sampling
>


June 4, 2007 | 9:14 am

Quote: wesley.hoke@gmail.com wrote on Mon, 04 June 2007 10:32
—————————————————-
> Hi Mattijs,
> Sounds like Cg in general doesn’t work with Jitter on your machine.
> The reason I asked you to try the phong shader was that it uses Cg
> like the projective texturing one. THe glass shader uses GLSL so that
> doesn’t help too much.

Well, it shows that it’s not a problem with shaders in general ;)

> The only shader I’m aware of that came with
> Jitter 1.5 using Cg was vd.twist.jxs . If that one doesn’t work, then
> Cg is definitely the problem.

Correct, vd.twist.jxs doesn’t work.

> There’s supposed to be a Cg framework
> in the jitter-externals folder. Is this the case?

yes there is, modified on 19 sept 2006

>
> wes
>
> On 6/4/07, Mattijs Kneppers wrote:
> >
> > Hi, I tried mat.phong.cg.jxs and it doesn’t work either. Other shaders (mat.glass.jxs for example) do work.
> >
> > Mattijs
> >
> > Quote: wesley.hoke@gmail.com wrote on Fri, 01 June 2007 18:28
> > —————————————————-
> > > Well, if it’s coming out black then there is something to do with Cg
> > > and the shader that’s not working on your machine. Can you verify if
> > > the mat.phong.cg.jxs shader works for you? If so, go into the
> > > projective texture shader and comment out the entire fragment shader
> > > and add a line that just assigns a color like red to every pixel. If
> > > this works, keep uncommenting more code until it fails. This will
> > > tell myou what is going on.
> > >
> > > wes
> > >
> >
> > –
> > SmadSteck – http://www.smadsteck.nl
> > Hard- and software for interactive audiovisual sampling
> >
>
—————————————————-


June 5, 2007 | 7:40 pm

super!

it’s definitely cool with checker pattern!

thanks wes!


June 7, 2007 | 4:54 am

Hello Mattijs,
I just got on a machine that reproduced you blackness. As far as I
can tell, the issue was that the normals weren’t being passed into the
shader somehow. I don’t really understand it, so I got around it by
making the same shader in GLSL. Here’s a download tat should work on
your machine.

http://www.mat.ucsb.edu/~whsmith/ProjectiveTextures.zip

best,
wes


June 11, 2007 | 10:08 am

Great! Now everything works here too.

This looks nice. I’d like to check it out more in-depth some time.

Mattijs

Quote: wesley.hoke@gmail.com wrote on Thu, 07 June 2007 06:54
—————————————————-
> Hello Mattijs,
> I just got on a machine that reproduced you blackness. As far as I
> can tell, the issue was that the normals weren’t being passed into the
> shader somehow. I don’t really understand it, so I got around it by
> making the same shader in GLSL. Here’s a download tat should work on
> your machine.
>
> http://www.mat.ucsb.edu/~whsmith/ProjectiveTextures.zip
>
> best,
> wes
>
—————————————————-


November 4, 2008 | 11:27 pm

this is one of the most interesting patchshader made. i just re-found it in
my patch archive, i would love to see it developed to the core of the next
jitter. or a nice in depth article, no?

On Mon, Jun 11, 2007 at 12:08 PM, Mattijs Kneppers wrote:

>
> Great! Now everything works here too.
>
> This looks nice. I’d like to check it out more in-depth some time.
>
> Mattijs
>
> Quote: wesley.hoke@gmail.com wrote on Thu, 07 June 2007 06:54
> —————————————————-
> > Hello Mattijs,
> > I just got on a machine that reproduced you blackness. As far as I
> > can tell, the issue was that the normals weren’t being passed into the
> > shader somehow. I don’t really understand it, so I got around it by
> > making the same shader in GLSL. Here’s a download tat should work on
> > your machine.
> >
> > http://www.mat.ucsb.edu/~whsmith/ProjectiveTextures.zip< http://www.mat.ucsb.edu/%7Ewhsmith/ProjectiveTextures.zip>
> >
> > best,
> > wes
> >
> —————————————————-
>
>
> –
> SmadSteck –
http://www.smadsteck.nl
> Hard- and software for interactive audiovisual sampling
>


Viewing 18 posts - 1 through 18 (of 18 total)