Shortcut key to enter Presentation mode?

Jan 24, 2009 at 1:50pm

Shortcut key to enter Presentation mode?

I can’t seem to find one, but it would be very nice if there was one!

#41914
Jan 24, 2009 at 4:26pm

you can make it yourself, but unfortunately you have to add it per patch. i’ve got this saved in my clippings folder.
this works with option-p (on mac, will have to be edited for win),and it remembers the window locations and sizes. props to whoever first posted this:

– Pasted Max Patch, click to expand. –
#149629

m
Jan 26, 2009 at 12:49pm

#149630
Jan 26, 2009 at 1:25pm

#149631
Jan 26, 2009 at 1:29pm

But there is a menu command for Presentation?

Under “View” => “Presentation”.

#149632
Jan 26, 2009 at 1:36pm

#149633

m
Jan 26, 2009 at 2:16pm

#149634

m
Jan 26, 2009 at 2:16pm

#149635
Jan 26, 2009 at 3:06pm

m,

Never used this feature before, thanks. But for some reason the fade time between presentation and normal mode is significantly longer when you use the keyboard shortcut vs. when you click on the menu item. Have you noticed the same?

best,
Zachary

#149636
Jan 26, 2009 at 3:09pm

well when I switched my shortcut from command-shift-E to command-P the slowness disappeared. Strange…

Zachary

#149637
Jan 26, 2009 at 3:09pm

zachary: Could it be because of conflicting shortcuts?

#149638
Jan 26, 2009 at 3:41pm

#149639

m
Jan 26, 2009 at 4:26pm

#149640
Jan 26, 2009 at 4:29pm

You can also add shortcuts by editing

Max5/Cycling74/interfaces/maxinterface.json

If you do search in the file for ‘presentation’, you should see some text that looks like this-

{
“message” : “presentation”,
“label” : “Presentation”,
“target” : “owner”,
“icon” : “presentation.svg”,
“downicon” : “present_on.svg”,
“caption” : “Presentation Mode”,
“downcaption” : “Patching Mode”,
“flags” : 3,
},

I just added the line “shortcut” : “P” before the closing bracket so it looks like this-

{
“message” : “presentation”,
“label” : “Presentation”,
“target” : “owner”,
“icon” : “presentation.svg”,
“downicon” : “present_on.svg”,
“caption” : “Presentation Mode”,
“downcaption” : “Patching Mode”,
“flags” : 3,
“shortcut” : “P”
},

Now when I hit cmd+p it toggles the presentation mode.

#149641
Jan 26, 2009 at 4:38pm

…also I think this overrides the print command (?), which you might want to remove by doing a search for ‘print’. And its a good idea to keep a backup copy of the maxinterface.json in case you make a mistake.

Finally, don’t forget to add a comma to the end of the second to last line- “flags” : 3,

I included the comma by mistake in the first example but it wont be there by default. If you don’t include it your drop down menu will disappear until you add it back.

#149642
Jan 26, 2009 at 5:14pm

Ah, yes…but I’ve never found a way to print from within Max anyway. It’s
not listed in the menus, and Command-P doesn’t work, at least. So, I think
using “P” is a safe bet.

That said, IS there a way to print, other than a screen capture? This would
be really useful!

#149643
Jan 26, 2009 at 5:23pm

On 26 janv. 09, at 18:14, Brennon Bortz wrote:

> Ah, yes…but I’ve never found a way to print from within Max
> anyway. It’s
> not listed in the menus, and Command-P doesn’t work, at least. So,
> I think
> using “P” is a safe bet.
>
> That said, IS there a way to print, other than a screen capture?
> This would
> be really useful!

You can export patches as images. It generates png files up to 300dpi
(depending on your preferences).

ej

#149644

You must be logged in to reply to this topic.