Forums > Jitter

So, what's the best settings for qmetro of different fps?

August 9, 2007 | 4:55 pm

Hi,

I render my movies and put in the jitter but I found the timing is not right. I read many of the articles here but I still want to know is there a "right answer" of qmetro settings of different fps.

If I render my movies as 30 fps, 640×480, what should I set with the qmetro?

If I render my movies as 29.97 non-drop 640×480, what is the best setting of qmetro?

If I render my movies as 29.97 drop 640×480, is the setting still the same with 29.97 non-drop?

I haven’t tried it yet because some people said here that it is not recommend. Should I change qmetro settings if I put HD formate or very high resolution movies?

thank you so much



sm
August 10, 2007 | 7:35 pm

by rendering movies you mean to record them to harddisk via jit.record?
as long as you set ‘realtime 0′ the qmetro settings are less relevant to the
duration of your rendered movie as the timescale setting.
in realtime 0 mode every incoming frame is supposed to be the next frame in the
rendered video,
for pal content timescale should be set to 800. not realy shure about ntsc
though.

Quoting UCDMSRA :

>
> Hi,
>
> I render my movies and put in the jitter but I found the timing is not right.
> I read many of the articles here but I still want to know is there a "right
> answer" of qmetro settings of different fps.
>
> If I render my movies as 30 fps, 640×480, what should I set with the qmetro?
>
> If I render my movies as 29.97 non-drop 640×480, what is the best setting of
> qmetro?
>
> If I render my movies as 29.97 drop 640×480, is the setting still the same
> with 29.97 non-drop?
>
> I haven’t tried it yet because some people said here that it is not
> recommend. Should I change qmetro settings if I put HD formate or very high
> resolution movies?
>
> thank you so much
>
>

—————————————————————-
This message was sent using IMP, the Internet Messaging Program.


August 10, 2007 | 7:53 pm

I believe it is 600, but im not positive :X

On Aug 10, 2007, at 3:35 PM, sm@xdv.org wrote:

> by rendering movies you mean to record them to harddisk via
> jit.record?
> as long as you set ‘realtime 0′ the qmetro settings are less
> relevant to the
> duration of your rendered movie as the timescale setting.
> in realtime 0 mode every incoming frame is supposed to be the next
> frame in the
> rendered video,
> for pal content timescale should be set to 800. not realy shure
> about ntsc
> though.
>
> Quoting UCDMSRA :
>
>>
>> Hi,
>>
>> I render my movies and put in the jitter but I found the timing is
>> not right.
>> I read many of the articles here but I still want to know is
>> there a "right
>> answer" of qmetro settings of different fps.
>>
>> If I render my movies as 30 fps, 640×480, what should I set with
>> the qmetro?
>>
>> If I render my movies as 29.97 non-drop 640×480, what is the best
>> setting of
>> qmetro?
>>
>> If I render my movies as 29.97 drop 640×480, is the setting still
>> the same
>> with 29.97 non-drop?
>>
>> I haven’t tried it yet because some people said here that it is not
>> recommend. Should I change qmetro settings if I put HD formate or
>> very high
>> resolution movies?
>>
>> thank you so much
>>
>>
>
>
>
>
> —————————————————————-
> This message was sent using IMP, the Internet Messaging Program.

v a d e //

http://www.vade.info
abstrakt.vade.info


August 11, 2007 | 5:10 pm

Quote: sm wrote on Fri, 10 August 2007 13:35
—————————————————-
> by rendering movies you mean to record them to harddisk via jit.record?
> as long as you set ‘realtime 0′ the qmetro settings are less relevant to the
> duration of your rendered movie as the timescale setting.
> in realtime 0 mode every incoming frame is supposed to be the next frame in the
> rendered video,
> for pal content timescale should be set to 800. not realy shure about ntsc
> though.
>
> Quoting UCDMSRA :
>
> >
> > Hi,
> >
> > I render my movies and put in the jitter but I found the timing is not right.
> > I read many of the articles here but I still want to know is there a "right
> > answer" of qmetro settings of different fps.
> >
> > If I render my movies as 30 fps, 640×480, what should I set with the qmetro?
> >
> > If I render my movies as 29.97 non-drop 640×480, what is the best setting of
> > qmetro?
> >
> > If I render my movies as 29.97 drop 640×480, is the setting still the same
> > with 29.97 non-drop?
> >
> > I haven’t tried it yet because some people said here that it is not
> > recommend. Should I change qmetro settings if I put HD formate or very high
> > resolution movies?
> >
> > thank you so much
> >
> >
>
>
>
>
> —————————————————————-
> This message was sent using IMP, the Internet Messaging Program.
>
—————————————————-

Hmm…..well, the information you told me I didn’t know so that’s very good. However, I think what I want to say is if I render my movie in After Effects or editing my movie at Final Cut Pro. Why my movie end of play different speed when pull into jitter? All the movies I rendered out was 20:00 seconds. I render the movies as 29.97 fps non-drop. However, I found that it will playback less than 20 seconds in jitter (I think maybe 0.5 to 1 second different). Why is that? What did I do wrong, is the problem with "qmetro" settings?

thanks



Dan
August 11, 2007 | 5:26 pm

Try [qmetro 2] –> [qlim 33.333] –> [jit.qt.movie].



sm
August 11, 2007 | 5:31 pm

the qmetro setting has most definitely nothing to with the playback speed of you
movie.did you change the ‘rate’ parameter in jitter?
the qmetro just forces jit.movie do put out a frame each bang while the runs on
its own speed – determined by rate.

anyhow, to help you fix the problem you should provide your patch – a striped
down version – and a short part of you misbehaving movies.
cheers

Quoting UCDMSRA :

>
> Quote: sm wrote on Fri, 10 August 2007 13:35
> —————————————————-
> > by rendering movies you mean to record them to harddisk via jit.record?
> > as long as you set ‘realtime 0′ the qmetro settings are less relevant to
> the
> > duration of your rendered movie as the timescale setting.
> > in realtime 0 mode every incoming frame is supposed to be the next frame in
> the
> > rendered video,
> > for pal content timescale should be set to 800. not realy shure about ntsc
> > though.
> >
> > Quoting UCDMSRA :
> >
> > >
> > > Hi,
> > >
> > > I render my movies and put in the jitter but I found the timing is not
> right.
> > > I read many of the articles here but I still want to know is there a
> "right
> > > answer" of qmetro settings of different fps.
> > >
> > > If I render my movies as 30 fps, 640×480, what should I set with the
> qmetro?
> > >
> > > If I render my movies as 29.97 non-drop 640×480, what is the best setting
> of
> > > qmetro?
> > >
> > > If I render my movies as 29.97 drop 640×480, is the setting still the
> same
> > > with 29.97 non-drop?
> > >
> > > I haven’t tried it yet because some people said here that it is not
> > > recommend. Should I change qmetro settings if I put HD formate or very
> high
> > > resolution movies?
> > >
> > > thank you so much
> > >
> > >
> >
> >
> >
> >
> > —————————————————————-
> > This message was sent using IMP, the Internet Messaging Program.
> >
> —————————————————-
>
> Hmm…..well, the information you told me I didn’t know so that’s very good.
> However, I think what I want to say is if I render my movie in After Effects
> or editing my movie at Final Cut Pro. Why my movie end of play different
> speed when pull into jitter? All the movies I rendered out was 20:00 seconds.
> I render the movies as 29.97 fps non-drop. However, I found that it will
> playback less than 20 seconds in jitter (I think maybe 0.5 to 1 second
> different). Why is that? What did I do wrong, is the problem with "qmetro"
> settings?
>
> thanks
>
>

—————————————————————-
This message was sent using IMP, the Internet Messaging Program.



sm
August 11, 2007 | 5:31 pm

the qmetro setting has most definitely nothing to with the playback speed of you
movie.did you change the ‘rate’ parameter in jitter?
the qmetro just forces jit.movie do put out a frame each bang while the runs on
its own speed – determined by rate.

anyhow, to help you fix the problem you should provide your patch – a striped
down version – and a short part of you misbehaving movies.
cheers

Quoting UCDMSRA :

>
> Quote: sm wrote on Fri, 10 August 2007 13:35
> —————————————————-
> > by rendering movies you mean to record them to harddisk via jit.record?
> > as long as you set ‘realtime 0′ the qmetro settings are less relevant to
> the
> > duration of your rendered movie as the timescale setting.
> > in realtime 0 mode every incoming frame is supposed to be the next frame in
> the
> > rendered video,
> > for pal content timescale should be set to 800. not realy shure about ntsc
> > though.
> >
> > Quoting UCDMSRA :
> >
> > >
> > > Hi,
> > >
> > > I render my movies and put in the jitter but I found the timing is not
> right.
> > > I read many of the articles here but I still want to know is there a
> "right
> > > answer" of qmetro settings of different fps.
> > >
> > > If I render my movies as 30 fps, 640×480, what should I set with the
> qmetro?
> > >
> > > If I render my movies as 29.97 non-drop 640×480, what is the best setting
> of
> > > qmetro?
> > >
> > > If I render my movies as 29.97 drop 640×480, is the setting still the
> same
> > > with 29.97 non-drop?
> > >
> > > I haven’t tried it yet because some people said here that it is not
> > > recommend. Should I change qmetro settings if I put HD formate or very
> high
> > > resolution movies?
> > >
> > > thank you so much
> > >
> > >
> >
> >
> >
> >
> > —————————————————————-
> > This message was sent using IMP, the Internet Messaging Program.
> >
> —————————————————-
>
> Hmm…..well, the information you told me I didn’t know so that’s very good.
> However, I think what I want to say is if I render my movie in After Effects
> or editing my movie at Final Cut Pro. Why my movie end of play different
> speed when pull into jitter? All the movies I rendered out was 20:00 seconds.
> I render the movies as 29.97 fps non-drop. However, I found that it will
> playback less than 20 seconds in jitter (I think maybe 0.5 to 1 second
> different). Why is that? What did I do wrong, is the problem with "qmetro"
> settings?
>
> thanks
>
>

—————————————————————-
This message was sent using IMP, the Internet Messaging Program.


August 20, 2007 | 4:31 am

Quote: sm wrote on Sat, 11 August 2007 11:31
—————————————————-
> the qmetro setting has most definitely nothing to with the playback speed of you
> movie.did you change the ‘rate’ parameter in jitter?
> the qmetro just forces jit.movie do put out a frame each bang while the runs on
> its own speed – determined by rate.
>
> anyhow, to help you fix the problem you should provide your patch – a striped
> down version – and a short part of you misbehaving movies.
> cheers
>
> Quoting UCDMSRA :
>
> >
> > Quote: sm wrote on Fri, 10 August 2007 13:35
> > —————————————————-
> > > by rendering movies you mean to record them to harddisk via jit.record?
> > > as long as you set ‘realtime 0′ the qmetro settings are less relevant to
> > the
> > > duration of your rendered movie as the timescale setting.
> > > in realtime 0 mode every incoming frame is supposed to be the next frame in
> > the
> > > rendered video,
> > > for pal content timescale should be set to 800. not realy shure about ntsc
> > > though.
> > >
> > > Quoting UCDMSRA
:
> > >
> > > >
> > > > Hi,
> > > >
> > > > I render my movies and put in the jitter but I found the timing is not
> > right.
> > > > I read many of the articles here but I still want to know is there a
> > "right
> > > > answer" of qmetro settings of different fps.
> > > >
> > > > If I render my movies as 30 fps, 640×480, what should I set with the
> > qmetro?
> > > >
> > > > If I render my movies as 29.97 non-drop 640×480, what is the best setting
> > of
> > > > qmetro?
> > > >
> > > > If I render my movies as 29.97 drop 640×480, is the setting still the
> > same
> > > > with 29.97 non-drop?
> > > >
> > > > I haven’t tried it yet because some people said here that it is not
> > > > recommend. Should I change qmetro settings if I put HD formate or very
> > high
> > > > resolution movies?
> > > >
> > > > thank you so much
> > > >
> > > >
> > >
> > >
> > >
> > >
> > > —————————————————————-
> > > This message was sent using IMP, the Internet Messaging Program.
> > >
> > —————————————————-
> >
> > Hmm…..well, the information you told me I didn’t know so that’s very good.
> > However, I think what I want to say is if I render my movie in After Effects
> > or editing my movie at Final Cut Pro. Why my movie end of play different
> > speed when pull into jitter? All the movies I rendered out was 20:00 seconds.
> > I render the movies as 29.97 fps non-drop. However, I found that it will
> > playback less than 20 seconds in jitter (I think maybe 0.5 to 1 second
> > different). Why is that? What did I do wrong, is the problem with "qmetro"
> > settings?
> >
> > thanks
> >
> >
>
>
>
>
> —————————————————————-
> This message was sent using IMP, the Internet Messaging Program.
>
—————————————————-

Alright,

I give up……

I spent few days tried to figure out what is this patch and hope I can do some adjustment but……I just messed everything up.

Actually this is just a example patch from Max help file about how to load bunch of movies from one folder and playback randomly. There are two things I think I will never figure it out unless someone help me.

1. I hope I can read the movies in uyvy mode, I am not sure in this patch the movies are readed in uyvy mode because when I tried to mix the movies in uyvy mode, the colors became very weird.

2. I set the random metro to 20000 because all my movies are 20 seconds and I rendered my movies as 29.97fps non-drop. I hope every time my movies play is gonna be from beginning to the end. However, "sometimes" the movie suddenly jump out in the middle and that’s why it makes me think maybe the metro setting is wrong.

Here is the patch, I post the original one, not the one after I fixed (it doesn’t work anyway)…..because I don’t want you get more confused.

thank you so much

max v2;
#N vpatcher 283 175 1344 942;
#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P newex 72 163 52 196617 r subway;
#P outlet 247 513 15 0;
#P newex 412 62 48 196617 loadbang;
#P outlet 368 516 15 0;
#P newex 237 214 94 196617 prepend readfolder;
#P comment 239 308 124 196617 movie count;
#P button 237 167 15 0;
#P newex 237 190 75 196617 opendialog fold;
#P number 471 118 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P toggle 412 118 15 0;
#P number 236 269 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 412 166 42 196617 random;
#P newex 412 143 75 196617 qmetro 19500;
#P user ubumenu 114 271 100 196617 0 1 1 0;
#X add CKDaisy1PhotoJPEG.mov;
#X add CKDaisy2H264Matted.mov;
#X add CKDaisy3PhotoJPEG.mov;
#X add CKDaisy4PhotoJPEG.mov;
#X add CKDaisy5PhotoJPEG.mov;
#X add CKDaisy6PhotoJPEG.mov;
#X prefix_set 0 0 0;
#X pattrmode 1;
#P number 412 194 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P message 412 214 48 196617 index $1;
#P message 98 217 133 196617 readfolder ./patches/daisy;
#P user jit.pwindow 71 355 157 119 0 1 0 0 1 0;
#P user jit.fpsgui 72 501 60 196617 0;
#P newex 72 246 174 196617 js jsmoviebank.js;
#P window linecount 6;
#P comment 244 357 198 196617 todo: ; colormode ; arguments for dimensions ; insert/add entries ; fix empty property problem on first load ; solve anything method problem;
#P window linecount 2;
#P comment 103 306 124 196617 output designed to populate umenu/ubumenu;
#P comment 503 178 125 196617 select which movie to play , randomly if desired.;
#P comment 224 536 74 196617 random bang out;
#P comment 351 537 64 196617 moviebank out;
#P connect 24 0 5 0;
#P fasten 20 0 5 0 242 238 77 238;
#P fasten 8 0 5 0 103 238 77 238;
#P fasten 9 0 5 0 417 238 77 238;
#P connect 5 0 7 0;
#P connect 7 0 6 0;
#P connect 22 0 8 0;
#P fasten 5 1 11 0 159 267 119 267;
#P connect 5 2 14 0;
#P connect 18 0 17 0;
#P connect 17 0 20 0;
#P fasten 12 0 23 0 375 160 375 343 462 343 462 461 233 461 233 500 252 500;
#P fasten 5 0 21 0 77 339 247 339 247 491 373 491;
#P connect 22 0 15 0;
#P connect 15 0 12 0;
#P connect 12 0 13 0;
#P fasten 11 0 10 0 119 301 466 301 466 189 417 189;
#P connect 13 0 10 0;
#P connect 10 0 9 0;
#P fasten 14 0 13 1 241 289 486 289 486 163 449 163;
#P connect 16 0 12 1;
#P pop;


August 20, 2007 | 5:35 am

Ok.

#1 – Drop frame only refers to time code – and only really useful if
outputting to a tape or a VTR device. You should not need it in
jitter at all.

#2 What is important is the FPS. and number of frames, and the QTUNIT
- this determines the duration.

As was said before, if your movie is rate 1.0, and you realize that
unless you have autoplay disabled, a movie will start playing
immediately.

So to time a movie, autostart = 0, rate = 1, start timer and play at
the same time, report when movie loops.

this patch loads any movie, and times it in seconds. compare to your
movies.

I loaded a movie that was 18.38 seconds according to QT player, and
the timer returned 18.4

:)

#P window setfont "Sans Serif" 9.;
#P flonum 462 259 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P window linecount 1;
#P newex 469 218 46 196617 / 1000.;
#P flonum 456 170 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P button 394 248 15 0;
#P user jit.pwindow 169 254 82 62 0 1 0 0 1 0;
#P button 93 96 15 0;
#P button 248 96 15 0;
#P message 216 134 30 196617 read;
#P newex 401 187 32 196617 print;
#P newex 411 116 35 196617 timer;
#P message 187 61 104 196617 time 0 , start , rate 1;
#P newex 368 212 82 196617 route loopnotify;
#P newex 145 163 274 196617 jit.qt.movie @loopreport 1 @autostart 0
@adapt 1 @loop 1;
#P connect 11 0 12 0;
#P connect 10 0 11 0;
#P connect 3 0 10 0;
#P connect 9 0 3 1;
#P connect 1 0 9 0;
#P connect 2 0 0 0;
#P connect 2 0 6 0;
#P connect 0 0 8 0;
#P connect 7 0 0 0;
#P connect 0 1 1 0;
#P connect 0 1 4 0;
#P connect 5 0 0 0;
#P connect 6 0 3 0;
#P window clipboard copycount 13;

v a d e //

http://www.vade.info
abstrakt.vade.info


August 20, 2007 | 8:39 am

Quote: vade wrote on Sun, 19 August 2007 23:35
—————————————————-
> Ok.
>
> #1 – Drop frame only refers to time code – and only really useful if
> outputting to a tape or a VTR device. You should not need it in
> jitter at all.
>
> #2 What is important is the FPS. and number of frames, and the QTUNIT
> – this determines the duration.
>
> As was said before, if your movie is rate 1.0, and you realize that
> unless you have autoplay disabled, a movie will start playing
> immediately.
>
> So to time a movie, autostart = 0, rate = 1, start timer and play at
> the same time, report when movie loops.
>
> this patch loads any movie, and times it in seconds. compare to your
> movies.
>
> I loaded a movie that was 18.38 seconds according to QT player, and
> the timer returned 18.4
>
> :)
>
> #P window setfont "Sans Serif" 9.;
> #P flonum 462 259 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
> #P window linecount 1;
> #P newex 469 218 46 196617 / 1000.;
> #P flonum 456 170 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
> #P button 394 248 15 0;
> #P user jit.pwindow 169 254 82 62 0 1 0 0 1 0;
> #P button 93 96 15 0;
> #P button 248 96 15 0;
> #P message 216 134 30 196617 read;
> #P newex 401 187 32 196617 print;
> #P newex 411 116 35 196617 timer;
> #P message 187 61 104 196617 time 0 , start , rate 1;
> #P newex 368 212 82 196617 route loopnotify;
> #P newex 145 163 274 196617 jit.qt.movie @loopreport 1 @autostart 0
> @adapt 1 @loop 1;
> #P connect 11 0 12 0;
> #P connect 10 0 11 0;
> #P connect 3 0 10 0;
> #P connect 9 0 3 1;
> #P connect 1 0 9 0;
> #P connect 2 0 0 0;
> #P connect 2 0 6 0;
> #P connect 0 0 8 0;
> #P connect 7 0 0 0;
> #P connect 0 1 1 0;
> #P connect 0 1 4 0;
> #P connect 5 0 0 0;
> #P connect 6 0 3 0;
> #P window clipboard copycount 13;
>
>
> v a d e //
>
> http://www.vade.info
> abstrakt.vade.info
>
>
>
>
>
>
—————————————————-

Hi,

I got it….but how to apply it in the patch I posted above? The patch I posted above is actually the example patch of jsmoviebank.js, I don’t know how to do the adjustment according to what you told me. jx code is just still complicate to me……. I don’t even sure all the movies are read as uyvy modes or RGB modes. (I hope my movies can be read as uyvy modes)

I need to load a bunch of movies once at a time and play them back randomly. In the jitter this patch is the only example about how to load many movies and playback. Can you check out the js code for me or tell me how to read those codes? I tried but I really don’t understand most of them.

thank you so much

CK


August 20, 2007 | 3:57 pm

Quote: vade wrote on Sun, 19 August 2007 23:35
—————————————————-
> Ok.
>
> #1 – Drop frame only refers to time code – and only really useful if
> outputting to a tape or a VTR device. You should not need it in
> jitter at all.
>
> #2 What is important is the FPS. and number of frames, and the QTUNIT
> – this determines the duration.
>
> As was said before, if your movie is rate 1.0, and you realize that
> unless you have autoplay disabled, a movie will start playing
> immediately.
>
> So to time a movie, autostart = 0, rate = 1, start timer and play at
> the same time, report when movie loops.
>
> this patch loads any movie, and times it in seconds. compare to your
> movies.
>
> I loaded a movie that was 18.38 seconds according to QT player, and
> the timer returned 18.4
>
> :)
>
> #P window setfont "Sans Serif" 9.;
> #P flonum 462 259 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
> #P window linecount 1;
> #P newex 469 218 46 196617 / 1000.;
> #P flonum 456 170 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
> #P button 394 248 15 0;
> #P user jit.pwindow 169 254 82 62 0 1 0 0 1 0;
> #P button 93 96 15 0;
> #P button 248 96 15 0;
> #P message 216 134 30 196617 read;
> #P newex 401 187 32 196617 print;
> #P newex 411 116 35 196617 timer;
> #P message 187 61 104 196617 time 0 , start , rate 1;
> #P newex 368 212 82 196617 route loopnotify;
> #P newex 145 163 274 196617 jit.qt.movie @loopreport 1 @autostart 0
> @adapt 1 @loop 1;
> #P connect 11 0 12 0;
> #P connect 10 0 11 0;
> #P connect 3 0 10 0;
> #P connect 9 0 3 1;
> #P connect 1 0 9 0;
> #P connect 2 0 0 0;
> #P connect 2 0 6 0;
> #P connect 0 0 8 0;
> #P connect 7 0 0 0;
> #P connect 0 1 1 0;
> #P connect 0 1 4 0;
> #P connect 5 0 0 0;
> #P connect 6 0 3 0;
> #P window clipboard copycount 13;
>
>
> v a d e //
>
> http://www.vade.info
> abstrakt.vade.info
>
>
>
>
>
>
—————————————————-

Hi Vade,

I guess I need to put the following js code in the js file:

movearray[vcount].autostart = 0;
movearray[vcount].rate = 1;
movearray[vcount].readmode = uyvy;

now autostart and rate seems right but uyvy is still a problem. Would you please tell me how should I fix this?

thank you so much

CK


August 20, 2007 | 4:45 pm

Why do you need uyvy ? is your window also set to @colormode uyvy ?

With uyvy – its really most useful with GPU based effects, as 99% of
the matrix based processing effects are written with the assumption
of ARGB colors, not UYVY, so things like contrast, saturation etc
dont ‘work’ as expected with UYVY data.

On Aug 20, 2007, at 11:57 AM, UCDMSRA wrote:

>
> Quote: vade wrote on Sun, 19 August 2007 23:35
> —————————————————-
>> Ok.
>>
>> #1 – Drop frame only refers to time code – and only really useful if
>> outputting to a tape or a VTR device. You should not need it in
>> jitter at all.
>>
>> #2 What is important is the FPS. and number of frames, and the QTUNIT
>> – this determines the duration.
>>
>> As was said before, if your movie is rate 1.0, and you realize that
>> unless you have autoplay disabled, a movie will start playing
>> immediately.
>>
>> So to time a movie, autostart = 0, rate = 1, start timer and play at
>> the same time, report when movie loops.
>>
>> this patch loads any movie, and times it in seconds. compare to your
>> movies.
>>
>> I loaded a movie that was 18.38 seconds according to QT player, and
>> the timer returned 18.4
>>
>> :)
>>
>> #P window setfont "Sans Serif" 9.;
>> #P flonum 462 259 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
>> #P window linecount 1;
>> #P newex 469 218 46 196617 / 1000.;
>> #P flonum 456 170 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
>> #P button 394 248 15 0;
>> #P user jit.pwindow 169 254 82 62 0 1 0 0 1 0;
>> #P button 93 96 15 0;
>> #P button 248 96 15 0;
>> #P message 216 134 30 196617 read;
>> #P newex 401 187 32 196617 print;
>> #P newex 411 116 35 196617 timer;
>> #P message 187 61 104 196617 time 0 , start , rate 1;
>> #P newex 368 212 82 196617 route loopnotify;
>> #P newex 145 163 274 196617 jit.qt.movie @loopreport 1 @autostart 0
>> @adapt 1 @loop 1;
>> #P connect 11 0 12 0;
>> #P connect 10 0 11 0;
>> #P connect 3 0 10 0;
>> #P connect 9 0 3 1;
>> #P connect 1 0 9 0;
>> #P connect 2 0 0 0;
>> #P connect 2 0 6 0;
>> #P connect 0 0 8 0;
>> #P connect 7 0 0 0;
>> #P connect 0 1 1 0;
>> #P connect 0 1 4 0;
>> #P connect 5 0 0 0;
>> #P connect 6 0 3 0;
>> #P window clipboard copycount 13;
>>
>>
>> v a d e //
>>
>> http://www.vade.info
>> abstrakt.vade.info
>>
>>
>>
>>
>>
>>
> —————————————————-
>
> Hi Vade,
>
> I guess I need to put the following js code in the js file:
>
> movearray[vcount].autostart = 0;
> movearray[vcount].rate = 1;
> movearray[vcount].readmode = uyvy;
>
> now autostart and rate seems right but uyvy is still a problem.
> Would you please tell me how should I fix this?
>
> thank you so much
>
> CK

v a d e //

http://www.vade.info
abstrakt.vade.info


August 20, 2007 | 6:45 pm

Quote: vade wrote on Mon, 20 August 2007 10:45
—————————————————-
> Why do you need uyvy ? is your window also set to @colormode uyvy ?
>
> With uyvy – its really most useful with GPU based effects, as 99% of
> the matrix based processing effects are written with the assumption
> of ARGB colors, not UYVY, so things like contrast, saturation etc
> dont ‘work’ as expected with UYVY data.
>
>
>
> On Aug 20, 2007, at 11:57 AM, UCDMSRA wrote:
>
> >
> > Quote: vade wrote on Sun, 19 August 2007 23:35
> > —————————————————-
> >> Ok.
> >>
> >> #1 – Drop frame only refers to time code – and only really useful if
> >> outputting to a tape or a VTR device. You should not need it in
> >> jitter at all.
> >>
> >> #2 What is important is the FPS. and number of frames, and the QTUNIT
> >> – this determines the duration.
> >>
> >> As was said before, if your movie is rate 1.0, and you realize that
> >> unless you have autoplay disabled, a movie will start playing
> >> immediately.
> >>
> >> So to time a movie, autostart = 0, rate = 1, start timer and play at
> >> the same time, report when movie loops.
> >>
> >> this patch loads any movie, and times it in seconds. compare to your
> >> movies.
> >>
> >> I loaded a movie that was 18.38 seconds according to QT player, and
> >> the timer returned 18.4
> >>
> >> :)
> >>
> >> #P window setfont "Sans Serif" 9.;
> >> #P flonum 462 259 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
> >> #P window linecount 1;
> >> #P newex 469 218 46 196617 / 1000.;
> >> #P flonum 456 170 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
> >> #P button 394 248 15 0;
> >> #P user jit.pwindow 169 254 82 62 0 1 0 0 1 0;
> >> #P button 93 96 15 0;
> >> #P button 248 96 15 0;
> >> #P message 216 134 30 196617 read;
> >> #P newex 401 187 32 196617 print;
> >> #P newex 411 116 35 196617 timer;
> >> #P message 187 61 104 196617 time 0 , start , rate 1;
> >> #P newex 368 212 82 196617 route loopnotify;
> >> #P newex 145 163 274 196617 jit.qt.movie @loopreport 1 @autostart 0
> >> @adapt 1 @loop 1;
> >> #P connect 11 0 12 0;
> >> #P connect 10 0 11 0;
> >> #P connect 3 0 10 0;
> >> #P connect 9 0 3 1;
> >> #P connect 1 0 9 0;
> >> #P connect 2 0 0 0;
> >> #P connect 2 0 6 0;
> >> #P connect 0 0 8 0;
> >> #P connect 7 0 0 0;
> >> #P connect 0 1 1 0;
> >> #P connect 0 1 4 0;
> >> #P connect 5 0 0 0;
> >> #P connect 6 0 3 0;
> >> #P window clipboard copycount 13;
> >>
> >>
> >> v a d e //
> >>
> >> http://www.vade.info
> >> abstrakt.vade.info
> >>
> >>
> >>
> >>
> >>
> >>
> > —————————————————-
> >
> > Hi Vade,
> >
> > I guess I need to put the following js code in the js file:
> >
> > movearray[vcount].autostart = 0;
> > movearray[vcount].rate = 1;
> > movearray[vcount].readmode = uyvy;
> >
> > now autostart and rate seems right but uyvy is still a problem.
> > Would you please tell me how should I fix this?
> >
> > thank you so much
> >
> > CK
>
> v a d e //
>
> http://www.vade.info
> abstrakt.vade.info
>
>
>
>
>
>
—————————————————-

Hi Vade,

Yes, I run all my movies in jit.gl.texture, jit.gl.videoplane and jit.gl.slab in 3D space. I also use your Shader Beta 1 (again, that is awesome) for some color change and fade in/ fade out. The problem is I ran over 10 different movies in jit.gl.videoplane and I got over 5 different shaders run in the same window at the same time. Sometimes I still got slow response and weird movie timing. That’s why I think maybe I should use uyvy mode to save my poor ATI Radeon 9600 as possible as I can.

However, according to what you said, uyvy may bring me more problem right? What should I do?

best,

CK


August 20, 2007 | 7:00 pm

No, uyvy is not *more* of a problem, but be aware:

if you are on windows XP you should use the uyvy2rgba conversion
shader since XP doesnt have a UYVY Texture colormode natively.

If you are on the mac, be sure to set @colormode UYVY on your slabs/
textures.

Timing *should not* be an issue, but that many movies could pose disk
thrashing issues. You may need to spread your load out or get faster
drives. This might be where you are seeing time discrepancies. Does
your patch seem to be timed correctly with only one movie playing?

What is the bitrate of your movies, and how fast is your drive?
Important to look at the whole system.

Max’s (rather.. Jitters) single threaded Quicktime decoding is also a
bottleneck here as well :(

On Aug 20, 2007, at 2:45 PM, UCDMSRA wrote:

>
> Hi Vade,
>
> Yes, I run all my movies in jit.gl.texture, jit.gl.videoplane and
> jit.gl.slab in 3D space. I also use your Shader Beta 1 (again, that
> is awesome) for some color change and fade in/ fade out. The
> problem is I ran over 10 different movies in jit.gl.videoplane and
> I got over 5 different shaders run in the same window at the same
> time. Sometimes I still got slow response and weird movie timing.
> That’s why I think maybe I should use uyvy mode to save my poor ATI
> Radeon 9600 as possible as I can.
>
> However, according to what you said, uyvy may bring me more problem
> right? What should I do?
>
> best,
>
> CK

v a d e //

http://www.vade.info
abstrakt.vade.info


August 20, 2007 | 7:18 pm

Quote: vade wrote on Mon, 20 August 2007 13:00
—————————————————-
> No, uyvy is not *more* of a problem, but be aware:
>
> if you are on windows XP you should use the uyvy2rgba conversion
> shader since XP doesnt have a UYVY Texture colormode natively.
>
> If you are on the mac, be sure to set @colormode UYVY on your slabs/
> textures.
>
> Timing *should not* be an issue, but that many movies could pose disk
> thrashing issues. You may need to spread your load out or get faster
> drives. This might be where you are seeing time discrepancies. Does
> your patch seem to be timed correctly with only one movie playing?
>
> What is the bitrate of your movies, and how fast is your drive?
> Important to look at the whole system.
>
> Max’s (rather.. Jitters) single threaded Quicktime decoding is also a
> bottleneck here as well :(
>
>
>
> On Aug 20, 2007, at 2:45 PM, UCDMSRA wrote:
>
> >
> > Hi Vade,
> >
> > Yes, I run all my movies in jit.gl.texture, jit.gl.videoplane and
> > jit.gl.slab in 3D space. I also use your Shader Beta 1 (again, that
> > is awesome) for some color change and fade in/ fade out. The
> > problem is I ran over 10 different movies in jit.gl.videoplane and
> > I got over 5 different shaders run in the same window at the same
> > time. Sometimes I still got slow response and weird movie timing.
> > That’s why I think maybe I should use uyvy mode to save my poor ATI
> > Radeon 9600 as possible as I can.
> >
> > However, according to what you said, uyvy may bring me more problem
> > right? What should I do?
> >
> > best,
> >
> > CK
>
> v a d e //
>
> http://www.vade.info
> abstrakt.vade.info
>
>
>
>
>
>
—————————————————-

Hi,

Lucky I use Mac. If I set uyvy in slab I must first set uyvy mode when I load movie right? I did set uyvy mode in slab but what I got is a very weird colors. I guess I need to set colormode uyvy in my loadmoviebank.js first before I set uyvy mode in slab…..but I don’t know how to do it. I put movearray[vcount].colormode = uyvy but I got error message…..I guess I use the wrong command or I put the wrong place. How to solve this problem?

thank you so much

CK


August 20, 2007 | 7:24 pm

use jit.qt.movie @colormode uyvy, jit.gl.slab @colormode uyvy,
jit.gl.videoplane @colormode uyvy.

use the colormode attribute with every single object that is
processing the movie + texture.

On Aug 20, 2007, at 3:18 PM, UCDMSRA wrote:

>
> Quote: vade wrote on Mon, 20 August 2007 13:00
> —————————————————-
>> No, uyvy is not *more* of a problem, but be aware:
>>
>> if you are on windows XP you should use the uyvy2rgba conversion
>> shader since XP doesnt have a UYVY Texture colormode natively.
>>
>> If you are on the mac, be sure to set @colormode UYVY on your slabs/
>> textures.
>>
>> Timing *should not* be an issue, but that many movies could pose disk
>> thrashing issues. You may need to spread your load out or get faster
>> drives. This might be where you are seeing time discrepancies. Does
>> your patch seem to be timed correctly with only one movie playing?
>>
>> What is the bitrate of your movies, and how fast is your drive?
>> Important to look at the whole system.
>>
>> Max’s (rather.. Jitters) single threaded Quicktime decoding is also a
>> bottleneck here as well :(
>>
>>
>>
>> On Aug 20, 2007, at 2:45 PM, UCDMSRA wrote:
>>
>>>
>>> Hi Vade,
>>>
>>> Yes, I run all my movies in jit.gl.texture, jit.gl.videoplane and
>>> jit.gl.slab in 3D space. I also use your Shader Beta 1 (again, that
>>> is awesome) for some color change and fade in/ fade out. The
>>> problem is I ran over 10 different movies in jit.gl.videoplane and
>>> I got over 5 different shaders run in the same window at the same
>>> time. Sometimes I still got slow response and weird movie timing.
>>> That’s why I think maybe I should use uyvy mode to save my poor ATI
>>> Radeon 9600 as possible as I can.
>>>
>>> However, according to what you said, uyvy may bring me more problem
>>> right? What should I do?
>>>
>>> best,
>>>
>>> CK
>>
>> v a d e //
>>
>> http://www.vade.info
>> abstrakt.vade.info
>>
>>
>>
>>
>>
>>
> —————————————————-
>
> Hi,
>
> Lucky I use Mac. If I set uyvy in slab I must first set uyvy mode
> when I load movie right? I did set uyvy mode in slab but what I got
> is a very weird colors. I guess I need to set colormode uyvy in my
> loadmoviebank.js first before I set uyvy mode in slab…..but I
> don’t know how to do it. I put movearray[vcount].colormode = uyvy
> but I got error message…..I guess I use the wrong command or I
> put the wrong place. How to solve this problem?
>
>
> thank you so much
>
> CK
>


August 20, 2007 | 7:31 pm

You probably need to put quotes on uyvy in the JS code, like so:

movearray[vcount].colormode = "uyvy";

since uyvy is not a JS variable, but needs to be treated like a string.

Best,
Andrew B.


August 20, 2007 | 7:37 pm

Do you see gains in performance doing that? I tested just using
jit.qt.movie @colormode uyvy with jit.gl.texture @colormode uyvy with
a slab and videplane as normal and didn’t see any difference.

wes

On 8/20/07, joshua goldberg wrote:
> use jit.qt.movie @colormode uyvy, jit.gl.slab @colormode uyvy,
> jit.gl.videoplane @colormode uyvy.
>
> use the colormode attribute with every single object that is
> processing the movie + texture.
>
> On Aug 20, 2007, at 3:18 PM, UCDMSRA wrote:
>
> >
> > Quote: vade wrote on Mon, 20 August 2007 13:00
> > —————————————————-
> >> No, uyvy is not *more* of a problem, but be aware:
> >>
> >> if you are on windows XP you should use the uyvy2rgba conversion
> >> shader since XP doesnt have a UYVY Texture colormode natively.
> >>
> >> If you are on the mac, be sure to set @colormode UYVY on your slabs/
> >> textures.
> >>
> >> Timing *should not* be an issue, but that many movies could pose disk
> >> thrashing issues. You may need to spread your load out or get faster
> >> drives. This might be where you are seeing time discrepancies. Does
> >> your patch seem to be timed correctly with only one movie playing?
> >>
> >> What is the bitrate of your movies, and how fast is your drive?
> >> Important to look at the whole system.
> >>
> >> Max’s (rather.. Jitters) single threaded Quicktime decoding is also a
> >> bottleneck here as well :(
> >>
> >>
> >>
> >> On Aug 20, 2007, at 2:45 PM, UCDMSRA wrote:
> >>
> >>>
> >>> Hi Vade,
> >>>
> >>> Yes, I run all my movies in jit.gl.texture, jit.gl.videoplane and
> >>> jit.gl.slab in 3D space. I also use your Shader Beta 1 (again, that
> >>> is awesome) for some color change and fade in/ fade out. The
> >>> problem is I ran over 10 different movies in jit.gl.videoplane and
> >>> I got over 5 different shaders run in the same window at the same
> >>> time. Sometimes I still got slow response and weird movie timing.
> >>> That’s why I think maybe I should use uyvy mode to save my poor ATI
> >>> Radeon 9600 as possible as I can.
> >>>
> >>> However, according to what you said, uyvy may bring me more problem
> >>> right? What should I do?
> >>>
> >>> best,
> >>>
> >>> CK
> >>
> >> v a d e //
> >>
> >> http://www.vade.info
> >> abstrakt.vade.info
> >>
> >>
> >>
> >>
> >>
> >>
> > —————————————————-
> >
> > Hi,
> >
> > Lucky I use Mac. If I set uyvy in slab I must first set uyvy mode
> > when I load movie right? I did set uyvy mode in slab but what I got
> > is a very weird colors. I guess I need to set colormode uyvy in my
> > loadmoviebank.js first before I set uyvy mode in slab…..but I
> > don’t know how to do it. I put movearray[vcount].colormode = uyvy
> > but I got error message…..I guess I use the wrong command or I
> > put the wrong place. How to solve this problem?
> >
> >
> > thank you so much
> >
> > CK
> >
>
>


August 20, 2007 | 7:42 pm

On Aug 20, 2007, at 12:24 PM, joshua goldberg wrote:

> use jit.qt.movie @colormode uyvy, jit.gl.slab @colormode uyvy,
> jit.gl.videoplane @colormode uyvy.
>
> use the colormode attribute with every single object that is
> processing the movie + texture.

FWIW, the last stage is only necessary if coming jit.qt.movie-
>jit.gl.videoplane–i.e. @colormode uyvy is only necessary for the
movie and the *first* GL object in a chain of OpenGL objects to which
the video is sent. All subsequent GL objects in that chain will use
the texture as provided (which once on the GPU is actually RGBA data.
Colormode is only respected by objects receiving jit_matrix data, and
are ignored when receiving a jit_gl_texture message).

On Mac, you might want to use the cc.argb2uyvy.jxs shader anyway, if
you want to sneak a slightly higher quality look with some color
adjustment controls in the GPU conversion. If you use this shader,
you do *not* use @colormode uyvy for the jit.gl.slab, but rather
leave as colormode argb, and use @dimscale 2.

This latter strategy is a little tricky, so you can ignore it for now
if it confuses you, but in the long term worthwhile to figure out how
we sneak UYVY data to the graphics card to get high performance/
quality results on both platforms. Search the archives, look at the
example patches, and check out the colorspaces tutorial for more info
about this strategy as well as what UYVY data actually is and how it
is used.

-Joshua


August 20, 2007 | 7:43 pm

actually, i thought it was essential. thanks for the clarification.

On Aug 20, 2007, at 3:37 PM, Wesley Smith wrote:

> Do you see gains in performance doing that? I tested just using
> jit.qt.movie @colormode uyvy with jit.gl.texture @colormode uyvy with
> a slab and videplane as normal and didn’t see any difference.
>
> wes
>
> On 8/20/07, joshua goldberg wrote:
>> use jit.qt.movie @colormode uyvy, jit.gl.slab @colormode uyvy,
>> jit.gl.videoplane @colormode uyvy.
>>
>> use the colormode attribute with every single object that is
>> processing the movie + texture.


August 20, 2007 | 8:00 pm

except he is using javascript Josh :)

you need to set colormode for every item in your movie array.

set it during initialization.

On Aug 20, 2007, at 3:24 PM, joshua goldberg wrote:

> use jit.qt.movie @colormode uyvy, jit.gl.slab @colormode uyvy,
> jit.gl.videoplane @colormode uyvy.
>
> use the colormode attribute with every single object that is
> processing the movie + texture.
>
> On Aug 20, 2007, at 3:18 PM, UCDMSRA wrote:
>
>>
>> Quote: vade wrote on Mon, 20 August 2007 13:00
>> —————————————————-
>>> No, uyvy is not *more* of a problem, but be aware:
>>>
>>> if you are on windows XP you should use the uyvy2rgba conversion
>>> shader since XP doesnt have a UYVY Texture colormode natively.
>>>
>>> If you are on the mac, be sure to set @colormode UYVY on your slabs/
>>> textures.
>>>
>>> Timing *should not* be an issue, but that many movies could pose
>>> disk
>>> thrashing issues. You may need to spread your load out or get faster
>>> drives. This might be where you are seeing time discrepancies. Does
>>> your patch seem to be timed correctly with only one movie playing?
>>>
>>> What is the bitrate of your movies, and how fast is your drive?
>>> Important to look at the whole system.
>>>
>>> Max’s (rather.. Jitters) single threaded Quicktime decoding is
>>> also a
>>> bottleneck here as well :(
>>>
>>>
>>>
>>> On Aug 20, 2007, at 2:45 PM, UCDMSRA wrote:
>>>
>>>>
>>>> Hi Vade,
>>>>
>>>> Yes, I run all my movies in jit.gl.texture, jit.gl.videoplane and
>>>> jit.gl.slab in 3D space. I also use your Shader Beta 1 (again, that
>>>> is awesome) for some color change and fade in/ fade out. The
>>>> problem is I ran over 10 different movies in jit.gl.videoplane and
>>>> I got over 5 different shaders run in the same window at the same
>>>> time. Sometimes I still got slow response and weird movie timing.
>>>> That’s why I think maybe I should use uyvy mode to save my poor ATI
>>>> Radeon 9600 as possible as I can.
>>>>
>>>> However, according to what you said, uyvy may bring me more problem
>>>> right? What should I do?
>>>>
>>>> best,
>>>>
>>>> CK
>>>
>>> v a d e //
>>>
>>> http://www.vade.info
>>> abstrakt.vade.info
>>>
>>>
>>>
>>>
>>>
>>>
>> —————————————————-
>>
>> Hi,
>>
>> Lucky I use Mac. If I set uyvy in slab I must first set uyvy mode
>> when I load movie right? I did set uyvy mode in slab but what I
>> got is a very weird colors. I guess I need to set colormode uyvy
>> in my loadmoviebank.js first before I set uyvy mode in
>> slab…..but I don’t know how to do it. I put movearray
>> [vcount].colormode = uyvy but I got error message…..I guess I
>> use the wrong command or I put the wrong place. How to solve this
>> problem?
>>
>>
>> thank you so much
>>
>> CK
>>
>

v a d e //

http://www.vade.info
abstrakt.vade.info


August 20, 2007 | 8:00 pm

In my tests, the image run through uyvy2rgba shader looks much
cleaner to my eye. I suggest going that route, even though it is a
bit ‘odd’.

You can also use the alphaglue shader to ‘add’ in an alpha channel
after the uyvy2rgba shader.

On Aug 20, 2007, at 3:42 PM, Joshua Kit Clayton wrote:

> FWIW, the last stage is only necessary if coming jit.qt.movie-
> >jit.gl.videoplane–i.e. @colormode uyvy is only necessary for the
> movie and the *first* GL object in a chain of OpenGL objects to
> which the video is sent. All subsequent GL objects in that chain
> will use the texture as provided (which once on the GPU is actually
> RGBA data. Colormode is only respected by objects receiving
> jit_matrix data, and are ignored when receiving a jit_gl_texture
> message).

v a d e //

http://www.vade.info
abstrakt.vade.info


August 21, 2007 | 3:16 am

Quote: jkc wrote on Mon, 20 August 2007 13:42
—————————————————-
>
> On Aug 20, 2007, at 12:24 PM, joshua goldberg wrote:
>
> > use jit.qt.movie @colormode uyvy, jit.gl.slab @colormode uyvy,
> > jit.gl.videoplane @colormode uyvy.
> >
> > use the colormode attribute with every single object that is
> > processing the movie + texture.
>
> FWIW, the last stage is only necessary if coming jit.qt.movie-
> >jit.gl.videoplane–i.e. @colormode uyvy is only necessary for the
> movie and the *first* GL object in a chain of OpenGL objects to which
> the video is sent. All subsequent GL objects in that chain will use
> the texture as provided (which once on the GPU is actually RGBA data.
> Colormode is only respected by objects receiving jit_matrix data, and
> are ignored when receiving a jit_gl_texture message).
>
> On Mac, you might want to use the cc.argb2uyvy.jxs shader anyway, if
> you want to sneak a slightly higher quality look with some color
> adjustment controls in the GPU conversion. If you use this shader,
> you do *not* use @colormode uyvy for the jit.gl.slab, but rather
> leave as colormode argb, and use @dimscale 2.
>
> This latter strategy is a little tricky, so you can ignore it for now
> if it confuses you, but in the long term worthwhile to figure out how
> we sneak UYVY data to the graphics card to get high performance/
> quality results on both platforms. Search the archives, look at the
> example patches, and check out the colorspaces tutorial for more info
> about this strategy as well as what UYVY data actually is and how it
> is used.
>
> -Joshua
>
—————————————————-

Wow, that–is–a–really–wonderful–lesson….

When I did the test, I found that cc.argb2uyvy.jxs does make movie more clear and a little bit brighter. If I use cc.argb2uyvy.lite.jxs the fps runs even faster. I didn’t know this secret weapon before.

Thank you so much Joshua :)

CK


August 21, 2007 | 3:29 am

the color shift/brightness is due to lack of gamma correction. You
can choose to correct with a slightly more ‘expensive’ shader than
the standard.

On Aug 20, 2007, at 11:16 PM, UCDMSRA wrote:

>
> Quote: jkc wrote on Mon, 20 August 2007 13:42
> —————————————————-
>>
>> On Aug 20, 2007, at 12:24 PM, joshua goldberg wrote:
>>
>>> use jit.qt.movie @colormode uyvy, jit.gl.slab @colormode uyvy,
>>> jit.gl.videoplane @colormode uyvy.
>>>
>>> use the colormode attribute with every single object that is
>>> processing the movie + texture.
>>
>> FWIW, the last stage is only necessary if coming jit.qt.movie-
>>> jit.gl.videoplane–i.e. @colormode uyvy is only necessary for the
>> movie and the *first* GL object in a chain of OpenGL objects to which
>> the video is sent. All subsequent GL objects in that chain will use
>> the texture as provided (which once on the GPU is actually RGBA data.
>> Colormode is only respected by objects receiving jit_matrix data, and
>> are ignored when receiving a jit_gl_texture message).
>>
>> On Mac, you might want to use the cc.argb2uyvy.jxs shader anyway, if
>> you want to sneak a slightly higher quality look with some color
>> adjustment controls in the GPU conversion. If you use this shader,
>> you do *not* use @colormode uyvy for the jit.gl.slab, but rather
>> leave as colormode argb, and use @dimscale 2.
>>
>> This latter strategy is a little tricky, so you can ignore it for now
>> if it confuses you, but in the long term worthwhile to figure out how
>> we sneak UYVY data to the graphics card to get high performance/
>> quality results on both platforms. Search the archives, look at the
>> example patches, and check out the colorspaces tutorial for more info
>> about this strategy as well as what UYVY data actually is and how it
>> is used.
>>
>> -Joshua
>>
> —————————————————-
>
> Wow, that–is–a–really–wonderful–lesson….
>
> When I did the test, I found that cc.argb2uyvy.jxs does make movie
> more clear and a little bit brighter. If I use
> cc.argb2uyvy.lite.jxs the fps runs even faster. I didn’t know this
> secret weapon before.
>
> Thank you so much Joshua :)
>
> CK
>

v a d e //

http://www.vade.info
abstrakt.vade.info


August 21, 2007 | 3:40 am

Hi Vade,

According to what you said, I can put alphaglue after argb2uyvy shader. Is it also possible to make more correct brightness? After the test I didn’t see any difference but I just want to make sure it. I don’t really understand what you means by "expensive" shader. Can you give me some example? like what shader is recommended?

thank you,

CK


August 21, 2007 | 4:00 am

expensive as it is more computationaly expensive. this is why the
‘lite’ shader is
faster (more FPS).

On Aug 20, 2007, at 11:40 PM, UCDMSRA wrote:

>
> Hi Vade,
>
> According to what you said, I can put alphaglue after argb2uyvy
> shader. Is it also possible to make more correct brightness? After
> the test I didn’t see any difference but I just want to make sure
> it. I don’t really understand what you means by "expensive" shader.
> Can you give me some example? like what shader is recommended?
>
> thank you,
>
> CK

v a d e //

http://www.vade.info
abstrakt.vade.info


August 21, 2007 | 4:17 am

Quote: andrewb@cycling74.com wrote on Mon, 20 August 2007 13:31
—————————————————-
> You probably need to put quotes on uyvy in the JS code, like so:
>
> movearray[vcount].colormode = "uyvy";
>
> since uyvy is not a JS variable, but needs to be treated like a string.
>
> Best,
> Andrew B.
>
—————————————————-

Hi,

you are right, when I put "uyvy" after movarray[vcount].colormode the error message doesn’t come out anymore……but……the color is totally different from the original movies. I am going to go crazy………..

Would you or somebody please check out what happened with this patch? I am actually only added the following line:

movarray[vcount].autostart = 0;
movarray[vcount].adapt = 1;
movarray[vcount].rate = 1;
movarray[vcount].colormode = "uyvy";

thank you so much

max v2;
#N vpatcher 267 142 1328 909;
#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P newex 72 163 52 196617 r subway;
#P outlet 247 513 15 0;
#P newex 412 62 48 196617 loadbang;
#P outlet 368 516 15 0;
#P newex 237 214 94 196617 prepend readfolder;
#P comment 239 308 124 196617 movie count;
#P button 237 167 15 0;
#P newex 237 190 75 196617 opendialog fold;
#P number 471 118 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P toggle 412 118 15 0;
#P number 236 269 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 412 166 42 196617 random;
#P newex 412 143 75 196617 qmetro 19500;
#P user ubumenu 114 271 100 196617 0 1 1 0;
#X add CKDaisy1PhotoJPEG.mov;
#X add CKDaisy2H264Matted.mov;
#X add CKDaisy3PhotoJPEG.mov;
#X add CKDaisy4PhotoJPEG.mov;
#X add CKDaisy5PhotoJPEG.mov;
#X add CKDaisy6PhotoJPEG.mov;
#X prefix_set 0 0 0;
#X pattrmode 1;
#P number 412 194 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P message 412 214 48 196617 index $1;
#P message 98 217 133 196617 readfolder ./patches/daisy;
#P user jit.pwindow 71 355 157 119 0 1 0 0 1 0;
#P user jit.fpsgui 72 501 60 196617 0;
#P newex 72 246 100 196617 js jsmoviebankck.js;
#P window linecount 6;
#P comment 244 357 198 196617 todo: ; colormode ; arguments for dimensions ; insert/add entries ; fix empty property problem on first load ; solve anything method problem;
#P window linecount 2;
#P comment 103 306 124 196617 output designed to populate umenu/ubumenu;
#P comment 503 178 125 196617 select which movie to play , randomly if desired.;
#P comment 224 536 74 196617 random bang out;
#P comment 351 537 64 196617 moviebank out;
#P connect 24 0 5 0;
#P fasten 20 0 5 0 242 238 77 238;
#P fasten 8 0 5 0 103 238 77 238;
#P fasten 9 0 5 0 417 238 77 238;
#P connect 5 0 7 0;
#P connect 7 0 6 0;
#P connect 22 0 8 0;
#P fasten 5 1 11 0 122 267 119 267;
#P connect 5 2 14 0;
#P connect 18 0 17 0;
#P connect 17 0 20 0;
#P fasten 12 0 23 0 375 160 375 343 462 343 462 461 233 461 233 500 252 500;
#P fasten 5 0 21 0 77 339 247 339 247 491 373 491;
#P connect 22 0 15 0;
#P connect 15 0 12 0;
#P connect 12 0 13 0;
#P connect 13 0 10 0;
#P fasten 11 0 10 0 119 301 466 301 466 189 417 189;
#P connect 10 0 9 0;
#P fasten 14 0 13 1 241 289 486 289 486 163 449 163;
#P connect 16 0 12 1;
#P pop;

Here is the js file:


August 21, 2007 | 6:09 am

Please ignore my post above. After I re-start my computer and Max, everything is ok. Weird, I know.

thanks


Viewing 28 posts - 1 through 28 (of 28 total)