Forums > MaxMSP

SOS, Help…….rewire problem with ProTools HD 7.3

September 30, 2007 | 9:12 pm

Hi,

I have played with this thing for the whole day but I don’t know what’s wrong with it. I open Max/MSP, I open DSP status and I choose audio output as "ad_rewire", MIDI channel 1. When I choose "ad_rewire", Max window shows the message

"Registered MaxMSP Rewire Device, Please restart your ReWire mixer application"

When I open ProTools HD, I can not see anything related Max/MSP in the insert instrument. When I tried to turn on the audio in Max, message shows "error: ad_rewirre: error starting audio. Is ReWire mixer running?"

I don’t know what is ReWire Mixer. I also don’t know what’s happened to my computer. I use Max/MSP 4.6.3 with ProTools HD 7.3.1

anybody know how to solve this problem please let me know. very appreciate it.

thanks

CK


September 30, 2007 | 10:49 pm

Hi,

I tried to use Sunflower so that I can rout my sound (8 channels) from Max to ProTools HD. However, I don’t know how to set Sunflower input in ProTools HD. It seems that ProTools HD only recognized 192. Can anybody give me a hint?

thank you so much


October 1, 2007 | 10:46 am


October 1, 2007 | 2:29 pm

Hi,

I follow your step but still can not see anything in the RTAS plug-in. I want to make sure one thing, is that "select your virtual outputs form max/MSP" means I select I/O mapping in DSP status of Max? Sorry but I don’t really understand what is you said "virtual outputs".

I spent whole night tried to get Max/MSP singal into PT but still not working. I install re-wire 1.7, my DSP status is set to sampling Rate 44100, I/O Vector 1024, Signal Vector 256, I/O mapping rewire 1~8, audio driver setup is just core audio.

I follow your step and do it again but still can not see anything in PT AudioTrack/Insert/RTAS, it is really weird that I can see my other software such as Reason, Maledyn……but just can not see Max.

Did I miss any thing or did I do something wrong?

thanks,

CK


October 1, 2007 | 3:00 pm

—————————————————-

Hi,

In case I misunderstood some parts of your direction. I wrote down what I did just now. Would you please let me know if I did something wrong or I misunderstood your words? Thanks. I am so tired and I just wanna go home…….

1. Open PT, at the same time also open a new session, set audio file .aiff, 41000, 24bit
2. Open Max, because last time when I close Max, it has already been set to ad_wire. So here I just switch back to core audio and turn the audio on
3. Switch back to ad_rewire again
4. When I switch back to ad_rewire, I/O map switch to rewire1~16 automatically, Max output channel 1&2 also become ReWire Out 1&2.
5. I don’t know if I need to open a max file to make sure audio is go through, but here I didn’t open any max file.
6. go back to PT, from "insert" section, select RTAS plug-ins/instruments/
7. Nothing happened……..:(

Please let me know if there is anyting wrong. Thanks, I just wanna go home……..

best,

CK


October 1, 2007 | 3:28 pm

hmmm, strange… before write you I made this procedure in the studio
to be sure!

but your audio dirver into the DSP setup has to have choice between:

Driver:
None, CoreAudio "Built-in Output", NonRealTime, ad_rewire

and your Dididesign audio driver.

if you don’t have "ad_rewire" you can’t have audio rewire outputs
from Max….. and nothing into PT…

try to reinstil Max maybe? and what I made everytime after the
instals -> DiskUtilities/The Repair Disk Permissions

virtuals outputs are the aoutputs in "I/O Mappings" you map 16 ReWire
outputs into 512 virtuals outputs you have in Max

hope it help you….


October 1, 2007 | 3:30 pm

Hi,

I found one thing. When I first turn audio on and then switch to ad_rewire (just as what you told me to do), Max window show a error message: "error: ad_rewire: error starting audio. Is ReWire mixer running?"

what is ReWire Mixer? I only open PT and Max, and this time I only open a new patch, make "cycle~ 440" sound and connect to dac~.

Would you please be able to tell me what’s going on?

thank you so much,

CK


October 1, 2007 | 3:35 pm


October 1, 2007 | 3:54 pm

I think the strange thing is, when I switch to ad_wire, audio will turn off automatically and a error message just keeping show in Max window. "error: ad_rewire: error starting audio. Is ReWire mixer running?" Of course ReWire mixer is supposed to running right?

So, I can not turn the audio on because everything when I tried to turn audio on it will switch back to off automatically and show the error message again.

Would you or anybody please tell me if you have any idea what makes this error happened?

thanks


October 1, 2007 | 6:23 pm

Hi,

Well, the most strange thing probably happened here……

I though it was because of the computer I am using right now. So I tried three different ProTools HD system in 3 different computers. The same error.

what excactly is ReWire Mixer? All the error message are the same, "Is ReWire Mixer running?"

Is there anybody has the same problem?

I tried to search this forum and use any information I can get from the search result, but non of the solution work.

Really appreciate any help.

thanks


October 1, 2007 | 8:24 pm

Hello,
First, you will need to make sure that you have the latest version of ReWire installed.

Next, you will need to follow these steps:
1. Turn off both MaxMSP and Pro Tools (along with any other Rewire apps that might be open)

2. Open up MaxMSP and open the DSP Status window.

3. Set the audio driver to ad_rewire. Do not turn on audio

4. Start up Pro Tools. Create a new project with an Audio Track.

5. From the track’s RTAS insert menu, select Instrument->MaxMSP

6. When the Rewire window pops up, select MaxMSP 1 as the input.

7. Go back into MaxMSP and open the Audiotester patch in extras.
8. Click the start message. Do you get any errors? If not, try sending a test tone to the outputs.

Let us know how that works for you.

Best,
Andrew B.


October 2, 2007 | 5:27 pm

Hi,

SO I follow your direction again,

Here I download rewire 1.7 and install it first.

Then I do what you told me to do.

and nothing happened…..still

I even use snapshot to catch the screen of the computer, please check it out with the attached file, it is really weird. In the picture you can see, ad_wire is on, audio is on, but still can not see anything in PD.

I also test other 3 PT HD system in my school, the same result. Because I really need to go home, I have already stayed at school for two nights, I installed Digital Performer 5. It only took me 10 seconds to catch signal from Max/MSP to Digital Performer. Now I can finally record 8 channels from Max but I still don’t understand why ad_wire doesn’t work with my schools system.

We use PT HD 7.3.1.

thanks


October 20, 2007 | 7:59 pm

Hello. I am having exactly the same problem. I used to do this quite
a lot two years ago, with pro tools LE 6.x. and the latest max at the
time. Now I am on 7.0 and 4.6 and basically max does not understand
PT as a mixer and PT does not see max in its Instruments (plug ins).
As This discussion ended on October the 1st I cannot tell whether
they found the answer to the problem.
Saludos
[Adina]

http://prof.usb.ve/aizarra/videos.html

On Oct 1, 2007, at 4:24 PM, Andrew Benson wrote:


April 9, 2008 | 2:30 am

This problem sounds exactly the same as what I am experiencing now.
Has anyone found a solution yet?
Our Pro Tools HD 7.3.1 system will not rewire max/MSP, yet our PT LE system will. Both systems have similar admin restrictions.
On launching ad_rewire in max, a max/msp rewire device alias file is created in application support, pointing to the max/msp rewire device in the cycling 74 folder, perhaps this is not pionting back to the pro tools plugin folder where the digirewire plugin resides.
I’m really keen to get this working, so if anyone has time to try out a few solutions, please post your findings here.
Thanks


August 8, 2009 | 8:07 pm

I was having the same problems too, only with PT LE 8.0 cs3 and Max 5.0.7.

Going through all the steps as outlined by Andrew B. led to no ReWire instrument insert to select in PT. I repaired permissions with Disk Utility as suggested by mihalic.imeb and had no better results. The post just prior to mine by TimL gave me a clue, so I tried putting a copy of the MSPReWireDevice.bundle (in Max5/Cycling ’74/ad) in the /Library/Application Support folder. This gave me a MaxMSP ReWire Instrument, but no audio was passing from Max. Then I made an alias of the MSPReWireDevice.bundle and put that in the Application Support folder and everything worked. Interestingly, the audio out from Max works even with the Audio Off in the DSP Status window.


July 31, 2014 | 9:25 am

Hi everyone i hope that this will help you. I worked out how to do it..

p.s. check out my website for more music related stuff: joeperkinsmusic.com

Here’s my tutorial:

This tutorial will demonstrate how to send multiple audio outputs from Max/MSP to Pro Tools, whilst still allowing Max MSP to have priority over your soundcard. The aim of this is so that live music performances in Max/MSP can be performed whilst simultaneously recording the performance into Pro Tools in individual tracks (This can be in stereo or multiple outputs such as 5.1). You will need to download ‘Soundflower’ from the following link:

http://cycling74.com/products/soundflower/

(Once installing the computer will need to be restarted)

Firstly, open up Max/MSP and go to ‘Max Audio Status’. Your Input device should be set to your desired audio interface or sound card. The Output device should be set to Soundflower (2ch) or (64ch) depending on whether you need stereo or multi-output sent to Pro Tools.

The next step is to open up sound flower in your applications. This should then reveal a Soundflower icon next to the search bar at the top right hand side of your desktop. Click on this icon and a drop-down list of sound card options will appear. Choose your desired Audio interface from the list. (There will also be an option for 2ch or 64ch. Choose accordingly).

Type ‘Audio MIDI Setup’ into your search-bar, and click on the application. There will be a drop-down list of different options, including ‘Pro Tools Aggregate I/O’. Click on here and check/tick the box to enable Soundflower to coincide with Pro Tools.

The final step is to open Pro Tools with a new audio track/s and select the desired/predetermined audio outputs from Soundflower as the Inputs for the audio track in Pro Tools.

you will then need to open up the peripherals prefgerances in Prto tools to select the correct inputs.

These steps will enable you to unobtrusively record multiple outputs from Max MSP to Pro Tools on Mac.

Joe Perkins


Viewing 16 posts - 1 through 16 (of 16 total)