Forums > Misc

Soundflower feedback/phasing sound problem

September 5, 2011 | 6:50 pm

I’m sorry, I’m sure this has been posted before, I just don’t seem to be able to find an appropriate answer.

I love the idea of soundflower. I’m just trying to do simple recording of audio streams for learning music. Doesn’t have to be great quality.

So I’m starting by just recording the source from itunes, recording with Abelton Live. I set the input and output in the sound system prefs to soundflower 2ch.

I get in level in Live, but when I record, it has this sort of phasing sound, as though it’s two audio sources slightly apart.

When I record with tracktion, it sort of ramps up, and then redlines, as though it’s a feedback loop.


October 14, 2011 | 3:51 am

i had the same problem. had to take my macbook in for repair because of a hard drive failure. when i got it back i reloaded all my goodies. when i went to sample some sounds off the net like i always did with the system pref set input/output to soundflower and soundflower set to my soundcard it was creating a dual audio signal creating the phase. so it was playing audio through my speakers without the need for me arming an audio track to record that signal (something it never did before)plus the recorded signal on top of it. usually i would have no audio if a youtube video was playing until i armed the track. this time it played without the need. so i went to the soundflower dropdown and set it to my macbooks built in output instead of my soundcard and that fixed the issue.

so it should look like this
system pref>sound>output/soundflower 2 or 16.
system pref>sound>input/soundflower 2 or 16
soundflower dropdown set to built in audio not your soundcard
ableton live>preferences>audio>input soundflower 2 or 16
ableton live>preferences>audio>output>soundcard


March 10, 2013 | 7:32 pm

I searched for hours trying to find a solution to this issue. A friend suggested an idea that he had been shown. Setup soundflower as a midi simultaneously with your regular output. Therefore instead of routing through soundflower for your output (which seems to cause the issue), it routes each as their own output. So far seems to be working on my recording meters without the overdrive static. Here is the how to on this.

http://apple.stackexchange.com/questions/50904/if-we-use-soundflower-to-record-the-systems-audio-output-then-we-cant-hear-it

Also, if you are looking for more control I found software from Prosoft that allows for audio adjustment using hear or individual app volume control through hear or soundbunny.

http://www.prosofteng.com/products/

Hope this helps everyone!

~Epoch Dream Productions


Viewing 3 posts - 1 through 3 (of 3 total)