Forums > MaxMSP

Soundflower on Intel error

February 23, 2006 | 5:31 am

I just recieved my new MacBook Pro and I went to install all my favorite programs and I noticed that Soundflower doesn’t work.

After some troubleshooting I recieve this error when I try to load the Extension.

$ sudo kextload -t Soundflower.kext

kernel extension Soundflower.kext has problems:
Validation failures
{
"Kext claims an executable file but it doesn’t exist" = true
}

I downloaded the source and opened it in Xcode I was able to build the project agains despite some errors concerning Absolute time. But the freshly built kext returns the same error when loaded.

I rely only Soundflower to record my podcast and would greatly apprecate any help.

Thanks
Ben


February 23, 2006 | 6:24 am

Make sure you are building this Universal. I heard there’s a
checkbox in Xcode…
When you run the file command on the kext, does it say the binary has
2 arch’s?
I’m also not convinced that there aren’t any endian issues.

_Mark


February 23, 2006 | 12:55 pm

Thanks for the quick response but it appears that I do have Xcode configured for Intel binaries.

http://bdraw.cjb.net/~ben/SndBuild.png


February 25, 2006 | 9:52 am

I haven’t got the ability to help, but I have an iMacIntel and miss soundflower very much too.

I really hope someone (bjdraw?) will find a solution and can build a Universal version… and make it accessible for incapable guys, like me.

Good luck!!


March 31, 2006 | 10:07 pm

Here is a website that will tell you how to build Soundflower for Intel. You have to have Xcode installed and you need the source code. (both are free)

http://makeashorterlink.com/?M11D213EC


Viewing 5 posts - 1 through 5 (of 5 total)